ادراج كائن في جدول بيانات Excel

ملاحظة: إننا نرغب في تزويدك بأحدث محتوى تعليمات لدينا بأسرع ما يمكن، وبلغتك الخاصة. وقد تمت ترجمة هذه الصفحة آلياً، وقد تحتوي على أخطاء نحوية أو أخطاء تتعلق بالدقة. إن هدفنا هو أن يكون هذا المحتوى مفيداً لك. هل يمكنك إخبارنا إذا ما كانت المعلومات مفيدة لك في أسفل هذه الصفحة؟ فيما يلي المقالة باللغة الإنجليزية لتكون مرجعاً سهلاً لك.

يمكنك استخدام ارتباطات الكائنات وتضمينها (OLE) لتضمين محتوي من برامج أخرى ، مثل Word أو Excel.

يتم دعم OLE بواسطة العديد من البرامج المختلفة ، ويتم استخدام OLE لجعل المحتوي الذي تم إنشاؤه في أحد البرامج متوفرا في برنامج آخر. علي سبيل المثال ، يمكنك ادراج مستند Office Word في مصنف Office Excel. للاطلاع علي أنواع المحتويات التي يمكنك ادراجها ، انقر فوق كائن في المجموعة نص ضمن علامة التبويب ادراج . لا تظهر الا البرامج المثبتة علي الكمبيوتر الخاص بك والتي تدعم كائنات OLE في مربع نوع الكائن .

إذا قمت بنسخ المعلومات بين Excel أو اي برنامج يعتمد OLE ، مثل Word ، فيمكنك نسخ المعلومات اما كعنصر مرتبط أو عنصر مضمّن. الاختلافات الرئيسية بين الكائنات المرتبطة والكائنات المضمنة هي حيث يتم تخزين البيانات وكيفيه تحديث الكائن بعد وضعه في الملف الوجهة. يتم تخزين الكائنات المضمنة في المصنف الذي تم ادراجها فيه ، ولا يتم تحديثها. تظل الكائنات المرتبطة كملفات منفصلة ، ويمكن تحديثها.

الكائنات المرتبطة والمضمنة في مستند

العناصر المرتبطة والمضمنة في مستند Office for Windows

1. لا يحتوي كائن مضمن علي اتصال بالملف المصدر.

2. يرتبط كائن مرتبط بالملف المصدر.

3. يقوم الملف المصدر بتحديث الكائن المرتبط.

متى يجب استخدام الكائنات المرتبطة

إذا كنت تريد تحديث المعلومات الموجودة في الملف الوجهة ك عند تغيير البيانات الموجودة في الملف المصدر ، فاستخدم الكائنات المرتبطة.

باستخدام كائن مرتبط ، تبقي المعلومات الاصليه مخزنه في الملف المصدر. يعرض الملف الوجهة تمثيل المعلومات المرتبطة ولكنه يخزن فقط موقع البيانات الاصليه (والحجم إذا كان العنصر عبارة عن عنصر مخطط Excel). يجب ان يظل الملف المصدر متوفرا علي الكمبيوتر أو الشبكة للمحافظة علي الارتباط بالبيانات الاصليه.

يمكن تحديث المعلومات المرتبطة تلقائيا إذا قمت بتغيير البيانات الاصليه في الملف المصدر. علي سبيل المثال ، إذا قمت بتحديد فقره في مستند Word ، ثم قمت بلصق الفقرة ككائن مرتبط في مصنف Excel ، فيمكنك تحديث المعلومات في Excel إذا قمت بتغيير المعلومات الموجودة في مستند Word.

متى يجب استخدام الكائنات المضمنة

إذا كنت لا تريد تحديث البيانات المنسوخة عند تغييرها في الملف المصدر ، فاستخدم كائنا مضمنا. يتم تضمين إصدار المصدر بالبالكامل في المصنف. إذا قمت بنسخ المعلومات ككائن مضمن ، سيتطلب الملف الوجهة مساحة اضافيه علي القرص عما إذا كنت تقوم بربط المعلومات.

عندما يقوم أحد المستخدمين بفتح الملف علي كمبيوتر آخر ، يمكنه عرض الكائن المضمن دون الوصول إلى البيانات الاصليه. بما ان الكائن المضمن لا يحتوي علي ارتباطات إلى الملف المصدر ، فلن يتم تحديث الكائن إذا قمت بتغيير البيانات الاصليه. لتغيير كائن مضمن ، انقر نقرا مزدوجا فوق العنصر لفتحه وتحريره في البرنامج المصدر. يجب تثبيت البرنامج المصدر (أو اي برنامج آخر قادر علي تحرير العنصر) علي الكمبيوتر.

تغيير الطريقة التي يظهر بها عنصر OLE

يمكنك عرض عنصر مرتبط أو عنصر مضمّن في مصنف تماما كما يظهر في البرنامج مصدر أو كايقونه. إذا كان سيتم عرض المصنف عبر الإنترنت ، ولم تكن تخطط لطباعه المصنف ، يمكنك عرض العنصر كايقونه. يؤدي ذلك إلى تصغير مقدار مساحة العرض التي يشغلها الكائن. يمكن للعارضين الذين يرغبون في عرض المعلومات النقر نقرا مزدوجا فوق الايقونه.

تضمين عنصر في ورقه عمل

  1. انقر داخل خليه جدول البيانات الذي تريد ادراج الكائن فيه.

  2. علي علامة التبويب ادراج ، في المجموعة نص ، انقر فوق عنصر أيقونه عنصر علي الشريط .
    إدراج عنصر

  3. في مربع الحوار كائن ، انقر فوق علامة التبويب إنشاء من ملف .

  4. انقر فوق استعراض، وحدد الملف الذي تريد ادراجه.

  5. إذا أردت ادراج أيقونه في جدول البيانات بدلا من إظهار محتويات الملف ، فحدد خانه الاختيار عرض كايقونه . إذا لم تحدد اي خانه اختيار ، سيعرض Excel الصفحة الاولي من الملف. في كلتا الحالتين ، يتم فتح الملف بالنقر نقرا مزدوجا. انقر فوق موافق.

    ملاحظة: بعد أضافه الايقونه أو الملف ، يمكنك سحبه وإفلاته في اي مكان في ورقه العمل. يمكنك أيضا تغيير حجم الايقونه أو الملف باستخدام مقابض تغيير الحجم. للبحث عن المقابض ، انقر فوق الملف أو الايقونه مره واحده.

ادراج ارتباط إلى ملف

قد تحتاج فقط إلى أضافه ارتباط إلى العنصر بدلا من تضمينه بالبالكامل. يمكنك القيام بذلك إذا كان المصنف والكائن الذي تريد اضافتهما مخزنين علي موقع SharePoint أو محرك أقراص مشترك علي الشبكة أو موقع مماثل ، وإذا كان موقع الملفات سيظل كما هو. هذا مفيد إذا كان الكائن المرتبط نظر يتغير لان الارتباط يفتح دائما المستند الأحدث.

ملاحظة: إذا قمت بنقل الملف المرتبط إلى موقع آخر ، فلن يعمل الارتباط بعد الآن.

  1. انقر داخل خليه جدول البيانات الذي تريد ادراج الكائن فيه.

  2. علي علامة التبويب ادراج ، في المجموعة نص ، انقر فوق عنصر أيقونه عنصر علي الشريط .
    إدراج عنصر

  3. انقر فوق علامة التبويب إنشاء من ملف .

  4. انقر فوق استعراض، ثم حدد الملف الذي تريد ربطه.

  5. حدد خانه الاختيار ارتباط بالملف ، ثم انقر فوق موافق.

إنشاء عنصر جديد من داخل Excel

يمكنك إنشاء كائن جديد بالبالكامل استنادا إلى برنامج آخر دون مغادره المصنف. علي سبيل المثال ، إذا أردت أضافه شرح أكثر تفصيلا إلى المخطط أو الجدول ، فيمكنك إنشاء مستند مضمن ، مثل ملف Word أو PowerPoint ، في Excel. يمكنك اما تعيين الكائن لعرضه مباشره في ورقه عمل أو أضافه أيقونه تفتح الملف.

هذا العنصر المضمّن عبارة عن مستند Word.
  1. انقر داخل خليه جدول البيانات الذي تريد ادراج الكائن فيه.

  2. علي علامة التبويب ادراج ، في المجموعة نص ، انقر فوق عنصر أيقونه عنصر علي الشريط .
    إدراج عنصر

  3. علي علامة التبويب إنشاء جديد ، حدد نوع الكائن الذي تريد ادراجه من القائمة المعروضة. إذا أردت ادراج أيقونه في جدول البيانات بدلا من العنصر نفسه ، فحدد خانه الاختيار عرض كايقونه .

  4. انقر فوق موافق. استنادا إلى نوع الملف الذي تقوم بادراجه ، اما ان يتم فتح نافذه برنامج جديده أو تظهر نافذه تحرير ضمن Excel.

  5. قم بإنشاء الكائن الجديد الذي تريد ادراجه.

    عند الانتهاء ، إذا قام Excel بفتح نافذه برنامج جديده قمت فيها بإنشاء الكائن ، يمكنك العمل مباشره داخلها.

    يمكنك تحرير مستند Word المضمّن مباشرةً في Excel.

    عند الانتهاء من عملك في النافذة ، يمكنك القيام بمهام أخرى من دون حفظ الكائن المضمن. عند إغلاق المصنف ، سيتم حفظ العناصر الجديدة تلقائيا.

    ملاحظة: بعد أضافه الكائن ، يمكنك سحبه وإفلاته في اي مكان علي ورقه عمل Excel. يمكنك أيضا تغيير حجم الكائن باستخدام مقابض تغيير الحجم. للبحث عن المقابض ، انقر فوق العنصر مره واحده.

تضمين عنصر في ورقه عمل

  1. انقر داخل خليه جدول البيانات الذي تريد ادراج الكائن فيه.

  2. على علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    يوجد الخيار «عنصر» في علامة التبويب «إدراج».
  3. انقر فوق علامة التبويب إنشاء من ملف .

    علامة التبويب "إنشاء من ملف" في مربع الحوار «عنصر».
  4. انقر فوق استعراض، وحدد الملف الذي تريد ادراجه.

  5. إذا أردت ادراج أيقونه في جدول البيانات بدلا من إظهار محتويات الملف ، فحدد خانه الاختيار عرض كايقونه . إذا لم تحدد اي خانه اختيار ، سيعرض Excel الصفحة الاولي من الملف. في كلتا الحالتين ، يتم فتح الملف بالنقر نقرا مزدوجا. انقر فوق موافق.

    ملاحظة: بعد أضافه الايقونه أو الملف ، يمكنك سحبه وإفلاته في اي مكان في ورقه العمل. يمكنك أيضا تغيير حجم الايقونه أو الملف باستخدام مقابض تغيير الحجم. للبحث عن المقابض ، انقر فوق الملف أو الايقونه مره واحده.

ادراج ارتباط إلى ملف

قد تحتاج فقط إلى أضافه ارتباط إلى العنصر بدلا من تضمينه بالبالكامل. يمكنك القيام بذلك إذا كان المصنف والكائن الذي تريد اضافتهما مخزنين علي موقع SharePoint أو محرك أقراص مشترك علي الشبكة أو موقع مماثل ، وإذا كان موقع الملفات سيظل كما هو. هذا مفيد إذا كان الكائن المرتبط نظر يتغير لان الارتباط يفتح دائما المستند الأحدث.

ملاحظة: إذا قمت بنقل الملف المرتبط إلى موقع آخر ، فلن يعمل الارتباط بعد الآن.

  1. انقر داخل خليه جدول البيانات الذي تريد ادراج الكائن فيه.

  2. على علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    يوجد الخيار «عنصر» في علامة التبويب «إدراج».
  3. انقر فوق علامة التبويب إنشاء من ملف .

  4. انقر فوق استعراض، ثم حدد الملف الذي تريد ربطه.

  5. حدد خانه الاختيار ارتباط بالملف ، ثم انقر فوق موافق.

    من علامة التبويب «إنشاء من ملف»، حدد «ارتباط بالملف.»

إنشاء عنصر جديد من داخل Excel

يمكنك إنشاء كائن جديد بالبالكامل استنادا إلى برنامج آخر دون مغادره المصنف. علي سبيل المثال ، إذا أردت أضافه شرح أكثر تفصيلا إلى المخطط أو الجدول ، فيمكنك إنشاء مستند مضمن ، مثل ملف Word أو PowerPoint ، في Excel. يمكنك اما تعيين الكائن لعرضه مباشره في ورقه عمل أو أضافه أيقونه تفتح الملف.

هذا العنصر المضمّن عبارة عن مستند Word.
  1. انقر داخل خليه جدول البيانات الذي تريد ادراج الكائن فيه.

  2. على علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    يوجد الخيار «عنصر» في علامة التبويب «إدراج».
  3. علي علامة التبويب إنشاء جديد ، حدد نوع الكائن الذي تريد ادراجه من القائمة المعروضة. إذا أردت ادراج أيقونه في جدول البيانات بدلا من العنصر نفسه ، فحدد خانه الاختيار عرض كايقونه .

    علامة التبويب «إنشاء جديد» في مربع الحوار «عنصر».
  4. انقر فوق موافق. استنادا إلى نوع الملف الذي تقوم بادراجه ، اما ان يتم فتح نافذه برنامج جديده أو تظهر نافذه تحرير ضمن Excel.

  5. قم بإنشاء الكائن الجديد الذي تريد ادراجه.

    عند الانتهاء ، إذا قام Excel بفتح نافذه برنامج جديده قمت فيها بإنشاء الكائن ، يمكنك العمل مباشره داخلها.

    يمكنك تحرير مستند Word المضمّن مباشرةً في Excel.

    عند الانتهاء من عملك في النافذة ، يمكنك القيام بمهام أخرى من دون حفظ الكائن المضمن. عند إغلاق المصنف ، سيتم حفظ العناصر الجديدة تلقائيا.

    ملاحظة: بعد أضافه الكائن ، يمكنك سحبه وإفلاته في اي مكان علي ورقه عمل Excel. يمكنك أيضا تغيير حجم الكائن باستخدام مقابض تغيير الحجم. للبحث عن المقابض ، انقر فوق العنصر مره واحده.

ربط محتوي أو تضمينه من برنامج آخر باستخدام OLE

يمكنك ربط محتوي أو جزء من برنامج آخر أو تضمينه.

إنشاء ارتباط إلى محتوي من برنامج آخر

  1. انقر فوق ورقه العمل التي تريد وضع العنصر مرتبط فيها.

  2. على علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    صورة شريط Excel

  3. انقر فوق علامة التبويب إنشاء من ملف .

  4. في المربع اسم الملف ، اكتب اسم الملف ، أو انقر فوق استعراض للتحديد من القائمة.

  5. حدد خانه الاختيار ارتباط بالملف .

  6. قم بأحد الإجراءات التالية:

    • لعرض المحتوي ، قم بإلغاء تحديد خانه الاختيار عرض كايقونه .

    • لعرض أيقونه ، حدد خانه الاختيار عرض كايقونه . بشكل اختياري ، لتغيير صوره الايقونه أو التسمية الافتراضية ، انقر فوق تغيير الايقونه، ثم انقر فوق الايقونه التي تريدها من قائمه الأيقونات ، أو اكتب تسميه في مربع التسمية التوضيحية.

    ملاحظة: لا يمكنك استخدام الأمر كائن لادراج رسومات وأنواع معينه من الملفات. لادراج رسم أو ملف ، علي علامة التبويب ادراج ، في المجموعة رسومات توضيحيه ، انقر فوق صوره.

تضمين محتوي من برنامج آخر

  1. انقر فوق ورقه العمل التي تريد وضع العنصر مضمّن فيها.

  2. على علامة التبويب إدراج، في المجموعة نص، انقر فوق كائن.

    صورة شريط Excel

  3. إذا لم يكن المستند موجودا بالفعل ، فانقر فوق علامة التبويب إنشاء جديد . في المربع نوع الكائن ، انقر فوق نوع الكائن الذي تريد إنشاءه.

    إذا كان المستند موجودا بالفعل ، فانقر فوق علامة التبويب إنشاء من ملف . في المربع اسم الملف ، اكتب اسم الملف ، أو انقر فوق استعراض للتحديد من القائمة.

  4. قم بإلغاء تحديد خانه الاختيار ارتباط بالملف .

  5. قم بأحد الإجراءات التالية:

    • لعرض المحتوي ، قم بإلغاء تحديد خانه الاختيار عرض كايقونه .

    • لعرض أيقونه ، حدد خانه الاختيار عرض كايقونه . لتغيير صوره الايقونه أو التسمية الافتراضية ، انقر فوق تغيير الايقونه، ثم انقر فوق الايقونه التي تريدها من قائمه الأيقونات ، أو اكتب تسميه في مربع التسمية التوضيحية.

ربط محتوي جزئي أو تضمينه من برنامج آخر

  1. من برنامج آخر غير Excel ، حدد المعلومات التي تريد نسخها كمرتبطة أو عنصر مضمّن.

  2. ضمن علامة التبويب الصفحة الرئيسية، في المجموعة الحافظة، انقر فوق نسخ.

    المجموعة "الحافظة" ضمن علامة التبويب "الشريط الرئيسي"

  3. قم بالتبديل إلى ورقه العمل التي تريد وضع المعلومات فيها ، ثم انقر فوق المكان الذي تريد ظهور المعلومات فيه.

  4. على علامة التبويب الشريط الرئيسي، في مجموعة الحافظة انقر فوق السهم الموجود أسفل لصق، ثم انقر فوق لصق خاص.

  5. قم بأحد الإجراءات التالية:

    • للصق المعلومات ككائن مرتبط ، انقر فوق لصق الارتباط.

    • للصق المعلومات ككائن مضمن ، انقر فوق لصق. في المربع بصيغه ، انقر فوق الإدخال الذي يحتوي علي الكلمة "كائن" في اسمه. علي سبيل المثال ، إذا قمت بنسخ المعلومات من مستند Word ، فانقر فوق عنصر مستند Microsoft Word.

تغيير الطريقة التي يظهر بها عنصر OLE

  1. انقر بزر الماوس الأيمن فوق الايقونه أو الكائن ، وأشر إلىكائننوع الكائن(علي سبيل المثال ، عنصر مستند) ، ثم انقر فوق تحويل.

  2. قم بأحد الإجراءات التالية:

    • لعرض المحتوي ، قم بإلغاء تحديد خانه الاختيار عرض كايقونه .

    • لعرض أيقونه ، حدد خانه الاختيار عرض كايقونه . بشكل اختياري ، يمكنك تغيير صوره الايقونه أو التسمية الافتراضية. للقيام بذلك ، انقر فوق تغيير الايقونه، ثم انقر فوق الايقونه التي تريدها من قائمه الأيقونات ، أو اكتب تسميه في المربع التسمية التوضيحية.

التحكم في تحديثات الكائنات المرتبطة

يمكنك تعيين الارتباطات إلى البرامج الأخرى ليتم تحديثها بالطرق التالية: تلقائيا ، عندما تفتح الملف الوجهة; يدويا ، عندما تريد الاطلاع علي البيانات السابقة قبل التحديث باستخدام البيانات الجديدة من الملف المصدر ؛ أو عند طلب التحديث بشكل خاص ، بغض النظر عما إذا كان التحديث التلقائي أو اليدوي قيد التشغيل.

تعيين ارتباط إلى برنامج آخر لتحديثه يدويا

  1. على علامة التبويب بيانات، في مجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    صورة شريط Excel

    ملاحظة: لا يتوفر الأمر " تحرير الارتباطات " إذا كان الملف لا يحتوي علي ارتباطات إلى ملفات أخرى.

  2. انقر فوق الكائن المرتبط الذي تريد تحديثه من القائمة المصدر. يعني وجود A في عمود التحديث ان الارتباط تلقائي ، ويعني الأمر M في عمود التحديث ان الارتباط قد تم تعيينه إلى التحديث اليدوي .

    تلميح: لتحديد كائنات مرتبطة متعددة، اضغط باستمرار على CTRL أثناء النقر فوق كل كائن مرتبط. لتحديد كافة الكائنات المرتبطة ، اضغط علي CTRL + A.

  3. لتحديث كائن مرتبط فقط عند النقر فوق تحديث القيم، انقر فوق يدوي.

تعيين ارتباط إلى برنامج آخر ليتم تحديثه تلقائيا

  1. على علامة التبويب بيانات، في مجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    صورة شريط Excel

    ملاحظة: لا يتوفر الأمر " تحرير الارتباطات " إذا كان الملف لا يحتوي علي ارتباطات إلى ملفات أخرى.

  2. انقر فوق الكائن المرتبط الذي تريد تحديثه من القائمة المصدر. يعني وجود A في عمود التحديث ان الارتباط سيتم تحديثه تلقائيا ، ويعني الحرف M في عمود التحديث انه يجب تحديث الارتباط يدويا.

    تلميح: لتحديد كائنات مرتبطة متعددة، اضغط باستمرار على CTRL أثناء النقر فوق كل كائن مرتبط. لتحديد كافة الكائنات المرتبطة ، اضغط علي CTRL + A.

  3. انقر فوق موافق.

المشكلة: لا يمكنني تحديث الارتباطات التلقائية علي ورقه العمل الخاصة بي

يمكن تجاوز الخيار "تلقائي " بواسطة خيار " تحديث الارتباطات إلى المستندات الأخرى " في Excel.

للتاكد من امكانيه تحديث الارتباطات التلقائية لعناصر OLE تلقائيا:

  1. انقر فوق زر Microsoft Office صورة زر Office ، وانقر فوق خيارات Excel، ثم انقر فوق الفئة خيارات متقدمة .

  2. ضمن عند حساب هذا المصنف، تاكد من تحديد خانه الاختيار تحديث الارتباطات إلى المستندات الأخرى .

تحديث ارتباط إلى برنامج آخر الآن

  1. على علامة التبويب بيانات، في مجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    صورة شريط Excel

    ملاحظة: إذا لم يتضمّن الملف أية معلومات مرتبطة، فلن يتوفر الأمر تحرير الارتباطات.

  2. انقر فوق الكائن المرتبط الذي تريد تحديثه من القائمة المصدر.

    تلميح: لتحديد كائنات مرتبطة متعددة، اضغط باستمرار على CTRL أثناء النقر فوق كل كائن مرتبط. لتحديد كافة الكائنات المرتبطة ، اضغط علي CTRL + A.

  3. انقر فوق تحديث القيم.

تحرير محتوي من برنامج OLE

اثناء وجودك في Excel ، يمكنك تغيير المحتوي المرتبط أو المضمن من برنامج آخر.

تحرير كائن مرتبط في البرنامج المصدر

  1. على علامة التبويب بيانات، في مجموعة الاتصالات، انقر فوق تحرير الارتباطات.

    صورة شريط Excel

    ملاحظة: إذا لم يتضمّن الملف أية معلومات مرتبطة، فلن يتوفر الأمر تحرير الارتباطات.

  2. في القائمة الملف المصدر ، انقر فوق المصدر الخاص بالعنصر مرتبط ، ثم انقر فوق فتح المصدر.

  3. قم باجراء التغييرات التي تريدها علي الكائن المرتبط.

  4. قم بإنهاء برنامج مصدر للعودة إلى الملف الوجهة.

تحرير كائن مضمن في البرنامج المصدر

  1. انقر نقرا مزدوجا فوق عنصر مضمّن لفتحه.

  2. قم باجراء التغييرات التي تريدها علي الكائن.

  3. إذا كنت تقوم بتحرير الكائن في مكان داخل البرنامج المفتوح ، فانقر في اي مكان خارج الكائن للعودة إلى الملف الوجهة.

    إذا قمت بتحرير الكائن المضمن في البرنامج المصدر في نافذه منفصلة ، فقم بإنهاء البرنامج المصدر للعودة إلى الملف الوجهة.

ملاحظة: يؤدي النقر نقرا مزدوجا فوق بعض الكائنات المضمنة ، مثل مقاطع الفيديو والصوت ، إلى تشغيل الكائن بدلا من فتح برنامج ما. لتحرير أحد هذه الكائنات المضمنة ، انقر بزر الماوس الأيمن فوق الايقونه أو الكائن ، وأشر إلىكائننوع الكائن(علي سبيل المثال ، كائن قصاصه الوسائط) ، ثم انقر فوق تحرير.

تحرير كائن مضمن في برنامج غير البرنامج المصدر

  1. حدد عنصر مضمّن الذي تريد تحريره.

  2. انقر بزر الماوس الأيمن فوق الايقونه أو الكائن ، وأشر إلىكائننوع الكائن(علي سبيل المثال ، عنصر مستند) ، ثم انقر فوق تحويل.

  3. قم بأحد الإجراءات التالية:

    • لتحويل الكائن المضمن إلى النوع الذي تحدده في القائمة ، انقر فوق تحويل إلى.

    • لفتح العنصر المضمن كالنوع الذي تحدده في القائمة دون تغيير نوع الكائن المضمن ، انقر فوق تنشيط.

تحديد عنصر OLE باستخدام لوحه المفاتيح

  1. اضغط علي CTRL + G لعرض مربع الحوار الانتقال إلى .

  2. انقر فوق خاص، وحدد كائنات، ثم انقر فوق موافق.

  3. اضغط علي المفتاح TAB حتى يتم تحديد العنصر الذي تريده.

  4. اضغط علي SHIFT + F10.

  5. أشر إلى كائن كائن أو مخطط، ثم انقر فوق تحرير.

المشكلة: عند النقر نقرا مزدوجا فوق كائن مرتبط أو مضمن ، تظهر الرسالة "لا يمكن التحرير"

تظهر هذه الرسالة عندما لا يمكن فتح الملف المصدر أو برنامج مصدر.

تاكد من ان البرنامج المصدر متوفر     إذا لم يكن البرنامج المصدر مثبتا علي الكمبيوتر ، فقم بتحويل الكائن إلى تنسيق ملف البرنامج الذي قمت بتثبيته.

التاكد من ان الذاكرة كافيه     تاكد من ان لديك ذاكره كافيه لتشغيل البرنامج المصدر. اغلق البرامج الأخرى لتحرير الذاكرة ، إذا لزم الأمر.

إغلاق كافة مربعات الحوار     إذا كان البرنامج المصدر قيد التشغيل ، فتاكد من انه لا يحتوي علي اي مربعات حوار مفتوحة. قم بالتبديل إلى البرنامج المصدر ، واغلق مربعات الحوار المفتوحة.

إغلاق الملف المصدر     إذا كان الملف المصدر كائنا مرتبطا ، فتاكد من عدم فتح المستخدم الآخر.

تاكد من عدم تغيير اسم الملف المصدر     إذا كان الملف المصدر الذي تريد تحريره عبارة عن كائن مرتبط ، فتاكد من انه يحمل الاسم نفسه الذي تم عند إنشاء الارتباط فيه وانه لم يتم نقله. حدد العنصر المرتبط ، ثم انقر فوق الأمر " تحرير الارتباطات " في المجموعة "الاتصالات" ضمن علامة التبويب " بيانات " للاطلاع علي اسم الملف المصدر. إذا تمت أعاده تسميه الملف المصدر أو نقله ، فاستخدم الزر تغيير المصدر في مربع الحوار تحرير الارتباطات لتحديد موقع الملف المصدر وأعاده توصيل الارتباط.

هل تحتاج إلى مزيد من المساعدة؟

ويمكنك دائماً الاستفسار من أحد الخبراء في مجتمع Excel‏ التقني،أو الحصول على الدعم من خلال إجابات المجتمع،أو اقتراح ميزة جديدة أو تحسين عن طريق ‏Excel User Voice‏.

تعزيز مهارات Office
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Office Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×