تخطي إلى المحتوى الرئيسي
الدعم
تسجيل الدخول باستخدام حساب Microsoft
تسجيل الدخول أو إنشاء حساب.
مرحباً،
تحديد استخدام حساب مختلف!
لديك حسابات متعددة
اختر الحساب الذي تريد تسجيل الدخول باستخدامه.

الأعراض

عند محاولة ترقية جهاز الكمبيوتر الخاص بك من نظام التشغيل Windows Vista إلى ويندوز 7، توقف عملية الترقية استجابة 62 في المائة إلى ما لا نهاية.

بالإضافة إلى ذلك، يقوم Windows بإنشاء ملف يسمى system_drive: \$WINDOWS.~BT\Sources\Panther\setupact.log. في حالة فحص محتويات الملف، لاحظت المعلومات التالية:

<date> <time>, Info MIG IPostApply::ApplySuccess for Plugin={ServerPath="%windir%\system32\migration\IphlpsvcMigPlugin.dll", CLSID={ade10465-2a43-454e-b0a7-3f220a61bd03}, ThreadingModel=Apartment} - Working directory: C:\$UPGRADE.~OS\OnlineUpgradeApplyWork\srcworking\agentmgr\CCSIAgent\005AE0CB<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: Performing upgrade actions for all protocols
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, InterfaceCount = 0
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.Incrementing interface count
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, New value of *InterfaceCount = 1
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: RegEnumKeyEx return 259. key name: {AC049C3C-9B90-41A7-9385-DC5AD3E656F0}.new index: 2
Warning [0x080b50] MIG AsyncCallback_ApplyStatus: Progress appears to be stuck. Current progress: 62

ملاحظة: بشكل عام، يكون محرك الأقراص هو محرك الأقراص C في الكمبيوتر.

السبب

تحدث هذه المشكلة نظراً لتوقف خدمة إيفلبسفك عن الاستجابة أثناء الترقية.

ملاحظة: خدمات أخرى قد تؤدي مشكلة فيه عملية الترقية يتوقف عن الاستجابة في 62 في المائة.

الحل

هام: قم استخدام هذا الحل إذا توقف الترقية عن الاستجابة بنسبة خلاف 62% أو إذا لم تكن إدخالات سجل تسجيل . لمزيد من المعلومات حول كيفية فتح الملف Seupact.log، راجع مقطع معلومات إضافية .

لنقوم بإصلاح هذه المشكلة، انتقل إلى قسم "إصلاح ذلك بالنسبة لي". إذا كنت تفضل إصلاح هذه المشكلة بنفسك، انتقل إلى قسم "إصلاح المشكلة بنفسي".

إصلاح نيابة عني

لإصلاح هذه المشكلة تلقائياً، إعادة تشغيل الكمبيوتر حيث تفشل الترقية إلى ويندوز 7 نسبة 62%. سيتم استعادة جهاز الكمبيوتر إلى نظام التشغيل Windows Vista. أما تحميل الإصلاح التالي على محرك أقراص محمول أو قرص مضغوط أو الرجوع إلى هذه المقالة على الجهاز حيث تفشل الترقية. إذا قمت بالعودة إلى هذه المقالة على الجهاز حيث تواجه هذه المشكلة، انقر فوق
إصلاح هذه المشكلة
الارتباط. انقر فوق
تشغيلفي
الحوار تنزيل الملف، واتبع الخطوات الموجودة في الإصلاح معالج.




ملاحظة قد يتوفر هذا المعالج باللغة الإنكليزية فقط؛ ومع ذلك، يعمل الإصلاح التلقائي أيضا لإصدارات اللغات الأخرى من Windows.

ملاحظة: إذا لم تكن موجوداً على الكمبيوتر الذي يحتوي على المشكلة، يمكنك حفظ الإصلاح التلقائي بمحرك أقراص محمول أو قرص مضغوط، ومن ثم تشغيل على الكمبيوتر الذي يحتوي على المشكلة.

بعد ذلك، انتقل إلى "ذلك حل المشكلة؟" المقطع.

إصلاح المشكلة بنفسي

لحل هذه المشكلة بنفسك، اتبع هذه الخطوات:

  1. قم بإعادة تشغيل جهاز الكمبيوتر. ثم الكمبيوتر سيتم العودة إلى نظام التشغيل Windows Vista.

  2. انقر فوق ابدأوانقر نقراً مزدوجاً فوق الكمبيوترثم انقر فوق خصائص.

  3. ضمن علامة التبويب خيارات متقدمة ، انقر فوق متغيرات البيئة.

  4. ضمن متغيرات النظام، انقر فوق جديد.

  5. نوع MIG_UPGRADE_IGNORE_PLUGINS في الحقل اسم المتغير .

  6. اكتب IphlpsvcMigPlugin.dll في الحقل قيمة المتغير .

  7. انقر فوق موافق ثلاث مرات لإغلاق مربعات الحوار.

  8. بدء تثبيت الترقية مرة أخرى.

مزيد من المعلومات

كيفية فتح الملف seupact.log

لفتح الملف setupact.log أثناء عملية الترقية، اضغط SHIFT + F10 لفتح موجه الأوامر، اكتب C:\$WINDOWS.~BT\Sources\Panther\setupact.log، ومن ثم اضغط ENTER.

لفتح الملف setupact.log بعد تتحرك إعادة جهاز الكمبيوتر إلى نظام التشغيل Windows Vista، انقر فوق ابدأواكتب C:\$WINDOWS.~BT\Sources\Panther\setupact.log في المربع بدء البحث واضغط على ENTER.

سيتم فتح الملف seupact.log في "المفكرة". لعرض إدخالات سجل آخر، قم بالتمرير إلى نهاية الملف.

هل عمل ذلك على حل المشكلة؟

تحقق ما إذا كان يتم إصلاح المشكلة بترقية جهاز الكمبيوتر الخاص بك من نظام التشغيل Windows Vista إلى Windows 7. إذا تتقدم عملية الترقية بعد 62 في المائة، فقد انتهى مع هذه المادة. إذا لم يتم إصلاح هذه المشكلة، يمكنك الاتصال بالدعم.

لا تزال تحتاج إلى مساعدة؟

إذا كانت هذه المادة لم يرد السؤال الخاص بك، انقر فوق هذا الزر إلى طرح السؤال على أعضاء المجتمع الآخرين في مجتمع Microsoft:

طرح سؤال


إذا كنت تريد راجع الإجابات على قضايا مماثلة، انقر فوق الارتباطات التالية لعرض المواضيع في كومونيتيفوروم Microsoft:


هل تحتاج إلى مزيد من المساعدة؟

الخروج من الخيارات إضافية؟

استكشف مزايا الاشتراك، واستعرض الدورات التدريبية، وتعرف على كيفية تأمين جهازك، والمزيد.

تساعدك المجتمعات على طرح الأسئلة والإجابة عليها، وتقديم الملاحظات، وسماعها من الخبراء ذوي الاطلاع الواسع.

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟
بالضغط على "إرسال"، سيتم استخدام ملاحظاتك لتحسين منتجات Microsoft وخدماتها. سيتمكن مسؤول تكنولوجيا المعلومات لديك من جمع هذه البيانات. بيان الخصوصية.

نشكرك على ملاحظاتك!

×