يظهر مربع الحوار "إدخال قيمة معلمة" عند تشغيل استعلام أو نموذج أو تقرير

متوسطة: يتطلب ماكرو الأساسية ترميز والمهارات إمكانية التشغيل المتداخل.

تنطبق هذه المقالة فقط على قاعدة بيانات Microsoft Access (.mdb).


للحصول على إصدار Microsoft Access 2000 من هذه المقالة، راجع
301545.

للحصول على إصدار Microsoft Access 97 من هذه المقالة، راجع 302690.

الأعراض

عند محاولة تشغيل استعلام أو نموذج أو تقرير، قد يظهر مربع الحوار إدخال قيمة معلمة بشكل غير متوقع.

السبب

يحدث هذا السلوك عند حقل أو معيار، تعبير أو عنصر تحكم في استعلام، أو نموذج، أو تقرير تشير إلى اسم الوصول لا يمكن العثور عليه. على سبيل المثال، يمكن تسميته أو حقل قد لا تكون متاحة ضمن هذا النطاق.

الحل

لحل هذه المشكلة، أعد تسمية الإشارة إلى اسم حقل صالح. إذا كنت لا تعرف موقع المرجع، تشغيل "توثيق قاعدة بيانات" للكائنات المسرودة في مربع الحوار إدخال قيمة معلمة ، وثم إخراج المعلومات إلى ملف نصي. للقيام بذلك، اتبع الخطوات التالية:

  • إذا كنت تستخدم Access 2002 و 2003، اتبع الخطوات التالية:

    1. من القائمة أدوات ، أشر إلى تحليل، وثم انقر فوق "التوثيق".

    2. انقر فوق علامة التبويب الذي يتوافق مع نوع كائن قاعدة البيانات التي تبحث عنها، ثم انقر لتحديد خانة الاختيار الاستعلام أو النموذج أو التقرير الذي حاولت تشغيل.

      ملاحظة: إذا كان الكائن في نموذج أو تقرير، تتضمن كافة استعلامات المصدر والنماذج الفرعية أو التقارير الفرعية في قائمة التحديدات.

    3. انقر فوق خيارات لتحديد الميزات التي تريد طباعة الكائن المحدد ومن ثم انقر فوق موافق.

    4. انقر فوق موافق لإغلاق مربع الحوار "التوثيق" .

    5. من قائمة الملفات ، انقر فوق تصدير.

    6. في القائمة حفظ بنوع ، انقر فوق ملفات نصيةومن ثم أكمل باقي المعلومات حسب الحاجة.

    7. فتح الملف المصدر في Microsoft Word وقم بالبحث عن المعلمة المطلوبة في مربع الحوار إدخال قيمة معلمة .

  • إذا كنت تستخدم برنامج Access 2007، اتبع الخطوات التالية:

    1. في علامة التبويب " أدوات قاعدة البيانات "، انقر فوق توثيق قاعدة بيانات في المجموعة تحليل .

    2. انقر فوق علامة التبويب الذي يتوافق مع نوع كائن قاعدة البيانات التي تبحث عنها، ثم انقر لتحديد خانة الاختيار الاستعلام أو النموذج أو التقرير الذي حاولت تشغيل.

      ملاحظة: إذا كان الكائن في نموذج أو تقرير، تتضمن كافة استعلامات المصدر والنماذج الفرعية أو التقارير الفرعية في قائمة التحديدات.

    3. انقر فوق خيارات لتحديد الميزات التي تريد طباعة الكائن المحدد ومن ثم انقر فوق موافق.

    4. انقر فوق موافق لإغلاق مربع الحوار "التوثيق" .

    5. في المجموعة بيانات ، انقر فوق ملف نصي، ومن ثم أكمل باقي المعلومات حسب الحاجة.

    6. فتح الملف المصدر في Microsoft Word وقم بالبحث عن المعلمة المطلوبة في مربع الحوار إدخال قيمة معلمة .

في حالة تعذر تشغيل "توثيق قاعدة البيانات"، تحقق لمعرفة إذا كان هناك مرجع مفقود. في هذه الحالة مرجع مفقود الأكثر شيوعاً Utility.mda. للتحقق من هذا المرجع، اتبع الخطوات التالية:

  1. في الإطار "قاعدة بيانات"، انقر فوق الوحدات النمطية ضمن الكائنات.

    ملاحظة: إذا كنت تستخدم Access 2007، على علامة التبويب "أدوات قاعدة البيانات"، انقر فوق Visual Basic، ومن ثم انتقل إلى الخطوة 3.

  2. حدد أية وحدة نمطية الموجودة، ثم انقر فوق تصميم أو إدراج وحدة نمطية جديدة. سيبدأ "محرر Visual Basic".

  3. من القائمة أدوات ، انقر فوق " مراجع".

  4. في قائمة المراجع المتاحة ، مظهر لأية مرجع له "مفقود:" أمام الاسم. انقر لإلغاء تحديد خانة الاختيار.

    ملاحظة: إذا كان لا تحتاج مرجع إلى Utility.mda، انتقل إلى الخطوة رقم 8.

  5. انقر فوق استعراض.

  6. في القائمة أنواع الملفات ، انقر فوق الوظائف الإضافية (*.mda).

  7. استعرض للوصول إلى المجلد الذي يحتوي على Utility.mda وقم بتحديده ثم انقر فوق فتح. بشكل افتراضي، يكون هذا الملف في المجلد C:\Program Office\Office\1033 مايكروسوفت.

  8. انقر فوق موافق.

  9. في القائمة " تصحيح "، انقر فوق ترجمة اسم قاعدة البيانات.

  10. من القائمة ملف ، انقر فوق إغلاق ورجوع إلى Microsoft Access.

مزيد من المعلومات

خطوات إعادة إنشاء المشكلة في Access 2002 أو في Access 2003

تنبيه: في حالة اتباع الخطوات الموجودة في هذا المثال، يمكنك تعديل نموذج قاعدة البيانات Northwind.mdb. قد تحتاج إلى إجراء نسخ احتياطي الملف Northwind.mdb ثم اتبع هذه الخطوات على نسخة من قاعدة البيانات.

  1. افتح نموذج قاعدة البيانات Northwind.mdb.

  2. فتح استعلام "الإجماليات الفرعية أمر" في طريقة عرض التصميم.

  3. إعادة تسمية حقل "معرف الطلب" إلى
    أورديريدنومبير.

  4. قم بإغلاق الاستعلام، ومن ثم انقر فوق نعم لحفظ التغييرات.

  5. تشغيل استعلام "الإجماليات الفرعية أمر".

  6. لاحظ ظهور مربع الحوار إدخال قيمة معلمة .

هل تحتاج إلى مزيد من المساعدة؟

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Microsoft Insider

هل كانت المعلومات مفيدة؟

نشكرك على ملاحظاتك!

شكراً لك على الملاحظات! يبدو أنه من المفيد إيصالك بأحد وكلاء دعم Office لدينا.

×