OLEXP: Съобщение за грешка: Msimn.exe е генерирал грешки и ще бъде затворен от Windows

За информация относно разликите между Microsoft Outlook Express и клиенти за електронна поща на Microsoft Outlook щракнете върху следния номер на статия в базата знания на Microsoft:

257824 OL2000: разлики между Outlook и Outlook Express

Симптоми

Когато използвате Outlook Express, можете да получите някое от следните съобщения за грешка:

Msimn.exe е генерирал грешки и ще бъде затворен от Windows. Трябва да рестартирате програмата. Създава се регистър грешка.

- или -


MSIMN причинява невалиден виртуалната модул MSOE. DLL.

Причина

Тази грешка се дължи на едно от следните условия:

  • Си. DBX файловете са маркирани като само за четене.

  • Вашата самоличност ключ на системния регистър е повреден.

Решение

Преди да разрешите този проблем, се препоръчва да архивирате вашите съобщения и адреси. За допълнителна информация относно архивирането на писма и адресната книга, щракнете върху следните номера на статии в базата знания на Microsoft:

270670 как да направите резервно копие и възстановяване на данни от Outlook Express

175017 как да импортиране и експортиране на адресни книги в Outlook Express


За да разрешите този проблем, първо се уверете, че ви. DBX файловете не са само за четене. Ако проблемът остава неразрешен, тогава регенерира самоличности ключ на системния регистър. Следвайте стъпките, за да направите това.


Гарантира, че вашата. DBX файловете не са само за четене

Си. DBX файловете са файлове на хранилище за вашите папки в Outlook Express. Ако файловете са маркирани като само за четене, не са достъпни. Пример за причина за това ще бъде, ако наскоро сте възстановили файловете от резервно копие на CD-ROM. За да премахнете атрибут "само за четене", изпълнете следните стъпки:

  1. Щракнете върху Старт, щракнете върху Намери (или търсене) и след това щракнете върху файлове и папки.

  2. В полето име въведете *.dbxи след това задайте търсенето да включва локални твърди дискове.

  3. Щракнете върху Намери сега или Търси сегаи когато се появи, щракнете върху заглавката на колоната В папкатаза група артикули по местоположение. Отбележете местоположението на файловете намерени и използвайте Windows Explorer, за да отидете до директорията, съдържаща текущото ви хранилище.

  4. Щракнете с десния бутон върху първия файл в папката, изберете свойства, в раздела Общи , щракнете, за да махнете отметката от квадратчето Само за четене и след това щракнете върху OK.

  5. Повторете стъпка 4 за всеки файл в папката и Тествайте Outlook Express.

Забележка: по подразбиране файловете се съхраняват в папка на самоличности по пътя, подобно на едно от следните:

Устройство: \Documents and Обстановка\име\Local Settings\Application Data\Identities\ {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6} \Microsoft\Outlook Express
- или -

Drive: \Windows\Application Data\Identities\ {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6} \Microsoft\Outlook Express
Къде е буквата на устройството.

GUID номер по-горе, {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}, е само. Вашите данни се различават.


Възстановяване на ключа на системния регистър самоличности

Важно: Този раздел, метод или задача съдържат информация за модифициране на системния регистър. Въпреки това при неправилно модифициране на регистъра може да възникнат сериозни проблеми. Поради тази причина, трябва внимателно да изпълните тези стъпки. За допълнителна защита направете резервно копие на регистъра, преди да го промените. След това, ако възникне проблем, можете да възстановите системния регистър. За повече информация как да направите резервно копие и как да извършите възстановяване на системния регистър, щракнете върху следния номер на статия, за да видите статията в базата със знания на Microsoft:

322756 създаване на резервно копие и възстановяване на системния регистър в Windows
За да създадете отново самоличностите ключ на системния регистър:

  1. Щракнете върху бутона " Старт ", щракнете върху изпълнии въведете regedit. Щракнете OK.

  2. Намерете системния регистър в следния ключ на системния регистър:

    HKEY_CURRENT_USER/Identities

  3. В менюто на системния регистър щракнете върху Експортиране на файла на системния регистър.

  4. В полето Запиши в щракнете върху работния плот.

  5. В полето за Име на файла въведете самоличностии натиснете Запиши.

  6. В редактора на системния регистър, щракнете с десния бутон на самоличности ключ и натиснете Delete.

  7. Затворете редактора на системния регистър и след това стартирайте Outlook Express да тествате функционалността.

Сега можете да възстановите вашата поща, адреси и настройките на акаунта.

Допълнителна информация

В случай, че няколко идентичности съществува във вашата система, използвайте следните стъпки, за да определите GUID номер (например един показва над {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6} като пример):

  1. Щракнете върху Старт, щракнете върху изпълнение, въведете regeditи щракнете върху OK.

  2. Намерете системния регистър в следния ключ на системния регистър:

    HKEY_CURRENT_USER/Identities

  3. Щракнете върху "+" (знак плюс) до самоличности.

  4. За да определите GUID принадлежи към коя самоличност, щракнете върху GUID на прозореца на лявата страна. В прозореца на дясната страна, потърсете името на данни "Потребителско име" - това е името на самоличност в Outlook Express.

Нуждаете се от още помощ?

Разширете уменията си
Преглед на обучението
Получавайте първи новите функции
Присъединете се към Microsoft приобщени

Беше ли полезна тази информация?

Благодарим ви за обратната връзка!

Благодарим ви за вашата обратна връзка. Изглежда, че ще бъде полезно да ви свържем с един от нашите агенти по поддръжката на Office.

×