PrivilegeDenied грешка при синхронизиране на сървъра

Симптом

Когато използвате синхронизиране на сървъра на Dynamics 365, срещнете следното съобщение за грешка след като щракнете върху тест и разрешаване на пощенска кутия:

"Срещи, контакти и задачи може да се синхронизира за < име на пощенска кутия > пощенска кутия, защото пощенската кутия на потребител няма достатъчно разрешения за тази пощенска кутия.

Имейл сървър код на грешка: Crm.80040220.PrivilegeDenied "

Причина

Тази грешка ще се появи, ако потребителят, свързана със записа на пощенската кутия няма достатъчно права, за да използвате синхронизиране на сървъра.

Решение

Промяна на права на потребителя да включва липсващите привилегии.  Когато щракнете върху раздела подробни данни, тя трябва да включва името на липсващи привилегии.  В примера по-долу потребителят няма права за четене за обекта имейл профил сървър.

T:331ActivityId: < GUID >> изключение: необработено изключение: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: Неуспешно актуализиране на състоянието на синхронизация: необработено изключение: System.ServiceModel.FaultException'1 [[ Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, версия = 8.0.0.0, култура = неутрален, PublicKeyToken = 31bf3856ad364e35]]: главен потребител (ИД = < GUID > въведете = 8) липсва prvReadEmailServerProfile привилегия (ИД = edebe6f6-cf2e-4520-b635-ae0615d41e34) подробности: f6afa1da-a317-4cfd-a3ea-cb062b28dbcf-2147220960 главен потребител (ИД = < GUID > тип = 8) липсва prvReadEmailServerProfile привилегия (ИД = edebe6f6-cf2e-45...

За списък с права, които може да се наложи да използвате синхронизиране на сървъра вижте раздела допълнителна информация.

Повече информация

Следната таблица изброява права, изисква да използвате синхронизиране на сървъра и раздела права когато правата могат да бъдат намерени. Потребител с ролята на системен администратор може да намерите и промяна на правата за достъп чрез навигиране до настройките за сигурност, права за достъп. За да видите кои роля(и) са присвоени на определен потребител, преминаване към настройки, щракнете върху защита, щракнете върху потребители, изберете записа на конкретен потребител и щракнете върху управление на ролите.

Име на правата

Обект

Местоположение (раздел) в права

prvReadEmailServerProfile

EmailServerProfile

Управление на бизнес

prvWriteMailbox

Пощенска кутия

Бизнес Управление на

prvReadMailbox

Пощенска кутия

Бизнес Управление на

prvReadOrganization

Организация

Бизнес Управление на

prvSyncToOutlook (exchangesyncidmapping

Outlook

Управление на бизнес -> поверителност, свързани с права

prvReadActionCard

ActionCard

Главни записи

prvDeleteActivity

Дейност

Главни записи

prvAppendActivity

Дейност

Главни записи

prvWriteActivity

Дейност

Главни записи

prvCreateActivity

Дейност

Главни записи

prvReadActivity

Дейност

Главни записи

prvAppendToActivity

Дейност

Главни записи

prvReadConnection

Връзка

Главни записи

prvAssignContact

Контакт

Главни записи

prvReadContact

Контакт

Главни записи

prvWriteContact

Контакт

Главни записи

prvCreateContact

Контакт

Главни записи

prvDeleteContact

Контакт

Главни записи

prvReadUserQuery

Записан изглед

Главни записи

prvReadQueue

Опашка

Главни записи

prvReadQuery

Изглед

Персонализиране

prvReadIncident

Случай

Услуга

prvSearchAvailability

Управление на услуги -> други привилегии

prvOverrideCreatedOnCreatedBy

Управление на услуги -> други привилегии

Нуждаете се от още помощ?

Разширете уменията си
Преглед на обучението
Получавайте първи новите функции
Присъединете се към Microsoft приобщени

Беше ли полезна тази информация?

Благодарим ви за обратната връзка!

Благодарим ви за вашата обратна връзка. Изглежда, че ще бъде полезно да ви свържем с един от нашите агенти по поддръжката на Office.

×