Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Важно Преди да изпълните инструмента Fix It, запишете данните си и затворете приложението. След като изпълните инструмента Fix It, компютърът ще се рестартира след 10 минути.

Симптоми

На компютър, който изпълнява Windows XP, Windows Vista или Windows 7, някои икони на следните места са променени на случаен принцип в други икони:

  • Моят компютър

  • Windows Explorer

  • Работен плот

  • Лента за бързо стартиране

Причина

Този проблем възниква, тъй като кешът на иконите не се актуализира правилно.

Решение

За да отстраните проблема, първата стъпка е да влезете в друг потребителски акаунт с администраторски права. За да направите това, изпълнете следните стъпки:

  1. Излезте от текущия потребителски акаунт, който се сблъсква с промяната на иконите.

  2. Влезте като потребител с администраторски права.

Забележка Файлът трябва да бъде изтрит от друг потребител, защото по време на процеса на излизане, файлът IconCache.db може да бъде заместен с повредени данни за икони.

Важно Този раздел, метод или задача съдържа информация за модифициране на системния регистър. Имайте предвид, че при неправилна промяна на системния регистър е възможно да възникнат сериозни проблеми. Затова спазвайте внимателно тези стъпки. За допълнителна защита направете архивно копие на системния регистър, преди да го промените. Така в случай на възникване на проблем ще можете да възстановите регистъра. За допълнителна информация как да направите резервно копие на системния регистър или да възстановите регистъра щракнете върху следния номер на статия от базата знания на Microsoft:

322756 Как се архивира и възстановява системният регистър в Windows

След това изпълнете тези стъпки, за да разрешите проблема:

  1. Ако се покаже диалоговият прозорец Затвори взаимодействието на отворените програми, затворете всички отворени прозорци.

  2. Създайте ключ от системния регистър Макс. кеширани икони, след което задайте стойността на този ключ на 2048. За да направите това, изпълнете следните стъпки:

    1. Щракнете върху Старт, въведете regedit в полето за търсене и щракнете върху Regedit в показания списък.

    2. Намерете и изберете следния ключ от системния регистър:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer

    3. В менюто Редактиране щракнете върху Създаване, след което щракнете върху Стойност на низа.

    4. Въведете MaxCachedIcons като име на ключ от системния регистър и натиснете Enter.

    5. Щракнете двукратно върху ключа от системния регистър Макс. кеширани икони, въведете 2048 в полето Данни за стойност и след това щракнете върху OK.

    6. Затворете редактора на системния регистър.

  3. Изтрийте IconCache.db от следното местоположение в зависимост от вашата операционна система.

    Windows XP

    C:\Documents and Settings\<име на потребителя>\Local Settings\Application Data

    Windows Vista или Windows 7

    C:\Users\<потребителско име>\AppData\LocalЗабележка <Потребителско име> е контейнер за името на потребителския акаунт, за който се променя иконата.

Повече информация

Как работи MATS пакетът, за да реши този проблем

  1. MATS пакетът сканира вашия компютър и открива дали на него се изпълнява Windows XP, Windows Vista или Windows 7.

  2. MATS пакетът проверява дали стойността на Макс. кеширани икони от системния регистър съществува в подключовете от системния регистър. Ако стойността на Макс. кеширани икони в системния регистър не съществува, създайте я и след това задайте за нея 2048. Ако стойността Макс. кеширани икони в системния регистър съществува, задайте за нея 2048.

    Забележка: По време на този процес се показва диалогов прозорец. Това ви дава възможност да решите проблема автоматично (препоръчителната опция) или ръчно да изберете отделни проблеми, които да бъдат решени. Ако изберете ръчно отделни проблеми, които да бъдат решени, трябва да изберете опцията Персонализации на икони и папки или Други или не знам от диалоговия прозорец.

  3. MATS пакетът проверява дали файлът IconCache.db е изтрит успешно.

Други проблеми, които решава MATS пакетът

2394521 Не може да се изпразни кошчето в Windows XP или Windows Vista

949109 Грешка „Файлът или папката не съществува“ в Windows Vista

934160 Грешка „Достъп до мрежа или файл“ или грешка „Папката не съществува“

2394740 Не могат да се избират няколко елемента след надстройване от Windows XP до Windows Vista

813711 Промени в размера, изгледа, иконата или позицията на папка са загубени

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×