Outlook 2010, 2013, 2016, or Outlook for Office 365 may not connect using MAPI over HTTPs as expected

S'aplica a: Exchange Server 2016 Enterprise EditionExchange Server 2016 Standard EditionExchange Server 2013 Service Pack 1 Més

Symptoms


Consider the following scenario.
  • You are using Microsoft Outlook 2010.
  • You are using Microsoft Outlook 2013 Service Pack 1 (SP1) or a later version.
  • You are connected to a Microsoft Exchange Server 2013 Service Pack 1 (SP1) or Microsoft Exchange Server 2016 mailbox.
  • The Exchange mailbox and Client Access (CAS) servers that you are connecting to all have Exchange Server 2013 SP1 or a later version installed or Microsoft Exchange Server 2016.
  • The necessary server settings to establish MapiHttp connections are correctly configured.
In the above scenario, the Protocol column in the Outlook Connection Status dialog shows Outlook 2013 is connected to the Exchange server using a connection mechanism other than MAPI/HTTP. For example, the following figure shows a connection using RPC/HTTP.
Protocol

Note MAPI/HTTP connections are designated in the Protocol column using the string HTTP

Additionally, if MAPI/HTTP is disabled, Office 365 users receive a Basic Authentication prompt instead of a Modern Authentication prompt.

Cause


This problem can occur if the MapiHttp feature is disabled on the Outlook client using the following registry value:
Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange
DWORD: MapiHttpDisabled
Value: 1

Resolution


To resolve this problem, change the value of MapiHttpDisabled to 0 (zero) or delete the MapiHttpDisabled DWORD value. This registry data is intended for testing purposes only.
  1. Exit Outlook.
  2. Open Registry Editor. To do this, use one of the following procedures, as appropriate for your version of Windows.
    • Windows 10, Windows 8.1 and Windows 8: Press Windows Key + R to open a Run dialog box. Type regedit.exe and then press OK.
    • Windows 7: Click Start, type regedit.exe in the search box, and then press Enter.

  3. Locate and select the following key in the registry.

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
  4. Right-click MapiHttpDisabled and then click Modify.
  5. Change the Value data to 0 and then click OK.
  6. Close Registry Editor.
  7. Start Outlook.

More Information


For more information about the requirements for MAPI over HTTP connections, visit the following Microsoft TechNet website: