Vytvoření a sdílení řídicího panelu s aplikacemi Excel a Microsoft Groups

Platí pro
Excel pro Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

Řídicí panel představuje vizuální znázornění klíčových metrik, které vám umožní rychle zobrazit a analyzovat data na jednom místě. Řídicí panely poskytují nejen konsolidované zobrazení dat, ale také samoobslužnou příležitost business intelligence, kde uživatelé můžou filtrovat data tak, aby zobrazovala jen to, co je pro ně důležité. Vytváření sestav v Excelu bylo dříve často nutné generovat více sestav pro různé osoby nebo oddělení podle jejich potřeb.

Příklad excelového řídicího panelu s průřezy a přehledem časových linií

V tomto tématu se dozvíte, jak pomocí více nástrojů kontingenční tabulky, kontingenční grafy a kontingenční tabulky vytvořit dynamický řídicí panel. Potom dáme uživatelům možnost rychle filtrovat data požadovaným způsobem pomocí průřezů a časové osy, které umožní automatické zvětšování a zmenšování kontingenčních tabulek a grafů tak, aby zobrazovaly jenom ty informace, které chtějí vidět. Kromě toho můžete řídicí panel při přidávání nebo aktualizaci dat rychle aktualizovat. Je proto velmi šikovný, protože sestavu řídicího panelu stačí vytvořit jenom jednou.

V tomto příkladu vytvoříme čtyři kontingenční tabulky a grafy z jednoho zdroje dat.

Po vytvoření řídicího panelu vám ukážeme, jak ho můžete sdílet s lidmi vytvořením skupiny Microsoft. Máme také interaktivní excelový sešit, který si můžete stáhnout a postupovat podle těchto pokynů sami.

Stáhněte si sešit s výukovým kurzem řídicího panelu Excel.

Získání dat

  1. Data můžete zkopírovat a vložit přímo do Excelu nebo můžete nastavit dotaz ze zdroje dat. V tomto tématu jsme použili dotaz Analýza prodeje ze šablony Northwind Traders pro Microsoft Access. Pokud ji chcete použít, můžete otevřít Access, přejít doHledánínových>souborů>, do vyhledávacího pole zadat "Northwind" a vytvořit databázi šablon. Jakmile to uděláte, budete mít přístup ke všem dotazům obsaženým v šabloně. Tato data jsme už vložili do excelového sešitu za vás, takže pokud nemáte Access, nemusíte mít obavy.

  2. Ověřte, že jsou data správně strukturovaná a že v nich nechybí řádky ani sloupce. Každý řádek by měl představovat jeden záznam nebo položku. Pokud potřebujete pomoc s nastavením dotazu nebo pokud potřebujete manipulovat s daty, přečtěte si téma Získání & transformace v Excelu.

    Ukázková data v excelové tabulce, která se použijí jako zdroj dat kontingenční tabulky

  3. Pokud tomu tak ještě není, naformátujte data jako excelovou tabulku. Při importu z Accessu se data automaticky naimportují do tabulky.

Vytváření kontingenčních tabulek

  1. Vyberte libovolnou buňku v oblasti dat a přejděte na Vložit>nový listkontingenční tabulky>. Další podrobnosti najdete v tématu Vytvoření kontingenční tabulky k analýze dat listu .

  2. Přidejte požadovaná pole kontingenční tabulky a potom je naformátujte podle potřeby. Tato kontingenční tabulka bude základem pro ostatní, takže byste měli věnovat nějaký čas všem nezbytným úpravám stylu, rozložení sestavy a obecného formátování, abyste je nemuseli dělat vícekrát. Další podrobnosti najdete tady: Návrh rozložení a formátu kontingenční tabulky.
    V tomto případě jsme vytvořili souhrn prodeje na nejvyšší úrovni podle kategorie produktu a seřadili ho v sestupném pořadí podle pole Prodej.

    Ukázková kontingenční tabulka podle kategorie, prodej & % z celkové hodnoty

    Další podrobnosti najdete v tématu Řazení dat v kontingenční tabulce nebo kontingenčním grafu .

  3. Po vytvoření předlohy kontingenční tabulky ji vyberte a potom zkopírujte a vložte do prázdných oblastí listu tolikrát, kolikrát je potřeba. V našem příkladu mohou tyto kontingenční tabulky měnit řádky, ale ne sloupce, takže jsme je umístili na stejný řádek s prázdným sloupcem mezi každou z nich. Můžete ale zjistit, že pokud můžou roztáhnout sloupce, budete muset dát kontingenční tabulky pod sebe.

    Důležité

    Kontingenční tabulky se nesmí vzájemně překrývat, proto se ujistěte, že návrh ponechá mezi nimi dostatečný prostor, aby se mohly při filtrování, přidávání nebo odebírání hodnot rozšiřovat a smršťovat.

    V tomto okamžiku je vhodné dát kontingenčním tabulkám smysluplné názvy, abyste věděli, k čemu slouží. Jinak je Excel pojmenuje Kontingenční tabulka1, Kontingenční tabulka2 atd. Můžete vybrat každý z nich, pak přejít na Kontingenční tabulka analyzovat>a pak do pole Název kontingenční tabulky zadat nový název. Bude to důležité, až přijde čas na připojení kontingenčních tabulek k průřezům a ovládacím prvkům časové osy.

    Přejmenování kontingenční tabulky pomocí Nástrojů > kontingenční tabulky Analyze > PivotTable Name box

Vytváření kontingenčních grafů

  1. Klikněte kamkoli do první kontingenční tabulky a přejděte naKontingenční graf – Nástroje > pro analýzu >kontingenční tabulkya pak vyberte typ grafu. Zvolili jsme kombinovaný graf s grafem Prodej jako skupinovým sloupcovým grafem a % celkem jako spojnicovým grafem znázorněným na vedlejší ose.

    Dialogové okno zobrazení grafu pro kombinovaný graf se skupinovým sloupcovým a spojnicovým grafem

  2. Vyberte graf a potom na kartách Analýza kontingenčního grafu, Návrh a Formát nastavte jeho velikost a formát podle potřeby. Další podrobnosti najdete v našem seriálu o formátování grafů.

  3. Tento postup opakujte pro každou ze zbývajících kontingenčních tabulek.

  4. Teď je vhodný čas přejmenovat i kontingenční grafy. Přejděte na Kontingenční graf, analyzujte>kontingenční graf a do pole Název grafu zadejte nový název.

Přidání průřezů a časové osy

Průřezy a časové osy umožňují rychlé filtrování kontingenčních tabulek a kontingenčních grafů, takže vidíte jenom ty informace, které jsou pro vás důležité.

Rozložené zobrazení průřezů a ovládacího prvku Časové osy na řídicím panelu

  1. Vyberte libovolnou kontingenční tabulku a přejděte na Analýza>kontingenční tabulky, Filtr>,Vložit průřez, a pak zaškrtněte každou položku, kterou chcete použít jako průřez. Pro tento řídicí panel jsme vybrali Kategorie, Název produktu, Zaměstnanec a Jméno zákazníka. Když kliknete na OK, průřezy se přidají doprostřed obrazovky naskládané na sebe, takže je budete muset uspořádat a změnit jejich velikost podle potřeby.

    Možnost Vložit průřez z nabídky Nástroje > kontingenční tabulky Analýza > filtru

  2. Možnosti průřezu: Pokud kliknete na některý průřez, můžete přejít na kartu Průřez a vybrat různé možnosti, například Styl a počet zobrazených sloupců. Více průřezů můžete zarovnat tak, že je vyberete pomocí kombinace kláves Ctrl+kliknutí levým tlačítkem a potom použijete nástroje Zarovnání na kartě Nástroje průřezu .

  3. Připojení průřezu: Průřezy budou připojené jenom ke kontingenční tabulce, kterou jste použili k jejich vytvoření, takže musíte vybrat jednotlivé průřezy a pak přejít na>>Připojení sestavy průřezů a zkontrolovat, které kontingenční tabulky chcete ke každému připojit. Průřezy a časové osy můžou ovládat kontingenční tabulky na libovolném listu, dokonce i na skrytém listu.

    Připojení sestav průřezů z možností nástrojů > průřezu

  4. Přidání časové osy: Vyberte libovolnou kontingenční tabulku a přejděte na Analýza>kontingenční tabulky, Filtr>,Vložit časovou osu, a pak zaškrtněte všechny položky, které chcete použít. Pro tento řídicí panel jsme vybrali Datum objednávky.

  5. Možnosti časové osy: Klikněte na časovou osu a přejděte na kartu Časová osa a vyberte možnosti jako Styl, Záhlaví a Titulek. Vyberte možnost Připojení sestavy a propojte časovou osu s kontingenčními tabulkami podle vašeho výběru.

Přečtěte si další informace o průřezech a ovládacích prvcích časové osy .

Další kroky

Řídicí panel je teď funkčně kompletní, ale nejspíš ho budete muset uspořádat podle svých představ a provést konečné úpravy. Můžete například přidat název sestavy nebo pozadí. Pro náš řídicí panel jsme kolem kontingenčních tabulek přidali obrazce a vypnuli jsme možnost Nadpisy a mřížka na kartě Zobrazení .

Nezapomeňte otestovat všechny průřezy a časové osy, abyste měli jistotu, že se vaše kontingenční tabulky a kontingenční grafy chovají podle vašich představ. Můžete narazit na situace, kdy určité výběry způsobí problémy, když se jedna kontingenční tabulka bude chtít upravit a překrývat jinou, což ale nejde a zobrazí chybovou zprávu. Tyto problémy je potřeba opravit před distribucí řídicího panelu.

Po nastavení řídicího panelu můžete kliknout na kartu Sdílení řídicího panelu v horní části tohoto tématu a zjistit, jak řídicí panel distribuovat.

Viz také

Máte otázky, na které jsme tady neodpověděli?

Navštivte komunitu Microsoft Answers.