Řešení problémů s aktualizacemi Microsoft Security Essentials

Microsoft Security Essentials ve spojení se službou Microsoft Update automaticky zajišťuje, aby byly definice virů a spywaru aktualizované.

Příznaky

Tady jsou některé časté problémy s automatickými aktualizacemi:

  • Zobrazuje se chybová zpráva s oznámením, že aktualizace selhaly.
  • Při vyhledávání aktualizací se zobrazí chybová zpráva, že aktualizace definic virů a spywaru nejde vyhledat, stáhnout nebo nainstalovat.
  • Aktualizace selžou, přestože jste připojení k internetu.
  • Aktualizace se neinstalují automaticky podle plánu.

Příčina

Nejčastější příčinou selhání aktualizací jsou problémy s připojením k internetu. Pokud jste připojení, může být problém způsobený konflikty v nastavení Windows Internet Exploreru.

Řešení


Krok 1: Obnovte nastavení Internet Exploreru

  1. Ukončete všechny otevřené programy včetně Internet Exploreru.
  2. Klikněte na Start, do pole Spustit hledání zadejte inetcpl.cpl a stiskněte klávesu ENTER.
  3. V dialogu Možnosti internetu klikněte na kartu Upřesnit.
  4. V oblasti Obnovení nastavení aplikace Internet Explorer klikněte na Obnovit a pak znovu na Obnovit.
  5. Počkejte, dokud Internet Explorer neobnoví nastavení, a klikněte na OK.
  6. Otevřete Internet Explorer.
  7. Otevřete Microsoft Security Essentials, klikněte na kartu Aktualizace a pak na Aktualizovat. Pokud se problém opakuje, přejděte k dalšímu kroku.

Krok 2: Nastavte Internet Explorer jako výchozí prohlížeč

  1. Ukončete všechny otevřené programy včetně Internet Exploreru.
  2. Klikněte na Start, do pole Spustit hledání zadejte inetcpl.cpl a stiskněte klávesu ENTER.
  3. V dialogu Možnosti internetu klikněte na kartu Programy.
  4. V oblasti Výchozí webový prohlížeč klikněte na Nastavit jako výchozí. Klikněte na OK.
  5. Otevřete Microsoft Security Essentials. Klikněte na kartu Aktualizace a pak na Aktualizovat. Pokud se problém opakuje, přejděte k dalšímu kroku.

Krok 3: Zkontrolujte, jestli máte na počítači správně nastavené datum a čas

  1. Otevřete Microsoft Security Essentials.
  2. Pokud zobrazená chybová zpráva obsahuje kód 0x80072f8f, je nejpravděpodobnější příčinou problému nesprávné nastavení data nebo času počítače.
  3. Postup, jak obnovit nastavení data nebo času počítače, najdete v článku Oprava poškozených zástupců na ploše a běžné úlohy související s údržbou systému.

Krok 4: Přejmenujte složku pro distribuci softwaru v počítači

  1. Zastavte službu Automatické aktualizace.
    1. Klikněte na Start, klikněte na Spustit, zadejte services.msc a klikněte na OK.
    2. Klikněte pravým tlačítkem na službu Automatické aktualizace a pak klikněte na Zastavit.
    3. Minimalizujte modul snap-in Služby.
  2. Pokud zobrazená chybová zpráva obsahuje kód 0x80072f8f, je nejpravděpodobnější příčinou problému nesprávné nastavení data nebo času počítače.
  3. Následujícím způsobem přejmenujte adresář SoftwareDistribution:
    1. Klikněte na Start, klikněte na Spustit, zadejte cmd a klikněte na OK.
    2. Zadejte cd %windir% a stiskněte klávesu ENTER.
    3. Zadejte ren SoftwareDistribution SDTemp a stiskněte klávesu ENTER.
    4. Zadejte exit a stiskněte klávesu ENTER.
  4. Následujícím způsobem spusťte službu Automatické aktualizace:
    1. Maximalizujte modul snap-in Služby.
    2. Klikněte pravým tlačítkem na službu Automatické aktualizace a pak klikněte na Spustit.
    3. Zavřete okno modulu snap-in Služby.

Krok 5: Obnovte na počítači modul pro aktualizaci antivirového programu Microsoft

  1. Klikněte na Start, na Všechny programy, na Příslušenství, klikněte pravým tlačítkem na Příkazový řádek a vyberte Spustit jako správce.
  2. Do okna Příkazový řádek zadejte následující příkazy a za každým stiskněte klávesu ENTER:
    • Cd\
    • Cd program files\microsoft security essentials
    • Mpcmdrun –removedefinitions –all
    • Exit
  3. Restartujte počítač.
  4. Otevřete Microsoft Security Essentials, klikněte na kartu Aktualizace a pak na Aktualizovat. Pokud se problém opakuje, přejděte k dalšímu kroku.

Krok 6: Nainstalujte aktualizace definic virů a spywaru ručně

Klikněte na Spustit. Nejnovější aktualizace jsou ručně nainstalované na počítači.

Krok 7: Kontaktujte podporu

Pokud jste tímto postupem problém nevyřešili, obraťte se na podporu. Další informace najdete v článku Zákaznická podpora.





Vlastnosti

ID článku: 17451 - Poslední kontrola: 14. 9. 2016 - Revize: 2

Váš názor