Informace o seznamu automatického dokončování aplikace Outlook

Platí pro: Outlook 2016Outlook 2013Microsoft Office Outlook 2003 Více

Shrnutí


Tento článek obsahuje přehled seznamu automatického dokončování aplikace Microsoft Outlook (také známé jako v seznamu automatického dokončování aplikace Outlook). Vedle popisu funkce, tento článek obsahuje další informace a podrobné pokyny pro pokročilé uživatele, můžete spravovat seznam.

Více informací


Aplikace Outlook udržuje seznam automatického dokončování. Seznam je používán funkce automatické kontroly jmen i funkcí automatického doplňování. Seznamu funkce Automatické dokončování označované též jako mezipaměť přezdívek je vytvořen automaticky při odeslání e-mailové zprávy z aplikace Outlook. Seznam obsahuje adresy SMTP, LegacyExchangeDN položek a zobrazované názvy pro uživatele, kterému jste odeslali mail dříve.Poznámka: Seznam automatického dokončování pro aplikaci Outlook je specifický pro aplikaci Outlook a Outlook Web App (OWA) není sdílen. Aplikace Outlook Web Access udržuje svůj vlastní seznam automatického dokončování.Následující části obsahují informace o funkci Automatické dokončování.

Omezit počet položek

Aplikace Outlook omezuje počet položek, které lze uložit v seznamu funkce Automatické dokončování. Po dosažení tohoto limitu aplikace Outlook používá interní algoritmus k určení nejlepší jména ze seznamu odebrat. Je to založeno na použití vážení. Proto můžete najít některé názvy neočekávaně odebrána z mezipaměti přezdívek. Existují dva obecné přístupy, které lze použít k zabránění této situace:
  1. Aktivně lze odebrat seznam položek automatického dokončování, které již nepotřebujete. Toto je upřednostňovaný přístup. Další informace o tomto postupu naleznete v části "Jak odebrat seznam položek automatického dokončování jeden najednou."
  2. Můžete zvýšit limit mezipaměti přezdívek. Vzhledem k tomu, že tato konfigurace netestované, nedoporučujeme jej. Pokud máte větší mezipaměť přezdívek, můžete také ztratit větší počet položek v mezipaměti pokud je mezipaměť přezdívek nepoužitelný kvůli poškození. Další informace o zvýšení limitu naleznete v části "Jak změnit limit pro dokončování."
Mezní hodnoty jsou následující:
  • Aplikace Outlook 2016: 1000 položek
  • Outlook 2013: 1000 položek
  • Outlook 2010: 1000 položek
  • Aplikace Outlook 2007: 2 000 položek
  • Aplikace Outlook 2003: 1000 položek
 

Postup při povolení funkce Automatické dokončování

V této části Podrobné informace o tom, jak povolit nebo zakázat funkci automatického dokončování.
Aplikace Outlook 2010, aplikace Outlook 2013 a Outlook 2016
Chcete-li získat přístup k nastavení automatického dokončování, postupujte takto:
  1. V nabídce Soubor klikněte na příkaz Možnosti.
  2. Klepněte na kartu Pošta .
  3. Procházejte přibližně v polovině vzdálenosti dokud viz odesílání zpráv. Ujistěte se, že je zaškrtnuto políčko Použít seznam automatického dokončování navrhne jména při psaní do Komu, kopie a skrytá řádky .
Aplikace Outlook 2003 a Outlook 2007
Chcete-li získat přístup k nastavení automatického dokončování, postupujte podle pokynů:
  1. V nabídce Nástroje klepněte na příkaz Možnosti.
  2. Klepněte na tlačítko Možnosti e-mailu .
  3. Klepněte na tlačítko Upřesnit možnosti e-mailu .
  4. Ujistěte se, že Navrhovat jména Komu, kopie a skrytá pole políčko zaškrtnuto. (Následující obrazovky pro tento krok.)The screen shot for this step.
 

Postup importu souborů NK2 do aplikace Outlook 2010, aplikace Outlook 2013 a Outlook 2016

Aplikace Microsoft Office Outlook 2007 a dřívějších verzích uložení seznamu funkce Automatické dokončování v přezdívku (NK2) souboru na disku. Aplikace Outlook 2010, aplikace Outlook 2013 a 2016 aplikace Outlook uloženy jako skryté zprávy ve vašem úložišti zpráv primární seznamu funkce Automatické dokončování. Aplikace Outlook 2010, aplikace Outlook 2013 a Outlook 2016 umožňují import souborů NK2 starší.Další informace o importu souborů NK2 do aplikace Outlook 2010 přejděte na následující web společnosti Microsoft:

Kopírování seznamu funkce Automatické dokončování

Kroky pro export a import seznamu funkce Automatické dokončování se liší v závislosti na verzi aplikace Outlook, kterou používáte.
Aplikace Outlook 2010, aplikace Outlook 2013 a Outlook 2016
Kopírování seznamu funkce Automatické dokončování v aplikaci Outlook 2010, aplikace Outlook 2013 a 2016 aplikace Outlook, postupujte takto:Krok1Chcete-li exportovat zprávy automatického dokončování poštovní schránky, postupujte takto:
  1. Ukončete aplikaci Outlook a potom ukončete aplikaci Outlook Web Access nebo Outlook Web App (OWA) ve všech pracovních stanicích, které jsou připojeny k poštovní schránce.
  2. Stáhněte a nainstalujte z http://mfcmapi.codeplex.comMFCMAPI.
  3. Mfcmapi.exe spusťte.
  4. V nabídce relace klepněte na tlačítko přihlášení.
  5. Pokud se zobrazí výzva k výběru profilu, vyberte název požadovaného profilu a klepněte na tlačítko OK.
  6. V horním podokně vyhledejte řádek, který odpovídá vaší poštovní schránky a poklepejte na něj.
  7. V levém navigačním podokně rozbalte položku Kořenový kontejnera potom rozbalte Horní úložiště informací nebo IPM_SUBTREE.
  8. Klepněte pravým tlačítkem myši na složku Doručená pošta a potom klepněte na tlačítko Otevřít přidružený obsah tabulku. Tato akce otevře nové okno MFCMAPI, který obsahuje různé vlastnosti.
  9. Ve sloupci Předmět klepněte pravým tlačítkem myši na položku Předmět IPM. Configuration.Autocompletea potom klepněte na tlačítko Exportovat zprávy. Tato akce otevře okno Uložit zprávu do souboru .
  10. V rozevíracím seznamu vyberte soubor MSG (UNICODE)a potom klepněte na tlačítko OK.
  11. Vyberte umístění složky, do které chcete zprávu uložit a klepněte na tlačítko Uložit. Poznamenejte si toto umístění.
Krok 2Chcete-li importovat zprávy automatického dokončování poštovní schránky, postupujte takto.
  1. Ukončete aplikaci Outlook a potom ukončete aplikaci Outlook Web Access nebo Outlook Web App (OWA) ve všech pracovních stanicích, které jsou připojeny k poštovní schránce.
  2. Stáhněte a nainstalujte z http://mfcmapi.codeplex.com MFCMAPI
  3. Mfcmapi.exe spusťte.
  4. V nabídce relace klepněte na tlačítko přihlášení.
  5. Pokud se zobrazí výzva k výběru profilu, vyberte název požadovaného profilu a klepněte na tlačítko OK.
  6. V horním podokně vyhledejte řádek, který odpovídá vaší poštovní schránky a poklepejte na něj.
  7. V levém navigačním podokně rozbalte kořen - poštovní schránkya potom rozbalte Horní úložiště informací nebo IPM_SUBTREE.
  8. Klepněte pravým tlačítkem myši na složku Doručená pošta a potom klepněte na tlačítko Otevřít přidružený obsah tabulku. Tato akce otevře nové okno MFCMAPI, který obsahuje různé vlastnosti.
  9. Aby se zabránilo duplicitní položky, je nutné odstranit existující zprávu funkce Automatické dokončování. Poznámka: Před odstraněním IPM. Configuration.Autocomplete zpráva, je nutné exportovat zprávy pomocí kroků v části "Jak exportovat mezipaměti automatického doplňování". Chcete-li odstranit existující zprávu funkce Automatické dokončování, postupujte takto:
    1. Ve sloupci Předmět vyhledejte položku, která má předmět IPM. Configuration.Autocomplete.
    2. Klepněte pravým tlačítkem myši na položku a potom klepněte na tlačítko Odstranit zprávu. Otevře se okno Odstranit položku .
    3. V rozevíracím seznamu vyberte trvalé odstranění (odstraní pro zachování odstraněných položek, pokud je podporován)a potom klepněte na tlačítko OK.
  10. V nabídce složky klepněte na tlačítko importovata potom klepněte na tlačítko Z MSG.
  11. Vyhledejte soubor MSG, který jste vytvořili v kroku 11 v části "Jak na Export automatické doplňování seznamu" a potom klepněte na tlačítko OK.
  12. V okně Zatížení zpráva v seznamu styl zatížení vyberte načíst zprávu do aktuální složky a potom klepněte na tlačítko OK.
Automatické dokončování je importována z IPM. Msg< kód v šestnáctkové soustavě >Configuration.Autocomplete_, kde představuje zástupný symbol< kód v šestnáctkové soustavě > dlouhý řetězec čísel a písmen.
Aplikace Outlook 2003 a Outlook 2007

Postup kopírování seznamu funkce Automatické dokončování v aplikaci Outlook 2003 a Outlook 2007 jsou odlišné. Je to proto, že aplikace Outlook 2003 a Outlook 2007 uložit soubor NK2 seznamu funkce Automatické dokončování.

Kopírování seznamu funkce Automatické dokončování v aplikaci Outlook 2007, přejděte na následující web společnosti Microsoft:

Kopírování seznamu funkce Automatické dokončování do jiného počítače

Jak odebrat seznam položek automatického dokončování jeden najednou

Odebrání položek z jedné položky mezipaměti automatického dokončování najednou, postupujte takto:
  1. Otevřete novou e-mailovou zprávu.
  2. Zadejte prvních několika znaků položky automatického dokončování, která chcete odebrat.
  3. Pokud tato položka se objeví v seznamu navrhované názvy, přesuňte ukazatel myši nad název zvýrazněna, ale neklepejte na název.
  4. "X" Ikona vedle názvu zvýrazněné, X , chcete-li odebrat jméno ze seznamu klepnutím na tlačítko nebo stiskněte klávesu Delete na klávesnici.

Jak vymazat celý seznam automatického dokončování

Tato část vysvětluje, jak odstranit seznam automatického dokončování.
Aplikace Outlook 2010, aplikace Outlook 2013 a Outlook 2016

Odstranění seznamu funkce Automatické dokončování v aplikaci Outlook 2010, aplikace Outlook 2013 a 2016 aplikace Outlook pomocí jedné z následujících dvou metod.Metoda 1

  1. Spusťte aplikaci Outlook.
  2. Na kartě Soubor klikněte na příkaz Možnosti.
  3. Klepněte na kartu Pošta .
  4. V části Odeslat zprávyklepněte na tlačítko Prázdný seznam automatického dokončování.
  5. Klikněte na tlačítko Ano.
Metoda 2Spusťte aplikaci Outlook s přepínačem /CleanAutoCompleteCache. Chcete-li to provést, postupujte takto:
  1. Klikněte na tlačítko Start a potom na příkaz Spustit.
  2. Typ Outlook.exe /CleanAutoCompleteCache. Poznámka: Pokud aplikace Outlook není nainstalována ve výchozím umístění, musí odkazovat na cestu Outlook.exe.
Aplikace Outlook 2003 a Outlook 2007
Odstranění seznamu funkce Automatické dokončování v aplikaci Outlook 2003 a Outlook 2007, je nutné ručně odstranit soubor NK2. Chcete-li soubor NK2 odstranit, postupujte takto:
  1. Ukončete aplikaci Outlook.
  2. Klepněte na tlačítko Starta potom na příkaz počítač.
  3. Klepněte na tlačítko Uspořádata potom klepněte na příkaz Možnosti složky a hledání.
  4. Na kartě zobrazení zaškrtněte políčko Zobrazit skryté soubory, složky a jednotky.
  5. Klepněte na tlačítko OK.
  6. Klepněte na tlačítko Start, přejděte na příkaz Všechny programy, klepněte na položku Příslušenství a potom klepněte na příkaz Spustit.
  7. V dialogovém okně Spustit zadejte následující příkaz (včetně uvozovek) a potom klepněte na tlačítko OK: "C:\ \AppData\Roaming\Microsoft\Outlook Users\uživatelské jméno"Poznámka:uživatelské jméno v této cestě je jméno aktuálně přihlášeného uživatele na uživatele systému Windows.
  8. Klepněte pravým tlačítkem myši. Soubor NK2, který má název profilu, který chcete obnovit a potom klepněte na příkaz Přejmenovat.
  9. Přejmenujte soubor jako Název_profiluBAKa stiskněte klávesu Enter.
  10. tart aplikace Outlook.
 

Problémy s mezipaměti automatického dokončování

Tato část popisuje známé problémy, které mohou nastat u mezipaměti automatického dokončování. Automatické dokončování mezipaměti mohou být poškozeny v průběhu času a nelze uložit nové položky. V takovém případě můžete odebrat jednotlivé položky ze seznamu. Chcete-li to provést, naleznete v části "Jak odebrat seznam položek automatického dokončování jeden najednou." Pokud se problém nevyřeší, můžete obnovit celý seznam automatického dokončování. Chcete-li to provést, naleznete v části "Jak vymazat celý seznam automatického dokončování."

Jak změnit limit pro dokončování

Vzhledem k tomu, že tato konfigurace netestované, nedoporučujeme jej. Pokud máte větší seznamu funkce Automatické dokončování, můžete také ztratit větší počet položek v mezipaměti Pokud mezipaměť automatické dokončování z důvodu poškození nepoužitelný. Uvedena tato právní omezení, můžete použít následující údaje registru zvyšte limit seznamu funkce Automatické dokončování v aplikaci Outlook.Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému Windows
  1. Ukončete aplikaci Outlook.
  2. Spusťte Editor registru.
    • V systému Windows 8.x, stiskněte klávesu Windows, zadejte příkaz regedit a stiskněte klávesu Enter.
    • V systému Windows 7 a Windows Vista klepněte na tlačítko Start, do pole Zahájit hledání zadejte regedit a stiskněte klávesu Enter.
  3. Vyhledejte následující podklíč registru a vyberte jej:
    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck
    Poznámka: Zástupný symbol x.0 v tomto podklíči registru představuje verzi sady Microsoft Office. Použijte odpovídající hodnotu z následujícího seznamu. Aplikace Outlook 2016 = 16,0 Aplikace Outlook 2013 = 15.0 Aplikace Outlook 2010 = 14.0 Aplikace Outlook 2007 = 12.0 Aplikace Outlook 2003 = 11.0
  4. V nabídce Úpravy přejděte na příkaz Novýa klepněte na příkaz Hodnota DWORD.
  5. Zadejte MaxNickNamesa stiskněte klávesu Enter.
  6. V nabídce Úpravy klikněte na příkaz Změnit.
  7. Zadejte novou hodnotu pro omezení a potom klepněte na tlačítko OK. Poznámky
    • Ujistěte se, zadejte číslo v ddesítkové formuláře. To je správný formulář pro zadání čísla.
    • Zkuste zvětšit limit mezní částku k testování nového limitu. Chcete-li vytvořit 20 procent zvýšení limitu v aplikaci Outlook 2013, byste měli zadat 1200 pro hodnotu MaxNickNames.
  8. Ukončete program Editor registru.
  9. Spusťte Outlook.
Poznámka: Hodnota registru MaxNickNames pouze určuje jiný limit. Proto také můžete tuto hodnotu snížit limit mezipaměti přezdívek.