Minimalizace metadat v sešitech aplikace Excel

Souhrn

Tento článek popisuje různé metody, které lze použít v zájmu minimalizace metadat v sešitech.

Při vytvoření, otevření nebo uložení sešitu v aplikaci Microsoft Excel sešit může obsahovat obsah, který nechcete sdílet s ostatními při elektronické distribuci sešitu. Tyto informace se nazývají metadata. Metadata se používají pro různé účely zvýšit úpravy, zobrazení, archivace a načítání dokumentů systému Office.

Některá metadata jsou snadno přístupné prostřednictvím uživatelského rozhraní aplikace Excel. Ostatní metadata jsou přístupná pouze pomocí speciálních metod, jako je například otevřením sešitu v editoru nízkoúrovňové binární soubor.


Následuje několik příkladů metadat, které mohou být uloženy v sešitu:
  • Tvoje jméno
  • Iniciály
  • Název společnosti nebo organizace
  • Název počítače
  • Název síťového serveru nebo pevného disku, kam jste uložili sešit
  • Další vlastnosti a souhrnné informace o souboru
  • Neviditelné části vložené objekty OLE
  • Revize dokumentu
  • Skrytý text nebo buňky
  • Osobní zobrazení
  • Komentáře

Další informace

Metadata je vytvořena v mnoha různými způsoby v sešitech aplikace Excel. V důsledku toho je neexistuje jediná metoda odebrání takového obsahu ze sešitů. Následující části popisují oblasti, kde může být metadata uložena v sešitech aplikace Excel.

Nainstalujte nejnovější aktualizaci

Následující aktualizace jsou k dispozici.
Další informace o těchto aktualizacích získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

Aktualizace Office XP historie 305095

Přehled a historie aktualizace Excel 2000 269356

232652 přehled a historie oprav aplikace Excel

Jak odstranit uživatelské jméno z programů

Chcete-li zobrazit nebo změnit své uživatelské jméno, postupujte takto:
  1. V nabídce Nástroje klepněte na příkaz Možnosti. Klepněte na kartu Obecné . Zobrazí textové pole uživatelské jméno .
  2. Pokud nechcete, aby některé z těchto informací v sešitu, zadejte do textového pole neidentifikační informace nebo mezery a klepněte na tlačítko OK potvrďte změny.
Všechny nové sešity, které vytvoříte, bude obsahovat tyto informace namísto výchozích hodnot, které jste zadali při první instalaci sady Office. Však existující sešity mohou obsahovat již tyto informace.

Jak odebrat osobní souhrnné informace

Při vytvoření nebo uložení sešitu v aplikaci Microsoft Excel, mohou být v sešitu uloženy souhrnné informace. Existuje několik metod, které lze použít k získání přístupu k těmto informacím:
  • Otevřete sešit. V nabídce soubor klepněte na příkaz Vlastnosti. Všechny Souhrn, Statistika, obsaha vlastní karty mohou obsahovat různé vlastnosti, jako je například vaše jméno, jméno vašeho manažera a název společnosti.
  • V Průzkumníkovi Windows klepněte pravým tlačítkem myši sešit a potom v místní nabídce klepněte na příkaz Vlastnosti . Na kartách v dialogovém okně Vlastnosti mohou obsahovat informace, které chcete odebrat.
  • Číst vlastnosti zobrazené v dialogovém okně Vlastnosti můžete použít Microsoft Visual Basic for Applications makro nebo jiný programový kód.
Chcete-li odebrat souhrnné informace z existujícího sešitu nebo šablony, postupujte takto:
  1. Otevřete sešit nebo šablonu.
  2. V nabídce soubor klepněte na příkaz Vlastnosti.
  3. Na kartě Souhrn odstraňte text v Autor, Správce, Společnosta dalších textových polích, které nechcete distribuovat.
  4. Na kartě vlastní odstraňte všechny vlastnosti obsahující informace, které nechcete distribuovat.
  5. Po dokončení klepněte na tlačítko OK. V nabídce soubor klepněte na tlačítko Uložit.
  6. V nabídce soubor klepněte na tlačítko Zavřít.
Po dokončení těchto kroků sešit nebude obsahovat souhrnné vlastnosti.

Odebrat osobní souhrnné informace při připojení k síti

Pokud jste přihlášeni k síti, může vaše síťové uživatelské jméno zobrazí v Autor textové pole, na kartě Souhrn a uložil pole na kartě Statistika při uložení sešitu. Tato situace může nastat, i když jste odebrali všechny osobní informace z vašeho počítače.

Chcete-li ze sešitu odebrat souhrnné informace, když jste připojeni k síti, postupujte takto:
  1. Pokud je sešit uložen na síťovém serveru, zkopírujte sešit na místní pevný disk.
  2. Spusťte počítač, ale proveďte není přihlášení k síti. Jakmile se zobrazí dialogové okno přihlášení sítě, klepněte na tlačítko Storno nebo stisknutím klávesy ESC.

    Poznámka: Pokud nelze spustit systém Windows stisknutím klávesy ESC (například počítače se systémem Microsoft Windows NT), tyto kroky nelze pokračovat.
  3. Otevřete sešit.
  4. V nabídce soubor klepněte na příkaz Vlastnosti.
  5. Na kartě Souhrn odstraňte text v Autor, Správce, Společnosta dalších textových polích, které obsahují informace, které nechcete distribuovat.
  6. Na kartě vlastní odstraňte všechny vlastnosti obsahující informace, které nechcete distribuovat.
  7. Až skončíte, klepněte na tlačítko OK. V nabídce soubor klepněte na tlačítko Uložit.
  8. V nabídce soubor klepněte na tlačítko Zavřít.
Při přihlášení k síti, Neotevírejte soubor. Pokud tak učiníte, vaše síťové uživatelské jméno může být zapsáno do souboru. Můžete však použít Průzkumníka Windows kopírování souboru na síťový server nebo na disketu.

Jak odebrat komentáře v sešitech

Aplikace Microsoft Excel nabízí možnost přidat poznámky do sešitů. Komentáře obvykle obsahují jméno osoby, který je vytvořil.

Komentáře se zobrazí jako malý červený trojúhelník v pravém horním rohu buňky v aplikaci Microsoft Excel. Chcete-li zobrazit komentáře, klepněte pravým tlačítkem myši na buňku a v místní nabídce klepněte na příkaz Odstranit komentář .

Nové komentáře, které vytvoříte by neměla obsahovat uživatelské jméno, protože byste ho odstranili z dialogového okna Možnosti , jak je popsáno v části "Jak k odstranit svůj uživatelský název z vaše programy" dříve v tomto článku.

Jak odstranit informace ze záhlaví a zápatí

Záhlaví a zápatí v sešitech mohou obsahovat identifikační informace. Chcete-li odstranit informace ze záhlaví a zápatí, postupujte takto:
  1. Otevřete sešit.
  2. V nabídce soubor klepněte na příkaz Vzhled stránky. Klepněte na kartu Záhlaví a zápatí a potom změnit záhlaví a zápatí, takže neobsahují žádné identifikační informace.
  3. Jakmile budete hotovi, klepněte na tlačítko OK.
Všimněte si, že každý list v sešitu obsahuje vlastní záhlaví a zápatí, takže je nutné opakovat tento proces na každém listu.

Jak odstranit ze sešitů hypertextové odkazy

Sešity mohou obsahovat hypertextové odkazy na jiné dokumenty nebo webové stránky v síti intranet nebo Internet. Hypertextové odkazy se obvykle zobrazují jako modré podtržené textové řetězce.

Ze sešitu ručně odstranit jeden hypertextový odkaz, klepněte pravým tlačítkem myši na hypertextový odkaz v místní nabídce přejděte na příkaz hypertextový odkaz a potom klepněte na příkaz Odebrat hypertextový odkaz.

Chcete-li odstranit všechny hypertextové odkazy v sešitu, můžete použít Visual Basic pro makro aplikace.
Další informace o tom, jak vytvořit toto makro klepněte na následující čísla článku zobrazení v článcích znalostní báze Microsoft Knowledge Base:

213790 žádný příkaz nabídky vyberte všechny hypertextové odkazy v rámci sešitu

156353 žádná volba nabídky vyberte všechny hypertextové odkazy

Jak odebrat styly ze sešitů

Sešity aplikace Microsoft Excel může obsahovat styly, které obsahují metadata. Můžete tyto styly odstranit nebo přejmenovat. Chcete-li to provést, postupujte takto:
  1. Otevřete sešit obsahující styly.
  2. V nabídce Formát klepněte na styl.
  3. Vyberte styl, který chcete odstranit nebo přejmenovat. Klepněte na tlačítko Odstranit odstranit styl, nebo v rozevíracím seznamu název styluklepněte na položku a zadejte nový název stylu, chcete-li přejmenovat styl.

Jak zobrazit skryté buňky, řádky a sloupce v sešitech aplikace Excel

V aplikaci Microsoft Excel je možné skrýt celé řádky nebo sloupce buněk v listu.

Chcete-li zobrazit všechny buňky v listu, postupujte takto:
  1. Klepněte na tlačítko Vybrat vše v levém horním rohu listu. Nebo stiskněte kombinaci kláves CTRL + SHIFT + MEZERNÍK.
  2. V nabídce Formát přejděte na řádeka klepněte na příkaz Zobrazit.
  3. V nabídce Formát přejděte na příkaz sloupeca klepněte na příkaz Zobrazit.
Všechny buňky jsou nyní viditelné.

Poznámka: buňku může ještě jeho výška nebo šířka nastavena na velmi nízkou hodnotu, což špatně viditelné buňky. Pokud je to tento případ, postupujte takto:
  1. Klepněte na tlačítko Vybrat vše v levém horním rohu listu. Nebo stiskněte kombinaci kláves CTRL + SHIFT + MEZERNÍK.
  2. V nabídce Formát přejděte na řádeka potom klepněte na příkaz Přizpůsobit.
  3. V nabídce Formát přejděte na příkaz sloupeca klepněte na příkaz Přizpůsobit.
To způsobí, že všechny buňky, které změní velikost zobrazení jejich obsahu.


Všimněte si, že je stále možné pro obsah buněk bude obtížné vidět; Například pokud obsah buňky jsou formátovány na použití bílé písmo buňky barvou pozadí je bílá. Chcete-li změnit vlastnosti jejich písma vybrané buňky, klepněte na příkaz buňky v nabídce Formát a potom klepněte na kartu písmo .

Jak zobrazit skryté listy v sešitech aplikace Excel

Sešity aplikace Microsoft Excel může obsahovat skryté listy, které obsahují informace. Chcete-li zobrazit listy, přejděte na příkaz list v nabídce Formát a klepněte na příkaz Zobrazit. Pokud skrytý list můžete vybrat list a klepněte na tlačítko OK.

Poznámka: Pokud příkaz Zobrazit není k dispozici, neexistují žádné skryté listy nebo sešit je chráněn. V nabídce Nástroje přejděte na příkaz Zámeka potom klepněte na příkaz Odemknout sešit. Pokud se zobrazí výzva k zadání hesla, zadejte jej odemknout sešit.

Jak odebrat propojení ze sešitů aplikace Microsoft Excel

Sešity aplikace Microsoft Excel může obsahovat vzorce, které odkazují na buňky v jiných sešitech. Pokud odešlete sešit, který obsahuje odkazy na jiné uživatele, bude moci zjistit názvy z jiných sešitů pomocí dialogové okno odkazy .

Pokud chcete odebrat propojení ze sešitu, musíte odebrat všechny odkazy na jiné sešity ze vzorců v sešitě. Tento postup je možné provést:
  1. V nabídce Úpravy klepněte na příkaz propojení.
  2. Vyberte název sešitu, do kterého již nechcete propojit a klepněte na tlačítko Změnit zdroj.
  3. Vyberte sešit, který právě upravujete; Například pokud upravujete C:\Data\Test.xls, vyberte C:\Data\Test.xls. Potom klepněte na tlačítko OK.
  4. Opakujte kroky 2 a 3 pro další sešit, se kterým je spojen tento sešit.
  5. Jakmile budete hotovi, klepněte na tlačítko OK.
Poznámka: pomocí těchto kroků mohou ovlivnit výsledky vzorců v sešitě; může dokonce způsobit některé vzorce vrátit nesprávné výsledky.

Jiný způsob odebrání propojení na jiné sešity je převést na jejich výsledky vzorců. Chcete-li to provést, postupujte takto:
  1. Vyberte buňku obsahující vzorec, který je propojen na jiný sešit.
  2. V nabídce Úpravy klepněte na příkaz Kopírovat.
  3. V nabídce Úpravy klepněte na příkaz Vložit jinak. Klepněte na položku hodnotya potom klepněte na tlačítko OK.
Vzorec je nyní pryč, ale výsledek vzorce zůstane.

Jak odstranit sledované změny ze sdílené sešity

Aplikace Microsoft Excel zahrnuje funkce sledování změn, který umožňuje sledovat změny provedené ve sdíleném sešitu uživatelem. Odebrání sledovaných změn ze sešitu, postupujte takto:
  1. Otevřete sešit.
  2. V nabídce Nástroje přejděte na příkaz Sledování změna potom klepněte na příkaz Zvýraznit změny.
  3. Zrušte zaškrtnutí políčka (zrušte zaškrtnutí) políčko sledovat změny během úprav . Klepněte na tlačítko OK
  4. Klepnutím na tlačítko Ano vraťte sešitu výhradní použití režimu (je sešit již sdílený).

Odstranění zobrazení z sešity aplikace Microsoft Excel

Vlastní zobrazení v aplikaci Microsoft Excel sešity mohou obsahovat vaše jméno, zejména pokud používáte sdílené sešity.

Chcete-li ze sešitu odstranit zobrazení, postupujte takto:
  1. V nabídce Zobrazit klepněte na tlačítko Vlastní zobrazení.
  2. Vyberte libovolné zobrazení, který obsahuje vaše jméno nebo jiné identifikační údaje a klepněte na tlačítko Odstranit.
Všimněte si, že odstranění zobrazení může ovlivnit způsob tisku sešitu při tisku sestav pomocí Správce sestav.

Jak odstranit informace o směrovací adrese ze sešitu

Při odeslání sešitu prostřednictvím e-mailu pomocí směrovací adresy, mohou být připojeny informace o směrování sešitu. Chcete-li odebrat tyto informace ze sešitu, je nutné uložit sešit ve formátu, který není zachována informace o směrovací adrese.

V aplikaci Microsoft Excel uložte sešit ve starším formátu souboru, například formátu SYLK, 4.0 aplikace Excel nebo Lotus 1-2-3. Zavřete sešit a potom znovu otevřete nový soubor. Protože informace o směrovací adrese již není přítomen, můžete nyní uložit soubor ve formátu Sešit Microsoft Excel.


Můžete také postupujte takto:
  1. V nabídce soubor přejděte na příkaz Odeslata potom klepněte na příkaz Další příjemce směrování.
  2. Klepněte na tlačítko Vymazat odstranit směrovací adresu. Potom klepněte na tlačítko OK.
  3. V nabídce soubor klepněte na tlačítko Uložit.
Sešit je nyní uložen bez jakékoli informace o směrovací adrese.

Jak odstranit e-mailovou adresu informace ze sešitu

Informace o příjemci pošty zůstane v dokumentu sady Office při odeslání zprávy pomocí možnosti Odeslat soubor sady Microsoft Office XP. Excel 2002 zachová KOMU, kopie a SKRYTÁ e-mailové adresy, pokud použijete možnost Příjemce odeslat soubor a záhlaví e-mailu je aktivován v místě dokumentu.

Chcete-li tyto informace odebrat, postupujte takto:
  1. Soubor je otevřen vyberte Možnosti v nabídce Nástroje .
  2. Klepněte na kartu zabezpečení a zaškrtněte políčko uložení odebrat osobní informace z vlastností na uložení souboru .
  3. Klepněte na tlačítko OK zavřete Možnosti vyberte dialiog a potom soubor uložit.
Soubor je uložen bez zachování e-mailové adresy.

Jak odstranit své jméno z kódu jazyka Visual Basic

Při záznamu makra jazyka Visual Basic v aplikaci Microsoft Excel, zaznamenané makro začíná záhlaví je podobná následující:
   ' Macro1 Macro   ' Macro recorded 3/11/1999 by J. Doe

Chcete-li odebrat své jméno z makra, které jste nahráli, postupujte takto:
  1. Otevřete sešit obsahující makra.
  2. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz Editor jazyka Visual Basic. Nebo stiskněte klávesy ALT + F11.
  3. V okně projektu poklepejte na modul, který obsahuje makra.
  4. Odstraňte své jméno z kódu zaznamenaného makra.
Po dokončení, stiskněte klávesu ALT + Q vraťte do programu. Potom klepněte na tlačítko Uložit v nabídce soubor .

Jak odstranit Visual Basic odkazy na jiné soubory

V editoru jazyka Visual Basic, můžete vytvořit odkaz na jiný soubor. Pokud uživatel otevře sešit, který obsahuje odkazy na jiné soubory, může uživatel zobrazit názvy odkazovaných souborů.

Chcete-li odstranit tyto odkazy, postupujte takto:
  1. Otevřete sešit, který obsahuje odkazy.
  2. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz Editor jazyka Visual Basic. Nebo stiskněte klávesy ALT + F11.
  3. V nabídce Nástroje klepněte na odkazy.
  4. Klepnutím zrušte zaškrtnutí políčka vedle odkazovaný soubor. Po dokončení klepněte na tlačítko OK zavřete dialogové okno odkazy - VBAProject .
  5. Stiskněte klávesy ALT + Q.
  6. V nabídce soubor klepněte na tlačítko Uložit.
Poznámka: Odstranit odkazy na jiné soubory, může negativně ovlivnit schopnost makra v sešitě pracovat správně.

Jak odstranit ze sešitu sítě nebo informace o pevném disku

Pokud uložíte sešit na místní pevný disk nebo síťový server, může být informace identifikující místní pevný disk nebo síťový server zapsáno do sešitu.

Chcete-li odstranit tyto informace ze sešitu, postupujte takto:
  1. Otevřete sešit.
  2. V nabídce soubor klepněte na příkaz Uložit jako. Sešit uložte do disketové jednotky (obvykle A:).
  3. V nabídce soubor klepněte na tlačítko Zavřít.
  4. Vyjměte disketu z disketové jednotky.
Nyní můžete programu Průzkumník Windows zkopírujte sešit z diskety libovolný pevný disk nebo síťový server.

Poznámka: Vzhledem k omezenému prostoru diskety (obvykle 1,44 MB) nelze tuto metodu použít, pokud velikost souboru sešitu překračuje velikost volného místa na disketě.

Vložené objekty v sešitech mohou obsahovat Metadata

Pokud vložíte do sešitu objekt, objekt zůstane stále své vlastní vlastnosti, bez ohledu na to, proveďte v sešitu. Například pokud vložíte dokument Microsoft Word v sešitu aplikace Microsoft Excel, dokument a sešit, mají své vlastní vlastnosti.

Můžete odstranit metadata z vloženého objektu pomocí otevření objektu, odebrání libovolného metadat opětovná aktivace dokument kontejneru (v předchozím příkladu je tento sešit aplikace Excel) a potom uložíte dokument kontejneru.

Poznámka: Při otevření vloženého objektu v sešitu pouze část vložený objekt se zobrazí v sešitu. Objekt může obsahovat další informace, které se nezobrazí. Pokud chcete sešit obsahovat pouze vykreslení vloženého objektu a nikoliv jeho skutečný obsah, postupujte takto:
  1. Vyberte objekt. V nabídce soubor klepněte na příkaz Vyjmout.
  2. V nabídce Úpravy klepněte na příkaz Vložit jinak a vložte objekt do sešitu pomocí formátu Metafile.
Po to provést nelze upravit vložený objekt; objekt však nebude obsahovat žádné metadata.

Jak odebrat jedinečné identifikátory z dokumentů sady Office 97

Vzhledem k tomu, které jsou součástí Microsoft Office 97 programy dokumenty, které jsou vytvořeny nebo uložit v aplikacích sady Office 97 mohou obsahovat jedinečný identifikátor.
Další informace o tyto identifikátory a jak je odstranit klepněte na následující číslo článku databáze Microsoft Knowledge Base:

222180 jak a proč jedinečné identifikátory jsou vytvořeny v dokumentech sady Office

Poznámka: Tento jedinečný identifikátor neexistuje v novějších verzích sady Microsoft Office.

Obecná doporučení týkající se zabezpečení

Následuje několik obecných doporučení, které lze použít, chcete-li zvýšit úroveň zabezpečení vašeho výpočetního prostředí:
  • Pokud nepracujete u svého počítače, zabezpečte počítače spořič obrazovky chráněný heslem, power-on hesla nebo uzamčení funkce systému Windows NT.
  • Pokud váš počítač má všechny sdílené složky, přesvědčte se, zda použít hesla ke sdíleným složkám tak, aby pouze oprávnění uživatelé přístup. Pro ještě lepší zabezpečení pomocí řízení přístupu na úrovni uživatele, takže můžete řídit přesně kdo má přístup k sdílené složky v počítači.
  • Při odstranění souboru ihned vysypte Koš. Můžete zvážit použití nástroje, které zcela vymaže nebo přepíše soubory při jsou odstraněny.
  • Po zálohování dat uložte záložní soubory zabezpečeného umístění, například bezpečné, pole vkladové zabezpečení nebo uzamčená skříňka. Jednu kopii záložní soubory na bezpečném místě mimo místo úložiště v případě primárního umístění nepoužitelný.
  • Důležité dokumenty by měly být chráněné heslem, aby zajistily, že pouze oprávnění uživatelé mohou otevírat. Hesla by měla uloženy v bezpečném odděleném místě. Všimněte si, že pokud zapomenete heslo, je způsob, jak obnovit obsah dokumentu chráněného heslem.
  • Nedistribuujte dokumenty v elektronické podobě. Místo toho tisknout. Není použít identifikační prvky, jako jsou charakteristická písma, vodoznaky, loga nebo speciální papír, pokud není nezbytné (například pro prezentaci).
  • E-mailu není anonymní. E-mailem dokument Pokud máte obavy o vaši identitu žádným způsobem k dokumentu připojeno.
  • Neodesílejte dokument přes Internet pomocí protokolů HTTP nebo FTP. Informace odeslané prostřednictvím těchto protokolů je odeslána jako "prostý text", což znamená, že je technicky možné (byť nepravděpodobné) informace, které mají být zachyceny.

Další informace

Další informace o tématech, které jsou zmíněny v tomto článku získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

223396 jak lze minimalizovat metadata v dokumentech sady Office

222180 jak a proč jedinečné identifikátory jsou vytvořeny v dokumentech sady Office

314800 jak minimalizovat metadata v prezentacích aplikace PowerPoint 2002

314797 jak lze minimalizovat metadata v prezentacích aplikace PowerPoint

Jak 223793 Minimalizace metadat v prezentacích aplikace PowerPoint

Jak 290945 Minimalizace metadat v aplikaci Microsoft Word 2002

237361 jak lze minimalizovat metadata v dokumentech aplikace Microsoft Word 2000

Jak 223790 Minimalizace metadat v dokumentech aplikace Microsoft Word

Vlastnosti

ID článku: 223789 - Poslední kontrola: 10. 1. 2017 - Revize: 1

Váš názor