Při spuštění procesu synchronizace aplikace Outlook z aplikace Microsoft Office Outlook pro synchronizaci s produktem Microsoft Dynamics NAV dojde k vypršení časového limitu


Tento článek se týká aplikace Microsoft Dynamics NAV ve všech zemích a všechna národní prostředí jazyka.

Příznaky


Při spuštění procesu synchronizace aplikace Outlook z aplikace Microsoft Office Outlook pro synchronizaci s Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1), Microsoft Dynamics NAV 2009 nebo Microsoft Dynamics NAV 2009 SP1, Microsoft Dynamics NAV Application Server (NAS) generuje následující chybová zpráva:
Nebyla přijata odpověď z aplikace Microsoft Dynamics NAV z důvodu vypršení časového limitu připojení. Zkontrolujte, zda je spuštěn server Microsoft Dynamics NAV a opakujte akci později. Pokud potíže potrvají, zvyšte hodnotu časového limitu v konfiguračním souboru.

K tomuto problému dochází, pokud v tabulce Položka protokolu změn (405) obsahuje velký počet záznamů.

Příčina


K tomuto problému dochází z některého z následujících důvodů:
  • Poslední pokus o synchronizaci nebyla úspěšná.
  • Pokud nedávno nebyl spuštěn proces synchronizace, se provádí skenování celé tabulky zkontrolujte změny v tabulce Položka protokolu změn (405). To způsobí chybu vypršení časového limitu, pokud v tabulce Položka protokolu změn obsahuje velký počet záznamů.

Řešení


Informace o opravě hotfix

Podporovaná oprava hotfix je nyní k dispozici od společnosti Microsoft. Však je určena pouze k odstranění problému popsaného v tomto článku. Použijte ji pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud jste závažně tento problém, doporučujeme počkat na další aktualizaci service pack produktu Microsoft Dynamics NAV nebo další verzi, která obsahuje tuto opravu hotfix.

Poznámka: Ve zvláštních případech poplatky, které jsou třeba obvykle zaplatit za telefonní hovory mohou být stornovány, jestliže pracovník technické podpory společnosti Microsoft Dynamics a souvisejících produktů Určuje, že konkrétní aktualizace odstraní váš problém. Výdaje na technickou podporu použije dalších otázek a problémů, které nelze vyřešit konkrétní aktualizací.



Informace o instalaci

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci bez žádné záruky výslovně uvedené nebo odvozené. To zahrnuje, ale není omezen pouze na předpokládané záruky obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že jste obeznámeni s programovacím jazykem, který je předmětem ukázky a s nástroji, které slouží k vytvoření a ladění skriptu. Pracovníci podpory společnosti Microsoft mohou pomoci vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo vytvářet postupy podle vašich konkrétních požadavků.

Poznámka: Před instalací této opravy hotfix ověřte, že všichni uživatelé klienta Microsoft Navision odhlášeni systému. To zahrnuje uživatele klienta Microsoft Navision Application Services (NAS). Je třeba klienta pouze uživatel přihlášený při implementaci opravy hotfix.

Chcete-li implementovat tuto opravu hotfix, musí mít licenci vývojáře.

Doporučujeme, aby uživatelský účet v okně přihlášení systému Windows nebo v okně přihlášení databáze přidělí "SUPER" ID role. Pokud uživatelský účet nelze přiřadit ID role "SUPER", musíte ověřit, že uživatelský účet má následující oprávnění:
  • Změnit oprávnění pro objekt, který budete měnit.
  • Oprávnění ke spuštění pro System Object ID 5210 objekt a System Object ID 9015 objekt.


Poznámka: Nemáte práva k úložištím dat. Pokud nebudete provádět opravu dat.

Změny kódu

Poznámka: Vždy otestujte opravy kódu v kontrolovaném prostředí před instalací opravy v provozních počítačích.

Chcete-li nainstalovat tuto opravu hotfix, změňte kód ve funkci RemoveChangeLogDuplicates v Nastavení uživatele Synch. NAV Mgt procedura (5301) takto:
Existující kód
...ChangeLogEntry.SETCURRENTKEY("Table No.","Date and Time");
TempChangeLogEntry.RESET;
TempChangeLogEntry.DELETEALL;

IF ChangeLogEntry.FIND('+') THEN
REPEAT
IF ChangeLogEntry."Primary Key" <>TempChangeLogEntry."Primary Key" THEN BEGIN
TempChangeLogEntry.SETRANGE("Primary Key",ChangeLogEntry."Primary Key");
IF NOT TempChangeLogEntry.FIND('-') THEN BEGIN
TempChangeLogEntry.INIT;
TempChangeLogEntry := ChangeLogEntry;
TempChangeLogEntry.INSERT;
END;
END;
UNTIL ChangeLogEntry.NEXT(-1) = 0;

TempChangeLogEntry.RESET;
...

Změněný kód
...ChangeLogEntry.SETCURRENTKEY("Table No.","Date and Time");
ChangeLogEntry.SETFILTER("Date and Time" , '>=%1', OSynchUserSetup."Last Synch. Time"); // Add this line.
TempChangeLogEntry.RESET;
TempChangeLogEntry.DELETEALL;

IF ChangeLogEntry.FIND('+') THEN
REPEAT
IF ChangeLogEntry."Primary Key" <>TempChangeLogEntry."Primary Key" THEN BEGIN
TempChangeLogEntry.SETRANGE("Primary Key",ChangeLogEntry."Primary Key");
IF NOT TempChangeLogEntry.FIND('-') THEN BEGIN
TempChangeLogEntry.INIT;
TempChangeLogEntry := ChangeLogEntry;
TempChangeLogEntry.INSERT;
END;
END;
UNTIL ChangeLogEntry.NEXT(-1) = 0;

TempChangeLogEntry.RESET;
...

Předpoklady

Musí mít jednu z následujících produktů nainstalovali tuto opravu hotfix:
  • Aplikace Microsoft Dynamics NAV 2009 SP1
  • Microsoft Dynamics NAV 2009
  • Microsoft Dynamics NAV 5.0 SP1

Informace o odinstalaci

Tato oprava hotfix nelze odebrat.

Stav


Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Poznámka: Toto je článek "Rychlé publikování" vytvářen přímo v rámci odborné pomoci společnosti Microsoft. Informace obsažené v tomto dokumentu jsou poskytovány tak, jak je v reakci na vznikající problémy. V důsledku rychlosti v jeho zpřístupnění materiály, mohou obsahovat typografické chyby a mohou být upraveny kdykoli bez předchozího upozornění. Viz Podmínky použití pro další aspekty.