Služba Webový klient selže v systému Windows Server 2003 při odhlášení uživatele a služby UPHClean nástroj slouží k uvolnění profilu uživatele


Příznaky


Jde o takovouto situaci:
  • Máte počítač se systémem Windows Server 2003 Service Pack 2 (SP2).
  • Uvolnění profily uživatelů při odhlášení uživatele z počítače můžete použít nástroj User Profile Hive Cleanup Service (UPHClean).
  • Máte aplikaci, která pomocí služby Webový klient přistupuje k protokol WebDAV (Web Distributed Authoring and Versioning) sdílené složky (WebDAV).
  • Odhlášení uživatele.
V tomto scénáři může dojít k selhání služby Webový klient. Dojde-li k této chybě, ostatní uživatelé v počítači nemůže přístup WebDAV sdílené složky déle.

Příčina


Při odhlášení uživatele odstraní UPHClean nástroj některé klíče registru související v profilu tohoto uživatele. Pokud je služba Webový klient se pokusí o přístup jeden klíč, který je odstraněna v uživatelském profilu, čtení operace se nezdaří. Však služba Webový klient Chyba čtení nesprávně zpracovává a služba vrátí úspěch pomocí nesprávné hodnoty. V tomto případě služba Webový klient dojde k chybě při přístupu k nesprávné hodnoty.

Řešení


Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Pro úplný seznam telefonních čísel společnosti Microsoft Zákaznikého servisu a podpory nebo chcete-li vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musíte používat systém Windows Server 2003 Service Pack 2 (SP2). Další informace o možnostech získání aktualizace Windows Server 2003 service pack nebo aktualizace service pack systému Windows XP Professional x64 Edition klepněte na následující číslo článku databáze Microsoft Knowledge Base:

889100 jak získat nejnovější aktualizaci service pack pro systém Windows Server 2003

Informace o registrech

Pro použití tohoto hotfixu nemusíte provádět žádné změny v registrech.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o souborech

Angličtina (Spojené státy) verze této opravy hotfix nainstaluje soubory, jejichž atributy, které jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny dle vašeho místního času a také podle aktuálního letního času (DST). Navíc data a časy se mohou změnit při provádění některých operací se soubory.
Poznámky k informacím o soubor systému Windows Server 2003
  • Kromě souborů uvedených v těchto tabulkách tato oprava hotfix také nainstaluje příslušný soubor katalogu zabezpečení (KBčíslo.cat), který je podepsaný digitálním podpisem společnosti Microsoft.
Pro všechny podporované verze systému Windows Server 2003 x86
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Mswsock.dll5.2.3790.4772257,02409-Sep-201012:14x86
Pro všechny podporované verze systému Windows Server 2003 x64
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Mswsock.dll5.2.3790.4772493,05609-Sep-201010:00x64SP2Není k dispozici
Wmswsock.dll5.2.3790.4772234,49609-Sep-201010:00x86SP2WOW
Pro všechny podporované verze IA-64 systému Windows Server 2003
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Mswsock.dll5.2.3790.4772789,50409-Sep-201010:00IA-64SP2Není k dispozici
Wmswsock.dll5.2.3790.4772234,49609-Sep-201010:00x86SP2WOW

Stav


Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace


Další informace o nástroji podregistr služba vyčištění profil uživatele naleznete na následujícím webu společnosti Microsoft:Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft