Default gateway is set to 0.0.0.0 if you start a Windows Vista-based, Windows 7-based, Windows Server 2008-based or Windows Server 2008 R2-based computer from an iSCSI boot device

Symptoms

Assume that you start a Windows Vista-based, Windows 7-based, Windows Server 2008-based or Windows Server 2008 R2-based computer from an iSCSI boot device. Additionally, assume that the values in the default gateway setting in the iSCSI boot solution are all set to zero. Therefore, the default gateway setting is not set in the iSCSI boot solution. In this situation, the default gateway in the computer is set to 0.0.0.0 unexpectedly after the computer starts. Therefore, you experience slow network performance.

Cause

This issue occurs because the default gateway entry in Windows is set to 0.0.0.0 incorrectly. When you start a computer from an iSCSI boot device, Microsoft iSCSI Boot Initiator creates a static route that contains a gateway setting. The gateway setting is specified in the iSCSI boot solution. This route is a system-critical route that you cannot remove.

Because the gateway from the iSCSI Boot solution is specified in the route, the gateway is always used in network activities. This behavior occurs even if the iSCSI target can be reached directly (on-link) and if a gateway is not required to communicate with the iSCSI target. If an address that only contains zeros is specified as a default gateway in the iSCSI Boot Firmware Table (iBFT), the default gateway should not be set on the computer after you start the computer. However, Windows still adds an entry in the default gateway for iSCSI. Therefore, the issue that is described in the "Symptoms" section occurs.

Resolution

Hotfix information

If you use a network adapter that cannot set all values in the default gateway setting to zero, the issue that is described in the "Symptoms" section still occurs. The default gateway in the computer is usually not set to 0.0.0.0. Therefore, after you install the following hotfix, Windows does not set the default gateway entry if the default gateway in the iBFT is set to 0.0.0.0.

Important Microsoft has re-released this hotfix to address an issue in which the digital signature on files that are produced and signed by Microsoft expires prematurely. This issue is described in Microsoft Security Advisory 2749655.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information
Vlastnosti

ID článku: 2727330 - Poslední kontrola: 10. 1. 2013 - Revize: 1

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