Certifikát šíření služby dojde k chybě při odpojení od serveru Windows 7 nebo VP se systémem Windows Server 2008 R2 klient služby RDS

Příznaky

Předpokládá, že máte serveru se systémem Windows 7 nebo systémem Windows Server 2008 R2 Remote Desktop Services (RDS). Připojení klient služby RDS k serveru pomocí karty smart card a poté odpojte připojení ihned. V této situaci selhání služby šíření certifikátů a dalších služeb, které jsou součástí stejné skupiny Svchost na serveru RDS neočekávaně ukončit. V protokolu aplikací je dále zaznamenána následující událost:
 Poznámka: Tento problém se týká následující služby, které jsou obsaženy ve stejné skupině jako šíření certifikační služby Svchost:
  • Aplikace zkušeností služby
  • Aplikace informační služba
  • Služba Správa aplikací
  • Služba šíření certifikátů
  • Služba Zásady skupiny klienta
  • Služba Pomocník IP
  • Služba Server
  • Služba profilů uživatelů
  • Služba Plánovač úloh
  • Služba oznamování událostí systému
  • Služba vzdálené plochy konfigurace
  • Služba rozpoznávání hardwaru prostředí
  • Služba Windows Management Instrumentation
  • Služba Windows Update

Příčina

Tento problém je způsoben spor, který nastane, když klient služby RDS je připojen k serveru a potom odpojen. Dva oddělené podprocesy jsou vytvořeny pro zpracování události připojení a odpojení. Druhé vlákno je z důvodu rasy podmínku odstranit relaci, která používá první vlákno. Proto případě dojde k narušení přístupu v prvním vlákně.

Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Pro úplný seznam telefonních čísel společnosti Microsoft Zákaznikého servisu a podpory nebo chcete-li vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí být spuštěn systém Windows 7 Service Pack 1 (SP1) nebo Windows Server 2008 R2 SP1. Musíte mít v počítači se systémem Windows Server 2008 R2 nainstalována role služby Vzdálená plocha nebo funkce nástroje pro vzdálenou správu serveru nainstalována v počítači se systémem Windows 7.

Další informace o získání aktualizace service pack systému Windows 7 nebo Windows Server 2008 R2 získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:

976932 Informace o aktualizaci Service Pack 1 pro systém Windows 7 a Windows Server 2008 R2

Informace o registrech

Chcete-li nainstalovat tuto opravu hotfix, není nutné provádět žádné změny registru.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.
Informace o souborech

Jak potíže obejít

Chcete-li tento problém vyřešit, restartujte zastavené služby ručně.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:

824684 Popis standardní terminologie používané k popisu aktualizací softwaru společnosti Microsoft

Další informace o souborech
Vlastnosti

ID článku: 2799035 - Poslední kontrola: 12. 1. 2017 - Revize: 1

Váš názor