Aplikace PowerPoint nemůže načíst doplněk, při snížení úrovně zabezpečení maker

Příznaky

Při snížení úrovně zabezpečení maker v aplikaci PowerPoint a otevřete soubor doplňku PowerPoint (* .ppa), nemusí být použita nová úroveň zabezpečení maker a soubor doplňku nemusí fungovat podle očekávání. Doplněk je uveden jako k dispozici doplněk v dialogovém okně Add-Ins , ale není zaškrtnuto políčko a zobrazí chybová zpráva podobná následující při pokusu o zaškrtněte políčko:

Aplikace PowerPoint nemohla načíst doplněk názvu souboru.

Příčina

K tomuto chování může dojít, pokud jsou splněny následující podmínky:

  1. Pokusíte otevřít soubor doplňku PowerPoint pomocí příkazu Otevřít v nabídce soubor a úroveň zabezpečení maker je nastavena na hodnotu Vysoká.
  2. Snížení nastavení úroveň zabezpečení maker.
  3. Otevřete stejný PowerPoint doplněk soubor pomocí příkazu Otevřít v nabídce soubor .
Když se pokusíte otevřít soubor doplňku a doplněk není načten z důvodu zabezpečení maker, PowerPoint ukládá dočasně (mezipaměti) selhání načtení informací o tento doplněk aplikace PowerPoint nemůže načíst doplněk po snížení úrovně zabezpečení maker, dokud ji vymaže informace uložené v mezipaměti.

Jak potíže obejít

Chcete-li tento problém vyřešit, zrušte informace uložené v mezipaměti a potom načtete doplněk podle některou z následujících metod po změně nastavení úroveň zabezpečení maker.

Metoda 1: Ukončete a restartujte PowerPoint

  1. Ukončete aplikaci PowerPoint.
  2. Znovu spustíte aplikaci PowerPoint.
  3. Otevřete soubor doplňku.
  4. Klepněte na tlačítko "Souhlasím" načíst doplněk.

Metoda 2: Odebrat a přidat doplněk

Odebrat a přidat doplněk v aplikaci PowerPoint 2002, postupujte takto:
  1. V nabídce Nástroje klepněte na příkaz Doplňky.
  2. V seznamu Doplňky k dispozici klepněte na požadovaný doplněk a potom klepněte na tlačítko Odebrat.
  3. Klepněte na tlačítko Přidat nový, vyberte doplněk, klepněte na tlačítko OK, klepněte na tlačítko "Souhlasím" načíst doplněk a potom klepněte na tlačítko Zavřít.
Chcete-li odebrat doplněk v aplikaci PowerPoint 2007, postupujte takto:
  1. Klepněte na Tlačítko Microsoft Office, klepněte na tlačítko Možnosti aplikace PowerPointa potom klepněte na tlačítko Add-Ins.
  2. V seznamu Spravovat vyberte položku Doplňky aplikace PowerPointa klepněte na tlačítko Přejít.
  3. V seznamu Doplňky k dispozici vyberte doplněk, který chcete odebrat, klepněte na tlačítko Odebrata potom klepněte na tlačítko Zavřít.
Chcete-li přidat doplněk v aplikaci PowerPoint 2007 postupujte takto:
  1. Klepněte na Tlačítko Microsoft Office, klepněte na tlačítko Možnosti aplikace PowerPointa potom klepněte na tlačítko Add-Ins.
  2. V seznamu Spravovat klikněte na položku Doplňky aplikace PowerPointa klepněte na tlačítko Přejít.
  3. V dialogovém okně Doplňky klepněte na tlačítko Přidat nový.
  4. V dialogovém okně Nová PowerPoint přidat doplněk vyhledejte doplněk, který chcete přidat a klepněte na tlačítko OK.
  5. Zobrazí se upozornění zabezpečení. Pokud jste si jisti, že doplněk pochází z důvěryhodného zdroje, klepněte na tlačítko Povolit makraa potom klepněte na tlačítko Zavřít.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Kroky pro reprodukci problému

Aplikace PowerPoint 2007

  1. Spusťte aplikaci PowerPoint 2007.
  2. Na kartě Vývojář ve skupině kód klikněte na tlačítko Zabezpečení maker .
    Poznámka: Standardně se karta Vývojář nezobrazí. Chcete-li zobrazit kartu Vývojář , klepněte na Tlačítko Microsoft Office, klepněte na tlačítko Možnosti aplikace PowerPoint, vyberte Zobrazit kartu Vývojář na pásu pod Nejpoužívanější možnosti pro práci s aplikací PowerPointa klepněte na tlačítko OK.
  3. Na stránce Centrum zabezpečení klepněte ve skupinovém rámečku Nastavení makerzaškrtněte políčko Zakázat všechna makra s oznámeníma klepněte na tlačítko OK.
  4. V nabídce Office klepněte na tlačítko Otevřít.
  5. V rozevíracím seznamu Typ souboru klepněte na šipku, vyberte Add-Ins(*.ppam;*.ppa) aplikace PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: Doplněk nenačte očekávaným způsobem.
  6. Na kartě Vývojář ve skupině kód klikněte na tlačítko Zabezpečení maker .
  7. Na stránce Centrum zabezpečení vyberte Povolit všechna makra (nedoporučuje; spuštění potenciálně nebezpečného kódu) ve skupinovém rámečku Nastavení makera potom klepněte na tlačítko OK.
  8. V nabídce Office klepněte na tlačítko Otevřít.
  9. V rozevíracím seznamu Typ souboru klepněte na šipku, vyberte Add-Ins(*.ppam;*.ppa) aplikace PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: Nejste vyzváni k povolení nebo zakázání makro. Kromě toho doplněk stále nenačte.

Aplikace PowerPoint 2002

  1. Spusťte aplikaci PowerPoint.
  2. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz zabezpečení.
  3. Na kartě Úroveň zabezpečení klepněte na přepínač vysoké.
  4. V nabídce soubor klepněte na tlačítko Otevřít.
  5. V rozevíracím seznamu Typ souboru klepněte na šipku, vyberte položku Doplňky aplikace PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: doplněk nenačte očekávaným způsobem.
  6. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz zabezpečení.
  7. Na kartě Úroveň zabezpečení klepněte na položku Střední.
  8. V nabídce soubor klepněte na tlačítko Otevřít.
  9. V rozevíracím seznamu Typ souboru klepněte na šipku, vyberte položku Doplňky aplikace PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: nejste vyzváni k povolení nebo zakázání makro a doplněk stále nenačte.
Vlastnosti

ID článku: 285470 - Poslední kontrola: 23. 1. 2017 - Revize: 1

Váš názor