Jak spustit ukázkový kód pro aplikace sady Office XP z článků znalostní báze Knowledge Base

Microsoft Office 2000 verzi tohoto článku naleznete v tématu
212536 .
Microsoft Office 97 verzi tohoto článku naleznete v tématu
173707 .
Microsoft Office 2001 pro Mac verzi tohoto článku v tématu
274703 .
Microsoft Office 98 Macintosh Edition verzi tohoto článku naleznete v tématu
181058 .

Souhrn

Znalostní báze Microsoft Knowledge Base obsahuje počet článků, které zahrnují ukázkový kód pro Visual Basic pro aplikace makra. Mnohé z těchto maker znázorňují základní koncepty programování v jazyce Visual Basic pro různé sady Office XP. Tento článek obsahuje pokyny k vytvoření nového makra použít ukázkový kód a spustit toto makro.

Další informace

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci bez žádné záruky výslovně uvedené nebo odvozené. To zahrnuje, ale není omezen pouze na předpokládané záruky obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že jste obeznámeni s programovacím jazykem, který je předmětem ukázky a s nástroji, které slouží k vytvoření a ladění skriptu. Pracovníci podpory společnosti Microsoft mohou pomoci vysvětlit funkce určitého postupu, nemohou však následující příklady rozšířit o další funkce nebo vytvářet postupy podle vašich konkrétních požadavků. Chcete-li použít ukázkový kód z článku Knowledge Base, musíte přidat nové makro jazyka Visual Basic (nebo vyberte existující makro). Můžete typ vzorku nebo kopírování a vkládání kódu do toto makro pomocí následujících metod.

Chcete-li vytvořit nové makro

  1. Otevřete nebo vytvořte šablonu v aplikaci sady Office, kterou používáte.
  2. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz makra.
  3. V seznamu Prohledat vyberte šablonu aplikace Word nebo dokumentu, kam chcete makro uložit.
  4. V poli Název makra zadejte název makra.
  5. Klepněte na tlačítko vytvořit otevřete Editor jazyka Visual Basic.
  6. Proveďte jednu z následujících akcí:
    • Napište kód makra mezi řádkem Sub Macroname() a End Sub řádku.
      Sub macroname()    Type your macro code here
      End Sub

      - nebo -
    • Zkopírujte a vložte ukázkový kód makra pomocí následujících kroků:
      Sub macroname() 
      End Sub

      1. Přejděte do programu, který používáte k zobrazení v článku znalostní báze Microsoft Knowledge Base, jako je například aplikace Microsoft Internet Explorer.
      2. Vyberte ukázkový kód, stiskněte a podržte klávesu CTRL a potom klepnutím kód.
      3. V nabídce Úpravy klepněte na příkaz Kopírovat.
      4. Přepněte do editoru jazyka Visual Basic.
      5. V editoru jazyka Visual Basic vyberte stávající text kód Sub Macroname() Sub konce makra.
      6. V nabídce Úpravy klepněte na příkaz Vložit.

        Poznámka: Při vkládání, existující kód text nahrazen kód zkopírovaný z článku znalostní báze Knowledge Base.
  7. Po zadáním nebo vložením kód makra, klepněte na tlačítko Zavřít a návrat do Microsoft program v nabídce soubor , kde je program Microsoft Office XP program, který používáte.


Poznámka: text odsadíte pomocí klávesy TAB. Řádky, které začínají apostrof (') jsou komentáře a nejsou potřebné ke spuštění makra. Chcete však zadejte je usnadnit pochopení makro.

Ukázkový kód přidání do modulu

Přidání kódu do modulu, musíte mít existující modul nebo vytvořte nový modul. Chcete-li to provést, postupujte takto:
  1. Otevřete nebo vytvořte šablonu v aplikaci sady Office, kterou používáte.
  2. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz Editor jazyka Visual Basic.
  3. V okně projektu z editoru jazyka Visual Basic (ve výchozím nastavení toto je v levém horním rohu) klepněte na ikonu projekt se stejným názvem jako šablonu nebo dokument. Pokud jste dosud neuložili, šablonu nebo dokument, bude název projektu podobný Project(Document1) nebo TemplateProject(Template1).

    Poznámka pro uživatele aplikace WORD: Pokud chcete uložit makro do výchozí globální šablonu Normal.dot, poklepejte na Normální projektu.
  4. Pokud jste klepli na možnost Projekt neobsahuje složku s názvem moduly pod ním, v nabídce Vložit klepněte na modul .
  5. Klepněte na libovolné místo v okně kódu modulu, který chcete vytvořit. Okno kód je obvykle v pravém horním rohu editoru jazyka Visual Basic.
  6. Zadejte nebo vložte ukázkový kód přesně tak, jak je uvedena v následujícím článku znalostní báze Knowledge Base, včetně řádků Sub Macroname() a End Sub.

    Poznámka: Další informace o zadáním nebo vložením kód makra, naleznete v části "Chcete-li vytvořit nového makra" v tomto článku.
Po zadáním nebo vložením kód makra, klepněte na tlačítko Zavřít a návrat do Microsoft program v nabídce soubor

kde je program Microsoft Office XP program, který používáte.

Chcete-li spustit makro

  1. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz makra.
  2. Vyberte v seznamu Název makra název makra a potom klepněte na příkaz Spustit.

Odkazy

Help pro každou aplikaci sady Office obsahuje mnoho témata o práci s makry. Nápověda pro Visual Basic obsahuje podrobné informace o psaní vlastního kódu.
Vlastnosti

ID článku: 290140 - Poslední kontrola: 23. 1. 2017 - Revize: 1

Váš názor