Jak vytvořit dvě schémata číslování stránek v jednom dokumentu v aplikaci Word 2003 a Word 2002

Aplikaci Microsoft Word 97 verzi tohoto článku v tématu 155199 .

Aplikaci Microsoft Word 2000 verzi tohoto článku v tématu 212313 .

V TOMTO ÚKOLU

Souhrn

Aplikace Microsoft Word neposkytuje předdefinované způsob aplikace dvě různá schémata číslování stránek v jednom dokumentu. Tento článek popisuje, jak vytvořit jedno schéma číslování stránek pro celý dokument a jiné schéma pro každou část dokumentu.

Ukázkový dokument

Například 10 stránky dokumentu má 3 oddíly s následující počet stránek v každém oddílu:
4 stránky v části 1 (fyzické stránky 1 až 4)
2 stránky v oddílu 2 (fyzické stránky 5 až 6)
4 stránky v části 3 (fyzické stránky 7 až 10)
Pomocí následující metody můžete vytvořit dvě schémata číslování stránek následujícím způsobem:

Záhlaví se zobrazí schématu číslování:
Číslo stránky z Celkový počet stránek v oddílu
Zápatí zobrazí schématu číslování:
Celkový počet stránek v dokumentu
Například na stránce 3 oddíl 1 (stránka třetí fyzické celkový dokumentu) zobrazuje záhlaví Stránka 3 ze 4a zápatí zobrazí 3. Na stránky 2 oddílu 3 (stránka osmého fyzické celkový dokumentu) zobrazuje záhlaví Stránka 2 ze 4a zápatí zobrazí 8.

Poznámka: Tento proces předpokládá, že máte dokument s více oddíly a že jste obeznámeni s vkládání kódů polí.

Chcete-li vytvořit schéma číslování, který používá postupné číslování v celé dokument a druhý schéma číslování každého oddílu začínající 1 čísla, použijte jednu z následujících metod.

Metoda 1: Použití polí SEQ

  1. Na první stránce dokumentu, umístěte tyto dva kódy polí:
    {SEQ variable1 \h \r {SectionPages}}

    {\H \r0 variable2 SEQ}
    Poznámky:

    • \R následuje číslo nula, nikoli písmeno "O".
    • Pořadí polí zahrnují Přepínač \h formáty polí jako skryté. Přestože skrytý text lze zobrazit klepnutím na tlačítko Zobrazit či skrýt na panelu nástrojů Standardní, ujistěte se, chcete-li vypnout skrytý text před tisk, protože skrytý text ovlivňuje konce stránek a může mít za následek nesprávné číslování.
  2. Umístěte následující kódy polí za první oddíl na začátku každého oddílu:
    {SEQ variable2 \h \r {={SEQ variable1 \c}}}

    {SEQ variable1 \h \r {={SectionPages}+{SEQ variable2 \c}}}
  3. Umístěte kurzor na začátek dokumentu. V nabídce Zobrazit klepněte na příkaz záhlaví a zápatí.
  4. V záhlaví umístěte kurzor na místo, kam chcete umístit číslo stránky zobrazit, zadejte slovo stránky a mezeru a potom klepněte na tlačítko Vložit číslo stránky na panelu nástrojů záhlaví a zápatí .
  5. V nabídce Vložit na příkaz Čísla stráneka potom klepněte na tlačítko Formát.
  6. Ve skupinovém rámečku Číslování stránek, klepněte na začátek (1 by se měl zobrazit v poli začátek ). Klepněte na tlačítko OK
  7. Klepněte na tlačítko Zavřít.
  8. Umístěte kurzor za pole stránky, typ
    of (včetně mezery před a za slovo "z") a potom v nabídce Vložit klepněte na pole. Ve skupinovém rámečku kategorieklepněte na tlačítko číslování. Ve skupinovém rámečku Názvy políklepněte na tlačítko SectionPagesa klepněte na tlačítko OK.
  9. Na panelu nástrojů záhlaví a zápatí , klepněte na tlačítko Zobrazit další .

    Poznámka: měli byste vidět záhlaví oddílu 2 oblast záhlaví dokumentu.
  10. V nabídce Vložit na příkaz Čísla stráneka potom klepněte na tlačítko Formát. Ve skupinovém rámečku Číslování stránek, klepněte na začátek (1 by se měl zobrazit v poli začátek ). Klepněte na tlačítko OK
  11. Klepněte na tlačítko Zavřít.
  12. Opakujte kroky 9 až 11 pro každý oddíl dokumentu.
  13. Klepněte na tlačítko Zobrazit předchozí na panelu nástrojů záhlaví a zápatí dokud zobrazí sekce záhlaví 1 v záhlaví část dokumentu. Klepněte na tlačítko Přepnout mezi záhlavím a zápatím tlačítko na panelu nástrojů záhlaví a zápatí.

    Poznámka: měli byste vidět sekce zápatí 1 v oblasti zápatí dokumentu.
  14. Umístěte následující kód v zápatí zobrazit číslo stránky z celkový počet stránek v dokumentu:
    {={SEQ variable2 \c}+{Page}}
  15. Na panelu nástrojů záhlaví a zápatí , klepněte na tlačítko Zavřít .

Metoda 2: Použití pole PAGEREF

Chcete-li vytvořit schéma číslování části záhlaví, postupujte takto.

Poznámka: stránka číslování začíná 1 pro každý oddíl a PAGEREF pole vrací počet stránek v každém oddílu. Číslovat stránky se zobrazí jako "Stránka X z Y"na každé stránce, kde X je aktuální stránky v aktuálním oddílu a Y je počet stránek v aktuálním oddílu.
  1. V nabídce Zobrazit klepněte na příkaz záhlaví a zápatí.
  2. V části záhlaví 1 umístěte kurzor na místo, kam chcete umístit číslo stránky a potom klepněte na tlačítko Vložit číslo stránky na panelu nástrojů záhlaví a zápatí .
  3. V nabídce Vložit na příkaz Čísla stráneka potom klepněte na tlačítko Formát.
  4. Ve skupinovém rámečku Číslování stránek, klepněte na začátek (1 by se měl zobrazit v poli začátek ). Klepněte na tlačítko OK Klepněte na tlačítko Zavřít.
  5. Na panelu nástrojů záhlaví a zápatí klepněte na tlačítko Zavřít.
  6. Chcete-li vložit záložku na konci každého oddílu dokumentu, postupujte takto.

    Poznámka: Pokud dokument obsahuje tři oddíly, vložíte tři záložky.
    1. Vyberte nějaký text na konci poslední stránky oddílu.
    2. V nabídce Vložit klepněte na tlačítko Záložka.
    3. Zadejte název záložky, například Sec1 oddíl 1a potom klepněte na tlačítko Přidat.
  7. Stisknutím kláves CTRL + HOME se vrátíte na začátek dokumentu.
  8. V nabídce Zobrazit klepněte na příkaz záhlaví a zápatía potom postupujte takto:
    1. Po pole stránky, které jste vložili v kroku 2 klepněte na tlačítko a potom zadejte (včetně mezery před a za slovo "z").
    2. V nabídce Vložit klepněte na příkaz pole. V seznamu kategorieklepněte na položku (vše). V seznamu Názvy políklepněte PAGEREF. V poli vlastnosti pole klepněte na název záložky, který jste vložili konec aktuálního oddílu.
    3. Klepněte na tlačítko OK
    4. Na panelu nástrojů záhlaví a zápatí , klepněte na tlačítko Zobrazit další . Měli byste vidět
      Záhlaví oddílu 2 oblast záhlaví dokumentu.

      Pokud stejný jako předchozí je zapnutý (zobrazí se slova stejné jako předchozí na pravé straně tečkované čáry kolem záhlaví nebo zápatí), klepněte na tlačítko stejné jako minulé
      Panel nástrojů záhlaví a zápatí . Slova stejné jako minulé zmizí z pravé strany tečkované čáry kolem záhlaví nebo zápatí.
    5. V nabídce Vložit na příkaz Čísla stráneka potom klepněte na tlačítko Formát.
    6. Ve skupinovém rámečku Číslování stránek, klepněte na začátek (1 by se měl zobrazit v poli začátek ). Klepněte na tlačítko OK Klepněte na tlačítko Zavřít. Na panelu nástrojů záhlaví a zápatí , klepněte na tlačítko Zavřít .
    7. Pokud nejsou vaše kódy polí zapnuty, stiskněte kombinaci kláves ALT + F9 zapnout. S kódy polí zapnuty by měl zobrazit následující kód
      {Stránka} {PAGEREF název_záložky \ * MERGEFORMAT}
      kde název_záložky je název záložky, který jste vložili v kroku 6.
    8. Změnit NázevZáložky pole PAGEREF název záložky, kterou jste vybrali pro aktuální oddíl.

      Poznámka: abyste nezapomněli oddílu, které právě pracujete, naleznete v levé horní části čárkované ohraničení záhlaví.
    9. Zopakujte kroky d až h pro každou část dokumentu.
    10. Na panelu nástrojů záhlaví a zápatí , klepněte na tlačítko Zavřít .

      Poznámka: bude pravděpodobně nutné aktualizovat pole (klepněte na pole a stiskněte klávesu F9) se zobrazí správně.
Chcete-li vytvořit schéma číslování zápatí, postupujte takto:
  1. Umístěte kurzor na začátek dokumentu. V nabídce Zobrazit klepněte na příkaz záhlaví a zápatí. V
    Záhlaví a zápatí panel nástrojů, klepněte na tlačítko Přepnout mezi záhlavím a zápatím.
  2. 1 sekce zápatí klepněte na tlačítko Vložit číslo stránky na panelu nástrojů záhlaví a zápatí.
  3. Pokud nejsou vaše kódy polí zapnuty, stiskněte kombinaci kláves ALT + F9 zapnout. Odstraníte libovolné pole {} stránky v zápatí.
  4. Na panelu nástrojů záhlaví a zápatí , klepněte na tlačítko Zobrazit další .

    Poznámka: zobrazí sekce zápatí 2 v oblasti zápatí dokumentu.

    Pokud stejný jako předchozí je zapnutý (zobrazí se slova stejné jako předchozí na pravé straně tečkované čáry kolem záhlaví nebo zápatí), klepněte na tlačítko stejné jako minulé
    Panel nástrojů záhlaví a zápatí . Slova stejné jako minulé zmizí z pravé strany tečkované čáry kolem záhlaví nebo zápatí.
  5. Přechod na následující pole v zápatí sekce 2
    {{} PAGE = + {PAGEREF název_záložky (oddíl 1)}}
    kde název_záložky je název záložky, kterou jste použili v předchozí části.
  6. Zobrazit další tlačítko na panelu nástrojů záhlaví a zápatí a potom postupujte takto:
    1. Měli byste vidět 3 sekce zápatí v oblasti zápatí dokumentu. Pokud stejný jako předchozí je zapnutý (zobrazí se slova stejné jako předchozí na pravé straně tečkované čáry kolem záhlaví nebo zápatí), klepněte na tlačítko stejné jako minulé
      Panel nástrojů záhlaví a zápatí . Slova stejné jako minulé zmizí z pravé strany tečkované čáry kolem záhlaví nebo zápatí.
    2. Pokud nejsou vaše kódy polí zapnuty, stiskněte kombinaci kláves ALT + F9 zapnout.
    3. Změňte pole na následující:
      {{} PAGE = + {PAGEREF název_záložky (oddíl 1)} + {PAGEREF název_záložky (oddíl 2)}}
  7. Krok 6 opakujte pro každou část dokumentu.

    Poznámka: je třeba upravit pole umístěno v zápatí pro každý další oddíl přidáním následující na konec existující kód pole mezi dva koncové závorky ({})
    + {PAGEREF název_záložky (předchozí oddíl
    x) }
    kde x představuje číslo předchozího oddílu.

    Proto pokud máte čtyři oddíly, oddíl 4 bude vypadat podobně jako následující:
    {={} Stránky + {PAGEREF název_záložky (oddíl 1)} + {PAGEREF název_záložky (oddíl 2)} + {PAGEREF název_záložky (oddíl 3)}}
  8. Na panelu nástrojů záhlaví a zápatí , klepněte na tlačítko Zavřít .
Vlastnosti

ID článku: 291283 - Poslední kontrola: 19. 1. 2017 - Revize: 1

Váš názor