Co dělat, pokud je virus v makru aplikace Word pro Mac

Souhrn

Tento článek popisuje, co jsou viry v makrech, co dělat, pokud se domníváte, že počítač pravděpodobně obsahuje virus v makru aplikace Word a jak zajistit, že vaše dokumenty nejsou nakaženy virem v makru.

Další informace

V létě roku 1995 byla objevena první virus makra. Od té doby se objevily jiné viry v makrech.

Virus v makru je škodlivý program, který je napsán pomocí makra jazyka programu, jako je například aplikace Word. Virus šíří sama mezi datové soubory a mohou poškodit soubory nebo operační systém.

Word viry v makrech není volně cestovat přes Internet nebo jiného média; mohou být převedeny pouze při otevření dokumentu nebo šablony obsahující virus makra.

Viry v makrech nemohou být přeneseny prostřednictvím e-mailu, pokud ohrožený dokumentu je vložen v e-mailové zprávy a příjemce otevře dokument.

Příznaky napadení virem v makru

Některé příznaky Word makro viry, které jsou známé ovlivnit Word a Word jsou následující dokumenty:
  • Při pokusu o uložení dokumentu aplikace Word pouze umožňuje uložit dokument jako šablonu.

    - nebo -
  • Ikona pro soubor vypadá jako šablonu, nikoli dokument.

    - nebo -
  • Při otevření dokumentu se zobrazí dialogové okno zobrazující číslo 1.

    - nebo -
  • Makra a vlastní příkazy se již objeví v nabídce Nástroje .

    - nebo -
  • Nová makra se zobrazí v seznamu maker. Může také zobrazit makra AutoOpen FileSaveAs; Pokud již máte makra podle těchto názvů, jejich obsah může měnit virus makra.

    - nebo -
  • Neobvyklé nebo neočekávané zprávy se zobrazí při otevření dokumentu aplikace Word nebo šablony.
Poznámky
  • Slovo hledat viry v makrech není nebo z existující dokumenty a šablony odebrat viry v makrech. Je pouze upozornění, pokud otevíráte dokument obsahuje makra. Poté můžete buď otevřete s makry aktivní dokument nebo otevřete se zakázanými makry. Neměli byste otevírat dokumentu s makry aktivní, pokud si nejste zcela jisti, že dokument neobsahuje žádné viry v makrech.
  • Antivirové programy jiných výrobců musí být často aktualizován zůstat efektivní. Obraťte se na dodavatele pro aktualizaci informací.

Nainstalujte antivirový program

Do dlouhodobé řešení viry v makrech nainstalujte antivirový software, který je navržen speciálně pro zjišťování virů v makru. Další informace o dodavatelích antivirového softwaru, včetně software pro rozpoznání a antivirová ochrana maker, klepněte na následující číslo článku databáze Microsoft Knowledge Base:

49500 seznam výrobců antivirového softwaru

Společnost Microsoft poskytuje kontaktní informace jiného výrobce, a tím vám usnadňuje získání technické podpory. Tyto kontaktní informace se mohou změnit bez předchozího upozornění. Společnost Microsoft nezaručuje přesnost kontaktních informací jiných výrobců.

Co dělat, když si myslíte, že váš počítač může mít virus v makru

Jako dočasné řešení pouze v případě, že si myslíte, že váš počítač mít virus v makru, použijte následující metody.

Metoda 1: Zakázat makra a text zkopírovat do nového dokumentu

Pokud není projevit některý z příznaky popsané dříve v tomto článku, ale nechcete být ovlivněny virus v makru, podržte klávesu SHIFT při otevření souboru, který může být nakažen virem v makru. Stisknutím klávesy SHIFT makra aplikace Word automaticky zabraňuje spuštění; Pokud je přítomen virus v makru, není načten.

Metoda 2: Odstranit makro a obnovit dokument

Pokud se vyskytnou příznaky popsané dříve v tomto článku nebo pokud se domníváte, že máte virus makra, která není popsána v tomto článku, postupujte takto k odstranění podezřelých makro a opravě ohroženého dokumentu.

Poznámka: Toto řešení je pouze dočasné; vzhledem k tomu, že vytvoření nového makra tyto kroky nemusí fungovat na nová makra.

  1. V nabídce aplikace Word klepněte na tlačítko klepněte na tlačítko Konec. Normální soubor přesunete do plochy. To lze provést:
    1. Ukončete všechny aplikace sady Microsoft.
    2. V nabídce funkce hledání klepněte na tlačítko Přejít vyberte Home .
    3. Otevřete složku knihovny .
    4. Otevřete složku Application Support .
    5. Otevřete složku Microsoft .
    6. Otevřete složku Office .
    7. Otevřete složku pro Uživatelské šablony .
    8. Klepněte pravým tlačítkem myši normální soubor. Klepněte na tlačítko Upravit a poté zvolte možnost Kopírovat "Normal.dotm".

  2. Spusťte aplikaci Word. V nabídce soubor klepněte na tlačítko Otevřít.
  3. Přejděte do složky obsahující ohrožený soubor.
  4. Klepnutím vyberte ohrožený soubor. Okamžitě stiskněte a podržte klávesu SHIFT a klepněte na tlačítko Otevřít. Pokračujte, dokud ohrožený soubor je otevřen v aplikaci Word, podržte klávesu SHIFT.

    Poznámka: Podržením klávesy SHIFT při otevírání souboru zabraňuje spuštění makra aplikace Word automaticky.
  5. K odstranění podezřelých makro, použijte následující kroky:
    1. V nabídce Nástroje přejděte na příkaz makroa potom klepněte na příkaz makra.
    2. V Makra v rozbalovací nabídce vyberte všechny aktivní šablony a dokumenty.
    3. Vyberte podezřelou makro a potom klepněte na příkaz Odstranit. Klepněte na tlačítko Ano po zobrazení výzvy, zda chcete odstranit makro.
    4. Opakujte krok c pro všechna makra podezřelých.
    5. Klepnutím na tlačítko Storno zavřete dialogové okno makra .
  6. Obnovení textu napadené dokumentu, postupujte takto:
    1. Stisknutím kombinace kláves COMMAND + A nebo klepnutím na tlačítko Vybrat vše v nabídce Úpravy vyberte celý dokument.
    2. Posledním znakem konce odstavce dokumentu z výběru odstraňte stisknutím kláves SHIFT + šipka vlevo.
    3. V nabídce Úpravy klepněte na příkaz Kopírovat.
    4. V nabídce soubor klepněte na tlačítko Nový. Vyberte šablonu, kterou chcete použít a potom klepněte na tlačítko OK.
    5. V nabídce Úpravy klepněte na příkaz Vložit.
    6. Opakujte krok 7 zajistit, že makra obsahující virus nebyl replikován.
    7. Uložte dokument.
  7. Tyto kroky opakujte pro každý dokument, který máte podezření, že by mohly obsahovat virus v makru.
Poznámka: Pokud metoda 2 nefunguje, vyzkoušejte metodu 3.

Metoda 3: Použití organizátoru dočasně vyčistit virus makra

Pomocí dialogového okna Organizátor vyčistit virus makra. Uvědomte si, že pokud po otevření infikovaného souboru otevřít jiné soubory, pravděpodobně jsou soubory nakažené stejně.

Chcete-li odebrat virus z šablony Normal.dot, postupujte takto:
  1. Zavřete všechny dokumenty. Pokud napadené dokumentu je otevřena, ji můžete snadno znovu nakazit šablony Normal.
  2. V nabídce Nástroje klepněte na příkaz šablony a doplňkya klepněte na tlačítko Organizátor .
  3. Klepněte na kartu Makra přejmenovat nebo odstranit všechny následující makra:
    • NewMacros
    • AutoClose
    • AutoExec
    • AutoOpen
    • FileExit
    • Funkci FileNew
    • FileOpen
    • Soubor – uložit
    • FileSaveAs
    • Makra
    • ToolsMacro
  4. Klepněte na tlačítko Zavřít.
  5. Stiskněte a podržte klávesu SHIFT při klepnutí na tlačítko Uložit vše v nabídce soubor a uložte šablonu.
Chcete-li odebrat viry v makrech z napadené dokumentu:

Pokud je soubor napaden, použít stejnou metodu jako v krocích 1 až 5, ale odebrat makra z normální šablony a také z napadené dokumentu (šablona) v Organizátoru. Až budete hotovi, stiskněte a podržte klávesu SHIFT a klepněte na tlačítko Uložit vše v nabídce soubor a potom přesuňte na další soubor. Uvědomte si, že při každém otevření infikovaného souboru jej napadne šablona Normal.dot tak musí opakovaně odebrat makra z normální šablony.

Metoda 4: Vložte nakažený soubor do nového dokumentu

Tato metoda je užitečná zejména virem makro "CAP", která odebere makra a vlastní z nabídky Nástroje .

Poznámka: V takovém případě nemusí fungovat šablony a doplňky v nabídce Nástroje .

  1. V nabídce aplikace Word klepněte na tlačítko klepněte na tlačítko Konec. Normální šablona přesunete na plochu. To lze provést:
    1. Ukončete všechny aplikace sady Microsoft.
    2. V nabídce funkce hledání klepněte na tlačítko Přejít vyberte Home .
    3. Otevřete složku knihovny .
    4. Otevřete složku Application Support .
    5. Otevřete složku Microsoft .
    6. Otevřete složku Office .
    7. Otevřete složku pro Uživatelské šablony .
    8. Klepněte pravým tlačítkem myši normální soubor. Klepněte na tlačítko Upravit a poté zvolte možnost Kopírovat "Normal.dotm".

  2. Spusťte aplikaci Word a potom ověřte, že makra a vlastní se zobrazí v nabídce Nástroje .
  3. Otevřete nový dokument. V nabídce Vložit klepněte na soubor.
  4. Přejděte do složky obsahující ohrožený soubor.
  5. Klepnutím vyberte ohrožený soubor.
  6. Stiskněte a podržte klávesu SHIFT a klepněte na tlačítko Otevřít. Pokračujte, dokud ohrožený soubor je otevřen v aplikaci Word, podržte klávesu SHIFT.
    Poznámka: Podržením klávesy SHIFT při otevírání souboru zabraňuje spuštění makra aplikace Word automaticky.
  7. Chcete-li ověřit, zda makra existovat v novém dokumentu (žádný by měly být uvedeny), přejděte v nabídce Nástroje na příkaz makro a potom klepněte na příkaz makra. V Makra v seznamu místní nabídky klepněte na tlačítko všechny aktivní šablony a dokumenty. Ve skupinovém rámečku Název makraby měly být uvedeny žádné makra. Klepněte na tlačítko Storno.
  8. Uložte soubor s jiným názvem souboru.
  9. Odstraníte nakažený soubor.

Metoda 5: Použití řešení ve formátu RTF

A. Odstraňte soubor normální (globální šablona).

Jedná se o problém s makro uložit do šablony Normální.

Následující kroky odebrat šablony Normal. Uvědomte si, že žádné zvláštní formátování sady v normální šabloně budou odebrány a šablona bude obnoveno výchozí nastavení.
  1. Ukončete všechny aplikace sady Microsoft.
  2. V nabídce funkce hledání klepněte na tlačítko Přejít vyberte Home .
  3. Otevřete složku knihovny .
  4. Otevřete složku Application Support .
  5. Otevřete složku Microsoft .
  6. Otevřete složku Office .
  7. Otevřete složku pro Uživatelské šablony .
  8. Vyhledejte soubor s názvem Normální. Klepněte na soubor a klepněte na tlačítko přesunout do koše.

B. zakážete makra.

Otevřete soubory viru a pak zakázat makra na každý soubor, zobrazí se upozornění na makra. Pokud neobdržíte upozornění, je třeba zapnout upozornění na makra. Chcete-li to provést, postupujte takto:
  1. V nabídce aplikace Word a klepněte na tlačítko Předvolby.
  2. V navigačním podokně klepněte na položku zabezpečení a potom zaškrtněte políčko Zobrazit upozornění před otevřením souboru, který obsahuje makra .

C. znovu uložte existující soubory.

  1. V nabídce soubor na příkaz Uložit jako .
  2. V seznamu Formát klepněte na tlačítko RTF (RICH Text Format).
  3. Klepněte na tlačítko Uložit.

Po uložení souboru jako soubor ve formátu RTF dokument znovu uložit ve formátu aplikace Word (DOC) a přepsat soubor, který obsahuje virus v makru nebo dokument uložit jako nový soubor a odstraňte starý soubor, který obsahuje virus. Po znovu uložíte nový soubor ve formátu DOC, můžete odstranit soubor ve formátu RTF. Uvědomte si, že nemusí být některé prvky formátování zachováno při přechodu z aplikace Word (DOC) formát RTF.


Vlastnosti

ID článku: 291824 - Poslední kontrola: 19. 1. 2017 - Revize: 1

Váš názor