Jak používat hromadnou korespondenci k vytvoření seznamu seřazeného podle kategorie v aplikaci Word

Aplikace Microsoft Word 2000 verzi tohoto článku naleznete v tématu
211303 .
Microsoft Word 98 verzi tohoto článku naleznete v tématu
181731 .
Aplikace Microsoft Word 97 verzi tohoto článku naleznete v tématu
181730 .
Aplikace Microsoft Word 95 verzi tohoto článku naleznete v tématu
181729 .

Souhrn

Tento článek popisuje, jak pomocí funkce hromadné korespondence v aplikaci Word vytvořit seznam dat, které je seřazeno a odděleny kategorii. Tento článek obsahuje pokyny a vzorek, který slouží k vytvoření takového seznamu.

Nastavení datového souboru

Seřadit datový soubor tak, aby všechny záznamy se stejnou hodnotou klíče pole kategorie (pole, na kterých založíte řazení) se zobrazují společně, jak je znázorněno ukázkový datový soubor. Následující ukázkový seznam je seřazen podle pole Město (CITY je pole klíče v tomto příkladu).

Nastavit hlavní dokument

Poznámka: Slova "znak konce odstavce" v závorkách označení odstavce v následujícím příkladu. Chcete-li znak konce odstavce, stiskněte klávesu ENTER.

Pro tento postup fungoval je nutné vybrat typ dokumentu "Adresář" při nastavení hlavního dokumentu. Chcete-li nastavit hlavní dokument jako adresář, postupujte takto:
  1. V novém prázdném dokumentu spustíte hromadnou korespondenci. Chcete-li to provést, použijte jednu z následujících postupů v závislosti na verzi aplikace Word, který používáte:

    Aplikace Microsoft Word 2002

    V nabídce Nástroje klepněte na příkaz Dopisy a korespondencea klepněte na příkaz Průvodce hromadnou korespondencí.



    Aplikace Microsoft Office Word 2003

    V nabídce Nástroje klepněte na příkaz Dopisy a korespondencea klepněte na příkaz Hromadná korespondence.



    Aplikace Microsoft Office Word 2007 a Microsoft Office Word 2010

    Na kartě Pošta klepněte na tlačítko Spustit hromadnou korespondencia pak klepněte na příkaz Průvodce hromadnou korespondencí Step by Step.

  2. V podokno úloh hromadné korespondence ve skupinovém rámečku Vyberte typ dokumentuklepněte na tlačítko Vybrat adresář.
  3. Klepněte na Další: počáteční dokument.
  4. Ve skupinovém rámečku Vybrat počáteční dokumentklepněte na Použít aktuální dokument.
  5. Klepněte na Další: Vybrat příjemce.
  6. Ve skupinovém rámečku použít existující seznamklepněte na tlačítko Procházet.
  7. V dialogovém okně Vybrat zdroj dat vyberte ukázkový soubor, který jste vytvořili v
    Set Up soubor dat v oddílu.
  8. Pokud se zobrazí dialogové okno Potvrdit zdroj dat , vyberte typ dat, který je vhodný pro typ souboru, který jste vytvořili v části Nastavení datového souboru . Například pokud jste vytvořili soubor v aplikaci Microsoft Excel, vyberte Listy aplikace MS Excel pomocí rozhraní DDE (*.xls) nebo Soubory aplikace Excel prostřednictvím rozhraní ODBC (*.xls).
  9. V dialogovém okně Příjemci hromadné korespondence klepněte na tlačítko OK.
  10. Pomocí následujícího příkladu jako vodítko, vložte pole porovnat pole klíče v každém řádku pomocí pole klíče v předchozím řádku a vložte jeden textový řetězec, pokud se liší a jiný řetězec textu, pokud jsou stejné.
Příklad

V tomto příkladu vzorová data z
Nastavení datového souboru oddílu a používá jako klíčové pole MERGEFIELD Město { } .

Poznámka: Chcete-li vložit závorky pole, stiskněte kombinaci kláves CTRL + F9. Pole podle tohoto příkladu produktu seřazený seznam takto:
Atlanta

Galos 3 000 Kč.
Delaney 50 000 Kč
Henningsen 10 000 Kč

Houston

Johnson, 8 000 Kč
Kelly 9 000 $
Pak 0 Kč

Platnost každé nové kategorie pro novou stránku

Jako v předchozím příkladu je pole klíče v tomto příkladu { MERGEFIELD Město }. Při změně hodnoty města v datovém souboru do jiného města, doplňuje novou stránku sloučených výsledků a sloučení pokračuje v horní části následující stránky. Chcete-li vložit závorky pole, stiskněte kombinaci kláves CTRL + F9.
Poznámka: Chcete-li vložit konec stránky, buď stiskněte kombinaci kláves CTRL + ENTER nebo klepněte na příkaz Konec v nabídce Vložit , vyberte Konec stránkya klepněte na tlačítko OK.

Pole podle tohoto příkladu produktu výpis na samostatných stránkách takto:
Atlanta

Galos 3 000 Kč.
Delaney 50 000 Kč
Henningsen 10 000 Kč

----------------------------Page Break-----------------------------
Houston

Johnson, 8 000 Kč
Kelly 9 000 $
Pak 0 Kč

Formátovat pole klíče

Pole klíče v tomto příkladu je {MERGEFIELD Město}. Výsledky {MERGEFIELD Město} všechna písmena velká formátovat, můžete vložit přepínače formátování z
\ * Horní. Chcete-li vložit závorky pole, stiskněte kombinaci kláves CTRL + F9.
Pole podle tohoto příkladu produktu výpis s městem uvedené velkými písmeny, následujícím způsobem:
ATLANTA

Galos 3 000 Kč.
Delaney 50 000 Kč
Henningsen 10 000 Kč

HOUSTON

Johnson, 8 000 Kč
Kelly 9 000 $
Pak 0 Kč
Poznámka: Můžete použít různé formátování pole klíče { MERGEFIELD Město } výběrem celé pole (včetně složených závorek pole {}) a formátování pole podle vašich představ. Chcete-li formátovat pole, klepněte na příkaz písmo v nabídce Formát .

Vložit další text

Pokud chcete další text se zobrazí v dokumentu hromadné korespondence, musí obsahovat tento text uvnitř páry uvozovek v polích IF. Tímto způsobem text se zobrazí, pouze v případě, že informace ve zdroji dat splňuje podmínky, které definujete v polích IF (například pokud je název MĚSTA v aktuálním řádku zdroje dat, se liší od názvu MĚSTA v předchozím řádku).

Pokud umístíte text mimo pole IF do hlavního dokumentu, tento text se zobrazí v dokumentu hromadné korespondence jednou pro každý nový řádek ve zdroji dat, a ne jednou pro každé nové pole s klíčem. V příkladu, který jste vytvořili v části Nastavení souboru dat zobrazí se jednou pro každého zaměstnance, nikoli pouze jednou pro každé město.

V tomto příkladu představuje každé město v seznamu s krátkou úvodní větu: stanovené v tomto příkladu pole vytvořit výpis s úvodní text pro každé město takto:
Jedná se o celkový prodej Brno:

Galos 3 000 Kč.
Delaney 50 000 Kč
Henningsen 10 000 Kč

Jedná se o celkový prodej Houston:

Johnson, 8 000 Kč
Kelly 9 000 $
Pak 0 Kč

Jak tento proces funguje

První pole IF v těchto příkladech vloží název města a znak konce odstavce pro pouze první záznam hromadné korespondence. U všech následných záznamů, vloží toto pole IF nic (""). Rozpozná první záznam hromadné korespondence porovnáním pole MERGESEQ (která vrátí pořadové číslo aktuálního záznamu) číslicí "1".

Pokud pole vloží znak vrácení (a konec stránky, pokud jsou vynucení každé město na novou stránku), druhý název města dva více vrátit znaky, jméno zaměstnance a prodejní částky (v tomto pořadí), pouze v případě, že pole IF rozhoduje, že aktuální záznam obsahuje název města, které se liší od předchozí záznam. Aplikace Word určí, že aktuální záznam obsahuje název města, který je stejný jako předchozí záznam, vloží aplikace Word pouze další jméno zaměstnance a prodejní částky.


Následující pole IF rozpozná nové město porovnáním textu záložky podle dvou polí se SADOU. Text záložky "Place1" je vždy rovna aktuální záznam pole Město a text záložky "Place2" se rovná předchozí záznam pole Město.

Odkazy

Další informace o hromadné korespondence klepněte na následující čísla článku zobrazení v článcích znalostní báze Microsoft Knowledge Base:

294688 jak navrhnout a sestavit seznam adres hromadné korespondence v aplikaci Word 2002 a v novějších verzích aplikace Word

290408 často kladené dotazy týkající se hromadné korespondence v aplikaci Word 2002

294693 jak používat hromadnou korespondenci k vytvoření adresáře v aplikaci Word 2002 a v novějších verzích aplikace Word

294683 jak používat hromadnou korespondenci k vytváření formulářových dopisů v aplikaci Word 2002 a v novějších verzích aplikace Word

Vlastnosti

ID článku: 294686 - Poslední kontrola: 19. 1. 2017 - Revize: 1

Váš názor