Průvodce přenesením selže přenesení dat v rozsáhlých tabulkách

Střední: Vyžaduje základní maker, kódování a interoperability dovedností.

Tento článek se týká pouze databáze aplikace Microsoft Access (MDB).


Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravou registru, nezapomeňte zálohovat a ujistěte se, že víte, jak registr obnovit v případě výskytu problému. Informace o zálohování, obnovení a úpravě registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
256986 Popis registru systému Microsoft Windows

Příznaky

Při pokusu přenést databázi aplikace Microsoft Access (.mdb) na Microsoft SQL Server, Průvodce přenesením neexportuje data pro velké tabulky.

Příčina

Předávací dotaz ODBC, který aplikace Microsoft Access používá k exportu dat je vypršení časového limitu.

Řešení

Následující část popisuje řešení problému a zahrnuje změnu registru. Pokud nechcete provést změny v registru, je také řešení tohoto problému, který je popsán po rozlišení.

Chcete-li tento problém vyřešit, nastavte hodnotu QueryTimeout v registru na hodnotu 0. Tím zachováte dotazu časového limitu. Chcete-li nastavit hodnotu QueryTimeout 0, postupujte takto:
  1. Ukončete všechny spuštěné instance aplikace Microsoft Access.
  2. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.
  3. V dialogovém okně Spustit zadejte příkaz Regedit.exea klepněte na tlačítko OK. Spustí se Editor registru.
  4. Klepněte na hodnotu QueryTimeout v registru v následujícím podklíči:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC
  5. V nabídce Úpravy klepněte na příkaz změnit.
  6. V dialogovém okně Upravit hodnotu DWORD klepněte na přepínač Desítková pod Base.
  7. V poli Údaj hodnoty zadejte hodnotu 0 a klepněte na tlačítko OK.
  8. Ukončete Editor registru.
  9. Spusťte aplikaci Microsoft Access, otevřete databázi a pokuste se přenést jej.

Jak potíže obejít

Chcete-li tento problém vyřešit, postupujte takto:
  1. Přenesení pouze strukturu tabulky.
  2. Chcete-li importovat data z tabulky aplikace Access a poté přidat do struktury přenesené pomocí Data Transformation Services (DTS).
To vám umožní přenést databázové struktury a tedy bez nutnosti měnit nastavení registru vytvořit požadované vztahy a aktivace/DRI.

Další informace o použití DTS klepněte na následující číslo článku databáze Microsoft Knowledge Base:
285829 použití Data Transformation Services (DTS) k exportu dat z databáze Microsoft Access do databáze SQL Server

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti uvedených na začátku tohoto článku.

Další informace

Pokud jej přenese databázi Jet k Microsoft SQL Server, Průvodce přenesením použije předávací dotazy SQL ODBC provedeny prostřednictvím databázového stroje Jet. Určuje hodnotu QueryTimeout v registru ODBC jak dlouho (v sekundách) před vypršením časového limitu může spustit dotazy. Ve výchozím nastavení je hodnota QueryTimeout nastavena na 60 sekund. Proto jakékoli předávací dotaz ODBC, který trvá déle než 60 sekund, časový limit a Průvodce přenesením přeskočí operace.

Kroky pro reprodukci chování v aplikaci Access 2003

Poznámka: Následující kroky simulovat chování přenesení Northwind ukázkové databáze nastavením QueryTimeout na 1 sekundu. To způsobí, že jakýkoli předávacích dotazů ODBC k vypršení časového limitu po 1 sekundu.
  1. Ukončete všechny spuštěné instance aplikace Microsoft Access.
  2. Klepněte na tlačítko Start a potom klepněte na příkaz Spustit.
  3. V dialogovém okně Spustit zadejte příkaz Regedit.exea klepněte na tlačítko OK. Spustí se Editor registru.
  4. Klepněte na hodnotu QueryTimeout v registru v následujícím podklíči:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\4.0\Engines\ODBC
  5. V nabídce Úpravy klepněte na příkaz změnit.
  6. V dialogovém okně Upravit hodnotu DWORD klepněte na přepínač Desítková pod Base.
  7. Do pole Údaj hodnoty zadejte hodnotu 1 a klepněte na tlačítko OK.
  8. Ukončete Editor registru.
  9. Spusťte aplikaci Microsoft Access.
  10. Otevřete ukázkovou databázi Northwind.mdb.
  11. V nabídce Nástroje přejděte na příkaz Správa databázea klepněte na položku Průvodce přenesením.
  12. Klepněte na tlačítko vytvořit novou databázia potom klepněte na tlačítko Další.
  13. Vyberte, kterou chcete přenést do serveru SQL Server a potom zadejte informace o ověřování pro přihlášení k serveru SQL Server.
  14. Zadejte název nové databáze serveru SQL Server a potom klepněte na tlačítko Další.
  15. Vyberte všechny tabulky, které chcete přenést a klepněte na tlačítko Další.
  16. Zachovat všechny výchozí hodnoty na další stránce a potom klepněte na tlačítko Další.
  17. Vyberte možnost vytvořit novou aplikaci klient/server aplikace Microsoft Access.
  18. Zadejte cestu a název v poli Název ADP a potom klepněte na tlačítko Dokončit.
  19. Zpráva o přenesení může prokázat, že všechny tabulky byly úspěšně přenesena nebo se může zobrazit následující zpráva v některých tabulkách:
    Tabulka byla vynechána.
  20. Přenesením sestavu zavřete. Automaticky otevře nový soubor projektu (.adp) Access připojen k databázi serveru SQL Server nový.
  21. Otevřete tabulku Rozpis objednávek .
Všimněte si, že struktura tabulky byla přenesena, ale že tabulka neobsahuje žádná data.
Vlastnosti

ID článku: 295231 - Poslední kontrola: 19. 1. 2017 - Revize: 1

Váš názor