Jak otevřít databázi SQL Server pomocí zprostředkovatele dat .NET Server SQL pomocí jazyka Visual Basic .NET

Souhrn

Tento článek popisuje, jak pomocí technologie ADO.NET otevřete databázi serveru SQL Server pomocí zprostředkovatele dat SQL Server .NET. ADO.NET shromažďuje všechny třídy, které jsou nutné pro zpracování údajů. Obor názvů System.Data.SqlClient popisuje kolekce tříd, které slouží k programovému přístupu zdroje dat SQL Server. Třídy objektů ADO můžete přistupovat prostřednictvím System.Data.OleDb obor názvů poskytuje podporu pro databáze OLE DB.

V tomto článku, připojení jsou nastaveny obě programově a pomocí aplikace Visual Studio .NET Server Explorer. Ukázky kódu v tomto článku použít SqlConnection, SqlCommanda SqlDataReader ADO.NET objekty.

Požadavky

Následující seznam obsahuje požadovaný hardware, software, síťovou infrastrukturu a aktualizace service Pack, které potřebujete:
  • Microsoft SQL Server
  • Visual Basic .NET
Poznámka: SQL Server a Visual Basic .NET musí být nainstalována a spuštěna ve stejném počítači. Kromě toho uživatel musí být schopen se připojit k serveru SQL Server pomocí integrovaného zabezpečení systému Windows.

Tento článek předpokládá, že jste obeznámeni s následující témata:
  • ADO.NET koncepty
  • SQL Server concepts a syntaxe jazyka Transact-SQL (T-SQL)
  • Ukázková databáze Northwind

Vytvoření aplikace Windows Visual Basic .NET

  1. Visual Studio .NET spusťte a vytvořit nový projekt aplikace Visual Basic pro systém Windows s názvem SQLDataAccess.
  2. Otevřete Form1. Na prvním řádku Form1.vb přidejte odkaz na obor názvů ADO.NET takto:
    Imports System.Data.SqlClient
  3. Z nabídky Start systému Windows přejděte na příkaz programy, přejděte na Microsoft SQL Servera pak klikněte na zajištění toho, aby SQL Server v počítači je spuštěna služba SQL Server Service Manager .
  4. Nastavte vlastnost Server na název počítače a nastavte vlastnost služby MSSQLServer.
  5. Pokud služba není spuštěna, klepněte na tlačítko Start.
  6. Zavřete dialogové okno SQL Server Service Manager .

Vytvoření objektů ADO.NET

Změníte třídy Form1 následujícím způsobem:
Public Class Form1    Inherits System.Windows.Forms.Form
'Create ADO.NET objects.
Private myConn As SqlConnection
Private myCmd As SqlCommand
Private myReader As SqlDataReader
Private results As String

Objekt SqlConnection naváže připojení databáze a objekt SqlCommand spustí dotaz proti databázi SqlDataReader objekt načte výsledky dotazu.

Otevřít připojení k serveru SQL pomocí objektu SqlConnection

  1. Chcete-li nastavit připojovací řetězec pro SqlConnection objekt, přidejte následující kód do událostní procedury Form1_Load :
           'Create a Connection object.        myConn = New SqlConnection("Initial Catalog=Northwind;" & _
    "Data Source=localhost;Integrated Security=SSPI;")


  2. Nastavit příkaz objekt, který obsahuje SQL dotazu, přidejte následující kód do událostní procedury Form1_Load :
           'Create a Command object.       myCmd = myConn.CreateCommand
    myCmd.CommandText = "SELECT FirstName, LastName FROM Employees"

    'Open the connection.
    myConn.Open()

SqlConnection vaše přihlašovací údaje systému Windows používá pro připojení k databázi Northwind v počítači.

Načtení dat ze serveru SQL Server pomocí objektu SqlDataReader

  1. Přidejte následující kód do událostní procedury Form1_Load :
    myReader = myCmd.ExecuteReader()
  2. Při spuštění myCmd.ExecuteReader metoda SqlCommand načte dvě pole z tabulky Zaměstnanci a vytvoří SqlDataReader objekt.
  3. Chcete-li zobrazit výsledky dotazu, přidejte následující kód, který
    Form1_Load procedura události:
    'Concatenate the query result into a string.        Do While myReader.Read()
    results = results & myReader.GetString(0) & vbTab & _
    myReader.GetString(1) & vbLf
    Loop
    'Display results.
    MsgBox(results)

    MyReader.Read metoda vrátí logickou hodnotu, která určuje, zda existuje více záznamů ke čtení. Výsledky dotazu SQL jsou zobrazeny v okně se zprávou.
  4. Zavřete SqlDataReader a SqlConnection objekty, přidejte následující kód do událostní procedury Form1_Load :
    'Close the reader and the database connection.        myReader.Close()
    myConn.Close()

  5. Uložte a spusťte projektu.

Zobrazit databázi v Průzkumníku serveru

  1. V nabídce Zobrazit klepněte na tlačítko Server Explorer.
  2. Datová připojeníklepněte pravým tlačítkem myši a potom klepněte na tlačítko Přidat připojení.
  3. V dialogovém okně Vlastnosti Data Link klepněte na localhost , v seznamu Vyberte nebo zadejte název serveru.
  4. Klepněte na tlačítko Windows NT integrované zabezpečení přihlášení na server.
  5. Klepněte na možnost Vybrat databázi na serverua ze seznamu vyberte databázi Northwind .
  6. Klepněte na tlačítko Test připojení k ověření připojení a potom klepněte na tlačítko OK.
  7. V Server Explorer klepnutím rozbalte strom Datová připojení tak, aby Tabulka Zaměstnanci uzel se rozbalí. Vlastnosti jednotlivých polí se zobrazí v okně Vlastnosti .

Otevřít připojení k serveru SQL pomocí Průzkumníka serveru

  1. Zobrazení Form1 v návrhovém zobrazení.
  2. Z tabulky Employees v Průzkumníku serveru přetáhněte databázová pole jméno a Příjmení a přetažením těchto polí na Form1. SqlConnection a SqlDataAdapter objekt jsou vytvořeny ve formuláři.
  3. V nabídce Zobrazit klepněte na panelu nástrojů.
  4. Na kartě Data přetáhněte objekt DataSet (DataSet1) a umístěte jej do formuláře.
  5. V dialogovém okně Přidat Dataset netypovou datasetklepněte a potom klepněte na tlačítko OK.
  6. Vložte řádek kódu před DataReader a objekty připojení jsou uzavřeny do událostní procedury Form1_Load . Ukončení režimu by měla vypadat takto:
    SqlDataAdapter1.Fill(DataSet1, "Employees")        myReader.Close()
    myConn.Close()

  7. Na kartě Okna formuláře z panelu nástrojů přetáhněte ovládací prvek DataGrid a umístěte jej na Form1.
  8. Svázat ovládací prvek DataGrid objekt DataSet , který jste vytvořili, přidejte následující kód do událostní procedury Form1_Load před "myReader.close()" řádek kódu:
    DataGrid1.SetDataBinding(DataSet1, "Employees")
  9. Uložte a spusťte projektu.

Odkazy

Další informace o použití rozhraní ADO.NET naleznete v části "Data" v tématu "Visual Basic" v dokumentaci k nápovědě Visual Studio .NET.

Vlastnosti

ID článku: 308656 - Poslední kontrola: 20. 1. 2017 - Revize: 1

Váš názor