SharePoint 2013 nebo Project Server 2013 nastavení chyby, pokud je nainstalována 4.6 rozhraní.NET Framework

Příznaky

Pokud spustíte aplikaci Microsoft SharePoint Foundation 2013 Service Pack 1 instalace SharePoint Server 2013 Service Pack 1 Instalační program nebo Project Server 2013 Service Pack 1 Instalační program v počítači, který má Microsoft rozhraní.NET Framework 4.6, 4.6.1 a 4.6.2 nainstalována, zobrazí se následující chybová zpráva:
Instalační program se nemůže pokračovat z důvodu následující chyby:
Tento produkt vyžaduje rozhraní Microsoft .net Framework 4.5.

Příčina

K tomuto problému dochází, protože programy instalace služby SharePoint a Project Server instalace rozhraní.NET Framework 4.6, 4.6.1 a 4.6.2 nerozpoznají jako podporovanou verzi rozhraní.NET Framework.

Řešení

Chcete-li vyřešit tento problém, postupujte takto:

  1. Extrahujte instalační médium do umístění s možností zápisu.

    • Jestliže instalační médium je spustitelný soubor (.exe), extrahujte soubory a složky ze spustitelného souboru do umístění s možností zápisu spuštěním následujícího příkazu příkazového řádku:

      <executable file name> /extract:<path to writable location> 
      Například spusťte následující příkaz:

      sharepoint.exe /extract:C:\SharePointInstaller 
    • Pokud instalační médium je disk obraz ISO nebo IMG (ISO nebo img), připojte bitovou kopii disku a potom zkopírujte soubory a složky z obrazu disku do umístění s možností zápisu.
  2. Stáhnete soubor komprimovaného (ZIP), který obsahuje odpovídající produkt, který instalujete opravu:

  3. Otevřete soubor ZIP.
  4. Zkopírujte následující soubor podporu instalace, případně ze souboru ZIP do složky "aktualizace" v umístění lze zapisovat.

    • SharePoint Foundation 2013 s Service Pack 1: wsssetup.dll
    • 2013 SharePoint Server s Service Pack 1: svrsetup.dll
    • Project Server 2013 s Service Pack 1: svrsetup.dll
  5. Spusťte Setup.exe z umístění lze zapisovat ke spuštění instalace služby SharePoint nebo instalace aplikace Project Server. Instalační program použije podporu souboru, který obsahuje opravy, které jste zkopírovali do složky "aktualizace".

Jak potíže obejít

Pokud nelze použít opravu metody, která je k dispozici v části "Řešení", je k dispozici metodu alternativní řešení.

Chcete-li tento problém vyřešit, ujistěte se, že rozhraní.NET Framework 4.6, 4.6.1 a 4.6.2 není nainstalován při instalaci služby SharePoint.

Pokud Microsoft rozhraní.NET Framework 4.6, 4.6.1 a 4.6.2 je již nainstalována, postupujte takto:
  1. Odinstalujte rozhraní.NET Framework 4.6, 4.6.1 a 4.6.2. Chcete-li to provést, přejděte do umístění, které je specifické pro operační systém, jak je uvedeno v následujících článcích znalostní báze Microsoft Knowledge Base:
    3151800 rozhraní.NET Framework 4.6.2 offline instalační program pro Windows
    3102436 rozhraní.NET Framework 4.6.1 offline instalační program pro Windows
    3045557 Microsoft rozhraní.NET Framework 4.6 (Offline instalační služba) pro systém Windows
    Poznámka: Rozhraní.NET Framework v systému Windows Server 2012 nebo Windows Server 2012 R2 je součástí operačního systému a nelze odinstalovat samostatně. Aktualizace rozhraní.NET Framework se zobrazí v kartě Nainstalované aktualizace app ovládací Panel programy a funkce . Pro operační systémy, ve kterých není rozhraní.NET Framework předinstalována rozhraní.NET Framework se zobrazí v kartě Odinstalace nebo změna programu (nebo Přidat nebo odebrat programy kartu) aplikací programy a funkce v Ovládacích panelech. Naleznete v tématu Poradce při potížích s blokována instalace rozhraní.NET Framework a Uninstallations a v článcích znalostní báze Microsoft Knowledge Base další informace výše uvedené.
  2. Restartujte počítač.
  3. Instalace webové instalační služby rozhraní.NET Framework 4.5.2.
  4. Spusťte instalační program serveru SharePoint k instalaci služby SharePoint.
Po úspěšné instalaci služby SharePoint lze upgradovat z rozhraní.NET Framework 4.5.2 pro rozhraní.NET Framework 4.6, 4.6.1 a 4.6.2.

Další informace

Přestože se zobrazí chybová zpráva během instalace, služba SharePoint Foundation 2013 a 2013 serveru SharePoint jsou stále podporovány po upgradu rozhraní.NET Framework 4.6, rozhraní.NET Framework 4.6.1 nebo rozhraní.NET Framework 4.6.2.

Poznámka: Formální podpora rozhraní.NET Framework, 4.5.1, 4.5 a 4.0 ukončena v lednu 2016.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Vlastnosti

ID článku: 3087184 - Poslední kontrola: 20. 1. 2017 - Revize: 2

Microsoft SharePoint Server 2013, Microsoft SharePoint Foundation 2013, Microsoft Project Server 2013

Váš názor