Při instalaci nebo upgradu systému Windows XP přes systém Windows 95, Windows 98 nebo Windows Millennium Edition se zobrazí chybová zpráva "NTLDR nenalezen"

Microsoft Windows 2000 verzi tohoto článku naleznete v tématu 255220 .

Příznaky

Tato část je určena pro pokročilé uživatele počítače. Pokud se necítíte na postupy řešení potíží pro pokročilé uživatele, můžete chtít požádat někoho o pomoc nebo se obraťte na podporu. Informace o tomto postupu naleznete na následujícím webu společnosti Microsoft:

Při pokusu o instalaci systému Windows XP nebo inovaci na systém Windows XP v počítači se systémem Microsoft Windows 95, Windows 98 nebo Windows Millennium Edition, můžete obdržet následující chybovou zprávu po prvním restartování během instalace:

Nebyl nalezen soubor NTLDR
Restartujte libovolnou klávesou

Příčina

Tomuto problému může dojít, pokud stávající instalace systému Windows 95, Windows 98 nebo Windows Millennium Edition byla naklonována a potom použita na jednotce, která má jinou geometrii než zdrojová jednotka klonované kopie.

Například se systémem Windows 98 na jednotce 4 gigabajty (GB). Po upgradu na 30 GB pevný disk, použijte nástroj pro vytváření bitových kopií disků od jiného výrobce vytvořit zrcadlový obraz instalace systému Windows 98 a potom použít obrázek na novou jednotku. Později provedete upgrade na systém Windows XP. To provedete instalaci systému Windows XP přes naklonovanou bitovou kopii systému Windows 98.

K tomuto problému dojít musí být splněny všechny následující podmínky:

  • Systémový nebo spouštěcí oddíl je formátován systémem souborů FAT32.
  • Počítač se spouští pomocí rozšíření přerušení INT-13. (Toto je oddíl větší než 7,8 GB s 0C typ identifikátoru System ID v tabulce oddílů).
  • Hodnotu počtu hlaviček (stran) v systému souborů FAT32 BIOS Parameter Block (BPB) z důvodu proces klonování neodpovídá geometrii fyzické jednotky.
Spouštěcí kód systému Windows 95, Windows 98 nebo Windows Millennium Edition hodnotu počtu hlaviček v záznamu BPB ignoruje a umožní spuštění i v případě, že hodnota není platná. Však tuto hodnotu vyžaduje spuštění kódu v systému Microsoft Windows 2000 a Windows XP a spuštění se nezdaří, pokud hodnota není platná.

Řešení

Chcete-li tento problém vyřešit, opravte hodnotu počtu hlaviček (stran) v záznamu FAT32 BPB, aby mohl pokračovat spuštění systému Windows XP. Chcete-li aktualizovat hodnotu, přepište spouštěcí kód systému Windows 95, Windows 98 nebo Windows Millennium Edition. Chcete-li to provést, postupujte takto:

  1. Restartujte počítač pomocí spouštěcí diskety systému Windows 95, Windows 98 nebo Windows Millennium Edition, která obsahuje soubor Sys.com. (Ve výchozím nastavení, je součástí tohoto souboru.)
  2. Vytvořte záložní kopii souboru Msdos.sys v kořenovém adresáři systémové jednotky. Chcete-li to provést, zadejte následující příkazy na příkazovém řádku:
    attrib -h - r -s c:\msdos.sys
    rename msdos.sys *.ysy
  3. Na příkazovém řádku příkaz sys c: přepište spouštěcí kód systému Windows 95, Windows 98 nebo Windows Millennium Edition s přesnými informacemi, BPB. Pokud tato operace úspěšná, přejděte ke kroku 4.

    Pokud používáte spouštěcí disketu systému Windows Millennium Edition a zobrazí následující chybová zpráva, byly odebrány jeden nebo více souborů v systému Windows Millennium Edition:
    Nelze najít soubor systému ve standardních umístěních na jednotce C:
    Postupujte podle následujících kroků umístěte správné soubory na jednotku tak, aby je příkaz sys nalézt:
    1. Zadejte následující příkazy. Stisknutím klávesy ENTER po každém příkazu:
      c:
      cd\windows
      Pokud je systém Windows nainstalován v jiné složce než Windows, příkazy odpovídajícím způsobem upravte.
    2. Zkuste přepnout na složku Command zadáním následujícího příkazu:

      příkaz CD
      Pokud se zobrazí chybová zpráva, že zadaná cesta nebyla nalezena, zadejte následující příkaz, chcete-li vytvořit příkaz složky a pak spustit příkaz příkaz cd :
      příkaz MD
    3. Zadáním následujícího příkazu přejděte do složky EBD:

      cd ebd
      Pokud se zobrazí chybová zpráva, že zadaná cesta nebyla nalezena, zadejte následující příkaz Vytvořit složku EBD a potom opakujte příkaz cd ebd :
      md ebd
    4. Ve složce EBD pomocí následujících příkazů zkopírujte soubor Io.sys z kořenového adresáře pevného disku a přejmenujte jej na Winboot.sys:
      attrib -s -h - r c:\io.sys
      kopírování c:\io.sys winboot.sys
      Winboot.sys je soubor, který vyžaduje program Sys.com.
    5. Přepněte zpět do jednotky a zadejte následující příkazy:
      a:
      sys c:
    Zadáním následujících příkazů obnovte původní soubor Msdos.sys. Stisknutím klávesy ENTER po každém příkazu:

    attrib -s -h c:\msdos.sys - r
    Kopírovat c:\msdos.ysy c:\msdos.sys
    Stisknutím klávesy Y přepsání stávajícího souboru Msdos.sys. Obdržíte "1 soubor (S) ZKOPÍROVÁNO" ověření, že soubor byl přepsán.
  4. Restartujte počítač do systému Windows 95, Windows 98 nebo Windows Millennium Edition a potom zkuste instalaci nebo inovaci na systém Windows XP znovu.

    Poznámka: Nebo po spuštění příkazu sys c: , můžete spustit konzolu pro zotavení a potom pomocí příkazu fixboot přepište spouštěcí kód systému Windows XP. Pomocí tohoto postupu původní instalace pokračuje normálně.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

178947 soubor registru nebyl nalezen. Služby registru může...

318948 "NTLDR nenalezen nebo poškozen" chybová zpráva při upgradu na systém Windows 2000 nebo Windows NT 4.0

320397 Windows se nemusí spustit a může se zobrazit chybová zpráva "NTLDR nenalezen", pokud systém Windows není aktuální a v kořenové složce je příliš mnoho souborů

883275 nelze spustit počítač po změně oprávnění v systému Windows Server 2003, Windows XP nebo Windows 2000

812492 chybová zpráva při spuštění počítače pomocí nesystémového disku

315261 počítač nelze spustit po změně aktivního oddílu pomocí nástroje Správa disků

Pokud zde uvedené články nepomohou vyřešit váš problém nebo pokud se setkáváte s příznaky, které se liší od příznaků popsaných v tomto článku, vyhledejte další informace ve znalostní bázi Microsoft Knowledge Base. Chcete-li hledat znalostní báze společnosti Microsoft, naleznete na následujícím webu společnosti Microsoft:Potom zadejte text chybové zprávy se zobrazí, nebo zadejte popis problému do pole Hledání ve znalostní bázi (KB) .
Vlastnosti

ID článku: 314057 - Poslední kontrola: 20. 1. 2017 - Revize: 2

Váš názor