Při návštěvě webu Windows Update nebo webu Microsoft Update zobrazí chybová zpráva "Pouze správci" v systému Windows XP

Příznaky

Při pokusu o k návštěvě webu Windows Update nebo webu Microsoft Update, může se zobrazit chybová zpráva podobná následující:
Číslo chyby: 0x8DDD0002

Chcete-li instalovat položky ze systému Windows Update, musíte být přihlášeni jako správce nebo jako člen skupiny Administrators. Pokud je počítač připojen k síti, může vám v dokonèení tohoto postupu bránit také nastavení síťových zásad.
Tato zpráva se zobrazí, přestože již jste přihlášeni jako správce nebo jako člen skupiny Administrators.

Poznámka: Další informace o webu Windows Update a webu Microsoft Update naleznete v části "Další informace".

Příčina

K tomuto chování může dojít z libovolného z následujících důvodů:
  1. Nejste přihlášeni jako uživatel, který patří do místní skupiny Administrators.
  2. Nemáte oprávnění klíče registru konkrétní nebo složek.
  3. Operační systém nemůže číst data ve složce %Systemroot%\System32\Catroot2 je.

Řešení

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému Windows


Chcete-li tento problém vyřešit, použijte jednu z následujících metod. Pokud metoda 1 problém nevyřeší, použijte metodu 2.
  • Metoda 1

    Ověřte, zda jste přihlášeni jako uživatel, který patří do místní skupiny Administrators. Chcete-li to provést, klepněte na tlačítko Start, klepněte na tlačítko Spustit, typ
    nusrmgr.cpla potom klepněte na tlačítko OK otevřete okno uživatelské účty .

    Pokud jste součástí síťové domény, postupujte takto:
    1. V okně Uživatelské účty vyberte účet ze seznamu a potom klepněte na příkaz Vlastnosti.
    2. Na kartě Členství ve skupinách ověřte, že jste členem skupiny Administrators.

    Pokud není součástí síťové domény, v okně Uživatelské účty klepněte na účet a potom ověřte, zda Správce počítače se zobrazí pod názvem vašeho účtu.

    Po přihlášení jako správce, zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, nepokračujte Poradce při potížích.
  • Metoda 2

    Odstranění dočasných souborů Internetu. Chcete-li to provést, postupujte takto:
    1. Otevřete okno Aplikace Internet Explorer , klepněte na tlačítko Nástrojea potom klepněte na příkaz Možnosti Internetu.
    2. V okně Možnosti Internetu klepněte na kartu Obecné v části dočasné soubory Internetu, klepněte na tlačítko Odstranit souborya potom klepněte na tlačítko
      OK.
    Zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, nepokračujte Poradce při potížích.
  • Metoda 3

    Ověřte oprávnění pro klíče registru, které používá klient systému Windows Update a Microsoft Update klienta.
    1. Klepněte na tlačítko Start, klepněte na tlačítko
      Spustit, zadejte příkaz regedita klepněte na tlačítko
      OK.
    2. Vyhledejte a vyberte následující klíč registru:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
    3. V nabídce Úpravy klepněte na tlačítko
      Oprávnění, klepněte na tlačítko Přidata potom zadejte
      každý uživatel v dialogovém okně, které se zobrazí.
    4. Klepněte na tlačítko Kontrola jmena klepněte na tlačítko
      OK.
    5. Everyone vyberte v seznamu skupiny nebo jméno uživatele .
    6. Ve skupinovém rámečku oprávnění pro skupinu Everyone, klepnutím zaškrtněte políčko Úplné řízení ve
      Sloupci Povolit .

      Všimněte si, že políčko Číst ve sloupci Povolit nyní také zaškrtnuto.
    7. Pak vyberte jednotlivé uživatele v seznamu skupiny nebo jméno uživatele a potom ověřte, zda jsou zaškrtnuta žádná políčka v
      Odepřít sloupec. Klepnutím zrušte zaškrtnutí políček, které jsou vybrány ve sloupci Odepřít .
    8. Klepněte na tlačítko Upřesnit, vyberte klepnutím
      Nahradit položky oprávnění ve všech podřízených objektech , zaškrtněte políčko a klepněte na tlačítko OK.
    9. Pokud se zobrazí výzva k potvrzení a potom klepněte na tlačítko OK zavřete dialogové okno, klepněte na tlačítko Ano .
    Zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, nepokračujte Poradce při potížích.
  • Metoda 4

    Ověřte oprávnění můžete ve struktuře složek používá klient systému Windows Update nebo Microsoft Update klienta.
    1. Klepněte na tlačítko Start, klepněte na tlačítko
      Spustit, zadejte příkaz explorera klepněte na tlačítko
      OK.
    2. Rozbalte položku počítače, rozbalte položku
      Systémové jednotkya poté rozbalte položku
      V systému WINDOWS.
    3. SoftwareDistributionklepněte pravým tlačítkem myši a potom klepněte na příkaz Vlastnosti.
    4. V okně Vlastnosti SoftwareDistribution klepněte na kartu zabezpečení a ověřte, zda jsou v seznamu skupiny nebo jméno uživatele .
    5. V seznamu skupiny nebo jméno uživatele vyberte skupinu Everyone. Ve skupinovém rámečku oprávnění pro skupinu Everyoneklepnutím zaškrtněte políčko Úplné řízení ve sloupci Povolit .

      Všimněte si, že
      Nyní je také zaškrtnuto políčko Číst ve sloupci Povolit .
    Zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, nepokračujte Poradce při potížích.
  • Metoda 5

    Přejmenujte složku Catroot2. Chcete-li to provést, zadejte následující příkazy na příkazovém řádku stisknutím klávesy ENTER po každém řádku:
    net stop cryptsvc
    ren %systemroot%\system32\catroot2 oldcatroot2
    net start cryptsvc
    Potom zkuste znovu navštivte webu Windows Update nebo webu Microsoft Update. Pokud je problém vyřešen, nepokračujte Poradce při potížích.
  • Metoda 6

    Přejmenujte složku SoftwareDistribution. Chcete-li to provést, postupujte takto.
    1. Restartujte počítač v nouzovém režimu.
    2. Vyhledejte a přejmenujte
      Jednotka: \Windows\SoftwareDistribution složku
      SoftwareDistribution.old.

      Poznámka: Jednotka je písmeno jednotky, systém.
    3. Restartujte počítač v normálním režimu.

Další informace

Musí být místní správce k návštěvě webu Windows Update nebo webu Microsoft Update. Při přihlášení jako bez oprávnění správce nemůže naleznete na webu, i při použití Spustit jako ke spuštění aplikace Internet Explorer pomocí účtu správce. K tomuto problému dochází, protože jiných služeb systému jsou zapojeny do procesu. Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
326686 zobrazí jednu nebo více chybové zprávy Pokud správce systému zakáže systému Windows Update nebo Microsoft Update

Vlastnosti

ID článku: 316524 - Poslední kontrola: 20. 1. 2017 - Revize: 1

Microsoft Windows Update, Microsoft Update, Microsoft Windows XP Home Edition, Microsoft Windows XP Professional

Váš názor