ID události 11 v protokolu systému v řadiči domény

Příznaky

V systémovém protokolu na jeden nebo více řadičů domény, mohou být zaznamenány následující události:


Tato událost může také použít další hlavní názvy služeb. Například může tato událost také použít host /NetBIOSComputerName.

Příčina

K tomuto problému dochází, protože dvě nebo více účtů počítače mají stejný hlavní název služby (SPN) registrován. V případě, že Centrum distribuce klíčů (KDC) přijímá žádosti o lístek a související SPN existuje více než jednou když se kontroluje na globální katalog (GC) pro ověření forestwide je zaprotokolována událost s ID 11.

Řešení

Chcete-li vyřešit tento problém, vyhledejte účty počítače, které mají duplicitní názvy SPN. Při vyhledání počítačů, které mají duplicitní názvy SPN, můžete odstranit účet počítače z domény, disjoin a znovu připojit počítač k doméně, nebo můžete pomocí nástroje ADSIEdit opravit hlavní název služby v počítači, který má nesprávný název SPN.

K vyhledání účtů počítačů, které mají duplicitní názvy SPN, použijte jednu z následujících metod.

Metoda 1: Použití nástroje LDP

Poznámka: Pokud nemáte nainstalovány nástroje podpory systému Windows 2000, je nainstalujte z disku CD-ROM systému Windows 2000 před pokračováním. Spustitelný soubor instalace nástrojů podpory je umístěn na disku CD-ROM ve složce Support\Tools. Instalace nevyžaduje restartování počítače. Však bude pravděpodobně k restartování počítače aktualizujte proměnné prostředí.

  1. Klepněte na tlačítko Start, na příkaz Spustit, zadejte příkaz LDP a klikněte na tlačítko OK.
  2. Klepněte na připojení a klepněte na tlačítko Připojit.
  3. Ponechejte výchozí nastavení a klepněte na tlačítko OK.

    Poznámka: Pokud neobdržíte očekávaný výsledek, zkuste jiné hledání pomocí portu globální katalog (3268) místo výchozí nastavení (389).
  4. Klepněte na připojení a potom klepněte na příkaz vytvořit vazbu.
  5. Ponechejte výchozí nastavení a klepněte na tlačítko OK.
  6. Klepněte na tlačítko Zobrazita potom klepněte na tlačítko strom.
  7. Zadejte v dialogovém okně Zobrazení stromu DC =doména, DC = com do pole Základní rozlišující název , kde doména je domény.
  8. Klepněte na tlačítko Procházeta potom klepněte na tlačítko Hledat.
  9. V dialogovém okně Hledat zadejte DC =doména, DC = com do pole Základní rozlišující název .
  10. Do pole Hledat zadejte (serviceprincipalname= HOST /mycomputer.mydomain.com)v rozevíracím seznamu Filtr . Pokud hlavní název služby, který je uveden v chybě v protokolu systému se liší od tohoto příkladu, zadejte hlavní název služby, na které se vztahuje k chybě.


    Poznámka: Pokud neobdržíte očekávané výsledky, zkuste hledat "HOST /" jako protiklad k vyhledání pouze přesný název SPN událostí ID.
  11. V rámci oboruklepněte podstrom.
  12. Klepněte na příkaz Spustit.

Metoda 2: Použití nástroje Ldifde

Pomocí nástroje Ldifde výpis SPN doménové struktury:

  1. Z řadiče domény spusťte příkazový řádek a potom zadejte následující řetězec:

    ldifde -f check_SPN.txt -t 3268 - d "" servicePrincipalName -l - r "(servicePrincipalName = hostitele/tento počítač *)" podstromu -p
    (Poznámka: vzhledem k tomu, že pomocí parametru -t 3268 určit, že je v dotazu použit server globálního katalogu (GC) a pomocí parametru -d nelze zadat explicitní rozlišující název (DN), kořenovou DN slouží k hostiteli / tento počítač * parametr. Proto můžete vyhledat všechny názvy SPN, které obsahuje tento řetězec.
  2. V programu Poznámkový blok otevřete soubor check_SPN.txt a pak vyhledat název SPN, které je hlášeno v protokolu událostí.
  3. Poznámka: uživatelské účty a účty počítačů, pod kterými je umístěn hlavní název služby.

Metoda 3:

V následujícím článku Microsoft TechNet pomocí skriptu nástroje querySpn.vbs. Chcete-li tento skript použít, zkopírujte kód, vložit jej do programu Poznámkový blok a uložte skript jako nástroj querySpn.vbs.Spusťte skript pomocí následujícího příkazu:
cscript spnquery.vbs hostitele / tento počítač * > check_SPN.txt
Poznámka: Check_SPN.txt souboru získaných výstup ze skriptu v metodě 3 lze stejným způsobem popsaným v metodě 2.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Vlastnosti

ID článku: 321044 - Poslední kontrola: 16. 1. 2017 - Revize: 1

Váš názor