Chybová zpráva "Součást protokolu RDP"Šifrování"zjistila chybu..."

Příznaky

Po instalaci systému Windows 2000 Security Rollup Package 1 (SRP1), nemusí být klienti Terminálové služby připojit k serveru Terminálové služby. Tento problém může nastat také při použití součásti Webové připojení ke vzdálené ploše v počítači se systémem Windows XP Professional se připojit k serveru Terminálové služby. Když nastane tento problém, je v protokolu událostí systému zaznamenána událost s ID 50:
Typ události: Chyba
Zdroj události: TermDD
ID události: 50
Popis:
"Šifrování dat" součást protokolu RDP zjistila chybu v protokolu a klienta odpojila.
Další informace získáte kliknutím na následující číslo v článku databáze Microsoft Knowledge Base:
307454 MS01-052: neplatná data RDP mohou způsobit selhání Terminálové služby

Klient Terminálové služby může také zobrazí následující chybová zpráva při pokusu o připojení:
Terminálový Server ukončil připojení.

Příčina

Možný spor mezi Icaapi.dll a Rdpwsx.dll dynamických knihoven (DLL) může způsobit, že soukromý klíč certifikátu na serveru Terminálové služby nejsou synchronizovány.

Řešení

Chcete-li vyřešit tento problém za vás, přejděte "Opravit za mě" oddílu. Pokud dáváte přednost tyto potíže vyřešit sami, přejděte k části "opravit sám".

Automatická oprava



Chcete-li tento problém vyřešit automaticky, klepněte na tlačítko oprava tlačítko nebo odkaz. V dialogovém okně Stažení souboru klepněte na příkaz Spustit a potom postupujte podle pokynů v Průvodci oprav.




Poznámky
  • Tento průvodce může být dostupný pouze v angličtině. Nicméně, automatická oprava však také funguje pro ostatní jazykové verze systému Windows.
  • Pokud nejste v počítači, který má daný problém, uložit oprava ji řešení jednotku flash nebo na disk CD a spusťte jej v počítači, který má tyto potíže.

Potom pokračujte k části "Byl problém opraven?".



Opravím si sám

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému Windows

Chcete-li tento problém vyřešit, postupujte takto:
  1. Spusťte Editor registru.
  2. Vyhledejte a vyberte následující podklíč registru:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
  3. V tomto podklíči registru odstraňte následující hodnoty:
    • Certifikát
    • Certifikát X509
    • X509 certifikát ID
  4. Ukončete Editor registru a potom restartujte server.

Byl problém vyřešen?

  • Zkontrolujte, zda byl problém vyřešen. Pokud je problém vyřešen, jste hotovi s touto částí. Pokud potíže přetrvávají, můžete kontaktovat podporu.
  • Uvítáme vaše názory. Sdělit svůj názor nebo nahlásit potíže s tímto řešením komentář "Opravit za mě" blogu nebo nám odešlete e -mailovou zprávu.

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Vlastnosti

ID článku: 323497 - Poslední kontrola: 16. 1. 2017 - Revize: 1

Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server, Microsoft Windows XP Professional, Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Web Edition

Váš názor