Soubor je uzamčen nebo přístup byl odepřen chybová zpráva při ukládání souborů v síti

Příznaky

Při pokusu uložit soubor, například sešit aplikace Microsoft Excel, který jste otevřeli pomocí cesty universal naming úmluvy (UNC), zobrazí se chybová zpráva podobná jedné z následujících akcí:
Soubor nelze číst. Soubor je uzamčen.
Přístup byl odepřen
Chyba uzamčení
Prohlížeč událostí může obsahovat následující událost:

Příčina

K tomuto problému dochází, pokud přesměrovač vyprázdní obsah souboru a zapíše do popisovače souboru s přístupem jen pro čtení místo do popisovače souboru s přístupem pro zápis. Pokud Přesměrovač přijal přerušení příležitostného zamykání na none, vyprázdnil mezipaměť pro soubor, ale nezrušil inicializaci mezipaměti souboru. Přesměrovač musel také vyprázdnit a inicializaci, pokud dojde k nastavený konec souboru, protože je asynchronní přerušení příležitostného zamykání. Vzhledem k tomu, že ji nezrušil inicializaci mezipaměti pro soubor, zapsal do nesprávného popisovače souboru.

Řešení

Informace o aktualizaci Service pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Microsoft Windows XP. Další informace získáte kliknutím na následující číslo v článku databáze Microsoft Knowledge Base:
322389 jak získat nejnovější aktualizaci service pack pro systém Windows XP

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk. Anglická verze této opravy má atributy souborů (nebo novější) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi časem UTC a místním časem, naleznete na kartě časové pásmo na panelu Datum a čas v okně Ovládací panely.

Systém Windows XP s aktualizací SP1, Windows XP Tablet PC Edition

Date        Time  Version       Size      File name -------------------------------------------------------------- 
30-Jan-2003 21:41 5.1.2600.1164 400,896 Mrxsmb.sys
30-Jan-2003 21:41 5.1.2600.1164 154,880 Rdbss.sys

Windows XP 64-Bit Edition

Date         Time  Version       Size      File name ------------------------------------------------------------- 
30-Jan-2003 21:41 5.1.2600.1164 1,259,392 Mrxsmb.sys
30-Jan-2003 21:41 5.1.2600.1164 489,216 Rdbss.sys

Jak potíže obejít

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému Windows
Chcete-li tento problém vyřešit, zakažte na serveru příležitostné zamykání:
  1. Klepněte na tlačítko Starta potom klepněte na tlačítko
    Spustit.
  2. Do pole Otevřít zadejte
    regedita stiskněte klávesu ENTER.
  3. V editoru registru vyhledejte následující podklíč registru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\LanmanServer\Parameters
  4. V pravém podokně klepněte na položku EnableOplocksa stiskněte klávesu ENTER.
  5. Do pole Údaj hodnoty zadejte
    0a pak stiskněte klávesu ENTER.
  6. Ukončete Editor registru.

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti uvedených na začátku tohoto článku.
Tento problém byl poprvé opraven v aktualizaci Microsoft Windows XP Service Pack 2.

Další informace

Další informace o příležitostné uzamčení klepněte na následující číslo článku databáze Microsoft Knowledge Base:
296264 Konfigurace příležitostného zamykání v systému Windows 2000
Sledování tohoto problému ukazuje, že soubor je otevřen nejméně dvakrát a ukazuje, že systém nesprávně zapisuje do popisovače souboru jen pro čtení. Trasování zobrazující tento problém je podobné následujícímu:
96  CLIENT SMB: C NT create & X, File = \newshare.xls           SMB: Desired Access = 0x00020089 
(Read Data,Read EA,Read Attributes)
97 SERVER SMB: R NT create & X, FID = 0x5
SMB: Oplock Level = Batch

<content removed that displays the client program reading and locking the file, but the file is not closed>

450 CLIENT SMB: C NT create &amp; X, File = \newshare.xls
SMB: Desired Access = 0x0002019F
(Read/Write Data, Read/Write EA, Read/Write Attributes)

451 SERVER SMB: R NT create &amp; X, FID = 0xc007
SMB: Oplock Level = NONE

<content removed that displays the client program reading, locking, writing and flushing data on this file handle>

585 CLIENT SMB: C write &amp; X, FID = 0x5, Write 0xc00 at 0x00005000
PID = 0xFEFF TID = 0x1002 MID = 0x4400 UID = 0x0801
586 SERVER SMB: R write &amp; X - NT error, System, Error, Code = (34) STATUS_ACCESS_DENIED
Poznámka: Identifikátor procesu (PID) 0xFEFF v rámci 585 představuje proces systému klienta, který využívá popisovač souboru jen pro čtení. Klientský program zápisu dat na disk není uveden.
Vlastnosti

ID článku: 812937 - Poslední kontrola: 16. 1. 2017 - Revize: 2

Váš názor