Oprava: "Tato akce je platná pouze pro produkty, které jsou aktuálně nainstalován" chybová zpráva po instalaci dvou hlavních aktualizací produktu v systému Windows XP SP2 pomocí Instalační služba Windows Installer 3.0

Příznaky

Po instalaci dvou hlavních aktualizací produktu v systému Microsoft Windows XP Service Pack 2 (SP2) jsou žádné další instalační operace neúspěšné. Když nastane tento problém, zobrazí se následující chybová zpráva:
Tato akce je platná pouze pro produkty, které jsou aktuálně nainstalované
Poznámka: Aktualizace softwaru obsahuje opravy, odinstalace nebo další softwarové aktualizaci aplikací, které se vztahují k produktu. Je hlavní upgrade představuje komplexní aktualizaci produktu, která vyžaduje změnu vlastnosti ProductCode .

Příčina

K tomuto problému dochází, pokud Instalační služba Microsoft Windows Installer 3.0 pokouší nalézt nesprávný produkt. Tento problém je způsobena chybou v pořadí aktualizací.

Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady


Neexistují žádné požadavky.

Požadavek na restartování


Máte k restartování počítače po instalaci této opravy hotfix.

Informace o nahrazení opravy hotfix


Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi časem UTC a místním časem, naleznete na kartě časové pásmo na panelu Datum a čas v okně Ovládací panely.
Date          Time   Version        Size       File name --------------------------------------------------------------
25-Jan-2005 14:52 1.0.0.0 1,089,264 Windowsxp-kb893048-x86-enu.exe
25-Jan-2005 14:50 1.0.0.0 929,520 Windowsxp-kb893048-x86-symbols-enu.exe
25-Jan-2005 17:12 3.0.3790.2601 2,804,736 Msi.dll
Poznámka: Soubor Windowsxp-kb893048-x86-enu.exe je instalační program opravy hotfix. Soubor Windowsxp-kb893048-x86-symbols-enu.exe je instalační soubor opravy hotfix symbol s názvem Msi.pdb. Není nutné instalovat Soubor Windowsxp-kb893048-x86-symbols-enu.exe

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Další informace získáte kliknutím na následující číslo v článku databáze Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 893048 - Poslední kontrola: 16. 1. 2017 - Revize: 2

Váš názor