Můžete obdržet chybu "paměť nemůže být přečtena" zpráva při klepnutí na některé odkazy na webové servery v aplikaci Internet Explorer 6

Příznaky

Používáte aplikaci Microsoft Internet Explorer 6 v počítači, který je spuštěn některý z následujících operačních systémů:
  • Microsoft Windows Server 2003
  • Microsoft Windows XP Service Pack 1 (SP1)
  • Microsoft Windows XP Service Pack 2 (SP2)
Po klepnutí na některé odkazy na webové servery, může se zobrazit následující chybová zpráva:
Instrukce v paměti 0x7777f3d9 odkaz na 0x0c73a8bb. Paměť nelze číst. Klepněte na tlačítko OK ukončete program.

Příčina

K tomuto problému dochází s odkazy na webové servery používající dlouhých řetězců URL, které jsou volány ze skriptů. K tomuto problému dochází, protože další informace, které je přidružena adresa URL webu není správně uloženy v souboru Index.dat. Soubor Index.dat udržuje odkaz na všechny adresy URL webové stránky, které navštívíte. Po klepnutí na odkaz webu v aplikaci Internet Explorer, aktualizace aplikace Internet Explorer historie aplikace Internet Explorer informace o adresu URL webového serveru. V některých případech ukládá aplikace Internet Explorer Další informace, který je spojen s adresou URL v souboru Index.dat. Pokud tyto dodatečné informace je velmi dlouhý, zobrazí se chybová zpráva.

Poznámka: Soubor Index.dat je umístěn ve složce %userprofile%\Local Settings\History.

Řešení

Systém Windows XP

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Předpoklady
Chcete-li nainstalovat tuto opravu hotfix, musí mít systém Windows XP s aktualizací SP1 nebo v počítači nainstalovaná aktualizace Windows XP SP2.
Požadavek na restartování
Po instalaci této opravy hotfix musíte restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje žádné další opravy hotfix.
Informace o souborech
Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi časem UTC a místním časem, naleznete na kartě časové pásmo na panelu Datum a čas v okně Ovládací panely.
Date         Time   Version            Size    File name    Service Pack
------------------------------------------------------------------------
07-Sep-2005 02:14 6.0.2900.2754 1,485,824 Shdocvw.dll SP2
07-Sep-2005 00:09 5.1.2600.2754 30,720 Arpidfix.exe SP2
06-Sep-2005 10:48 6.0.2800.1740 1,338,880 Shdocvw.dll SP1

Windows Server 2003

Informace o aktualizaci Service pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Windows Server 2003. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
889100 jak získat nejnovější aktualizaci service pack pro systém Windows Server 2003

Informace o opravě hotfix

Předpoklady
Neexistují žádné požadavky.
Požadavek na restartování
Po instalaci této opravy hotfix musíte restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje žádné další opravy hotfix.
Informace o souborech
Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Chcete-li najít rozdíl mezi časem UTC a místním časem, použijte kartu časové pásmo v položce datum a čas v okně Ovládací panely.
Date         Time   Version            Size    File name     Service Pack
-------------------------------------------------------------------------
03-Jul-2005 02:19 6.0.3790.363 1,058,304 Browseui.dll
07-Sep-2005 02:10 6.0.3790.404 1,398,272 Shdocvw.dll
07-Sep-2005 02:33 6.0.3790.2524 1,503,744 Shdocvw.dll SP1
07-Sep-2005 00:29 5.2.3790.2524 32,256 Arpidfix.exe SP1

Jak potíže obejít

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1: Vymažte dočasné soubory Internetu a historii mezipaměti

  1. Spusťte aplikaci Internet Explorer.
  2. V nabídce Nástroje klikněte na Možnosti Internetu
  3. Ve skupinovém rámečku dočasné soubory Internetuklepněte na tlačítko Odstranit soubory, zaškrtněte políčko Odstranit veškerý obsah offline a klepněte na tlačítko OK.
  4. Ve skupinovém rámečku Historieklepněte na tlačítko Vymazat historiia potom klepněte na tlačítko OK.
  5. Vymazání dočasných souborů Internetu a historie mezipaměti. To lze provést ve skupinovém rámečku Historieklepněte na tlačítko Vymazat historii a klepněte na tlačítko Ano.
  6. Restartujte aplikaci Internet Explorer.

Metoda 2: Odebrat složku historie

  1. Restartujte počítač.
  2. Přihlaste se k počítači pomocí pověření pro správu.
  3. Spusťte Průzkumníka Windows.
  4. Vyhledejte ve složce %userprofile%\Local Settings\History pro uživatele, který má potíže.

    Poznámka: Složka Local Settings je skrytá složka. K zobrazení této složky, povolte možnost Zobrazovat skryté soubory a složky v programu Průzkumník Windows. Chcete-li to provést, klepněte v nabídce Nástroje v programu Průzkumník Windows, klepněte na příkaz Možnosti složky, klepněte na kartu zobrazení , povolte možnost Zobrazovat skryté soubory a složky .
  5. Klepněte pravým tlačítkem myši na složku Historie a potom klepněte na příkaz Odstranit.
  6. Po zobrazení výzvy k potvrzení odebrání složky, klepněte na tlačítko Ano.
  7. Ukončete program Průzkumník Windows.
  8. Restartujte počítač.
  9. Přihlaste se k počítači jako uživatel, který dojde k těmto potížím.
  10. Spusťte aplikaci Internet Explorer.
  11. V nabídce Nástroje klikněte na Možnosti Internetu
  12. Ve skupinovém rámečku dočasné soubory Internetuklepněte na tlačítko Odstranit soubory, zaškrtněte políčko Odstranit veškerý obsah offline a klepněte na tlačítko OK.
  13. Restartujte aplikaci Internet Explorer.

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro". Tento problém byl poprvé opraven v systému Windows Server 2003 Service Pack 2.

Další informace

Další informace o standardní terminologii používané k popisu aktualizací softwaru společnosti Microsoft klepněte na následující číslo článku databáze Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 899811 - Poslední kontrola: 16. 1. 2017 - Revize: 1

Váš názor