Počítač se systémem Windows 2000, systémem Windows Server 2003 nebo systémem Windows XP nastavené pomocí bitové kopie systému Windows 2000, Windows Server 2003 nebo Windows XP se nezobrazí v konzole služby WSUS

Příznaky

Počítač se systémem Windows 2000, Windows Server 2003 nebo Windows XP se nezobrazí v systému Windows Server Update Services (WSUS) konzoly.

K tomuto problému dochází, pokud počítač byla nastavena pomocí bitové kopie systému Windows 2000, bitové kopie systému Windows Server 2003 nebo bitové kopie systému Windows XP obsadí hodnotu registru SusClientID před nasazením klientských počítačů.

Při použití programu Sysprep k generalize obrazu virtuálního počítače nebo vytvořit obrázky pomocí unikátní technologii generování identifikátorů SID, hodnotu registru SusClientId není zaškrtnuté, pokud je naplněn uvnitř obrazu před nasazení bitové kopie.

Poznámka: V WSUS 3.0 klient změní jeho SusClientID změně konfigurace hardwaru. Pro systém Windows Vista, Windows Server 2008 a novější verze program Sysprep se změní SusClientID obnovit. Proto tento problém se týká pouze virtuální počítače, které běží operační systémy starší než Windows Vista nebo které nebyly vytvořeny pomocí nástroje Sysprep.

Příčina

K tomuto problému dochází, protože klienti s nainstalovanou bitovou kopií může mít duplicitní SusClientID hodnotu v registru.

Řešení

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1: Změňte registr

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému Windows
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, do pole Otevřít zadejte příkaz cmd a klepněte na tlačítko OK.
  2. Na příkazovém řádku zadejte příkaz net stop wuauserva stiskněte klávesu ENTER.
  3. Klepněte na tlačítko Start, klepněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  4. Vyhledejte a vyberte následující podklíč registru:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
  5. V podokně podrobností Editoru registru odstraňte následující položky registru:
    • PingID
    • AccountDomainSid
    • SusClientId
    • SusClientIDValidation
    Poznámka: Windows Update Agent 3.0 přidá hodnotu SusClientIDValidation. Tato hodnota byla vydána v květnu 2007. Ostatní položky registru existují v obou Windows Update Agent 2.0 a systému Windows Update Agent 3.0.
  6. Ukončete Editor registru.
  7. Na příkazovém řádku zadejte příkaz net start wuauserva stiskněte klávesu ENTER.
  8. Na příkazovém řádku zadejte wuauclt.exe /resetauthorization/detectnowa stiskněte klávesu ENTER.
  9. Počkejte 10 minut cyklu zjišťování dokončit.
  10. Spusťte konzolu služby WSUS a ujistěte se, že klienti se zobrazí v konzole služby WSUS.

Metoda 2: Použití souboru Sysprep.inf

Pokud již máte soubor s názvem souboru Sysprep.inf ve stejné složce jako Sysprep.exe, postupujte takto.

Poznámka: Chcete-li vyřešit tento problém, musí být takto použity před generalize obrazu.
  1. Poklepejte na soubor v programu Poznámkový blok otevřete soubor Sysprep.inf.
  2. Přejděte dolů k vyhledání oddílu [GuiRunOnce] .

    Poznámka: Oddíl [GuiRunOnce] registru neexistuje, vytvořte jej zadáním na konci souboru Sysprep.inf.
  3. Pod [oddíl GuiRunOnce]zadejte následující text.

    Poznámka: Tyto nové příkazy, které jsou uvedeny jako "Command0" až "Command3." Tato označení jsou správné pouze tehdy, pokud oddíl [GuiRunOnce] obsahuje aktuálně žádné příkazy. Pokud již existují příkazy pod [oddíl GuiRunOnce], změňte tak, aby začínala Další pořadové číslo položky "příkazx" v nové příkazy. Například pokud oddíl již obsahuje pět příkazů, které jsou uvedeny jako "Command0" až "Command4", číslo nové příkazy jako "Command5" až "Command8".
    • Command0="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f"
    • Command1="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f"
    • Command2="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f"
    • Command3="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f"
  4. V nabídce soubor klepněte na tlačítko Uložit.
  5. V nabídce soubor klepněte na příkaz Konec.

Metoda 3: Vytvořte soubor Sysprep.inf, pokud nemáte soubor

Pokud nemáte soubor s názvem souboru Sysprep.inf ve stejné složce jako Sysprep.exe, postupujte takto Chcete-li vytvořit soubor.

Poznámka: Chcete-li vyřešit tento problém, musí být takto použity před generalize obrazu.
  1. Klepněte na tlačítko Start, přejděte na příkaz Všechny programy, na položku Příslušenstvía potom klepněte na tlačítko Poznámkový blok.
  2. Zadejte následující text:
    Oddíl [GuiRunOnce]

    Command0="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f"

    Command1="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f"

    Command2="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f"

    Command3="reg.exe odstranit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f"
  3. V nabídce soubor klepněte na tlačítko Uložit.
  4. Vyhledejte adresář, ve kterém je umístěn soubor Sysprep.exe.
  5. Do pole název souboru zadejte soubor Sysprep.inf .
  6. V poli Uložit jako typ vyberte položku Všechny soubory .
  7. Klepněte na tlačítko Uložit.
  8. V nabídce soubor klepněte na příkaz Konec.

Další informace

První počítač se systémem Windows 2000, počítače se systémem Windows Server 2003 nebo počítače se systémem Windows XP nastavené pomocí bitové kopie systému Windows 2000, bitové kopie systému Windows Server 2003 nebo bitové kopie systému Windows XP se zobrazí v konzole služby WSUS. Dalším systémem Windows 2000, systémem Windows Server 2003 nebo systémem Windows XP počítačů, které jsou nastaveny pomocí stejného obrazu se však nezobrazí. K tomuto problému dochází, protože první počítač, který byl nastaven pomocí jedné z těchto obrázků používá stejnou hodnotu SusClientID.

Po provedení kroků popsaných v části "Řešení", je vytvořena nová hodnota SusClientID. Kromě toho další počítače se systémem Windows 2000, počítače se systémem Windows Server 2003 nebo počítače se systémem Windows XP, které jsou nastaveny pomocí stejného obrazu zobrazí v konzole služby WSUS.



Doplnili jsme automatickou funkci agenta Windows Update Agent, která je nainstalována v klientských počítačích služby WSUS. Tato funkce může pomoci vyřešit tento problém duplicitní SusClientID. Tato funkce poskytuje řešení, která je přidána do klienta služby Agent webu Windows Update počínaje verzí 7.0.6000.374. (Tato verze je verze klienta, která byla součástí služby WSUS 3.0.)

Toto řešení používá k určení, zda aktuální hardware klienta změnila hodnota SUSClientID byl vytvořen pomocí rutiny ověření hardwaru. (Tento hardware zahrnuje síťové adaptéry a pevné disky).

Rutinní ověření hardwaru je uložena jako binární rozsáhlý objekt v klíči registru Susclientidvalidation ve stejném umístění jako hodnotu registru Susclientid. Pokud rutinní ověření hardwaru označuje, že došlo ke změně veškerého hardwaru, klient vygeneruje novou hodnotu SusClientID.

Poznámka: Rutinní ověření hardwaru vyžaduje, aby klient připojit k serveru se systémem Windows Software Update Services 3.0 nebo novější verzi WSUS a serveru se systémem Windows Software Update Services 2.0.
Vlastnosti

ID článku: 903262 - Poslední kontrola: 16. 1. 2017 - Revize: 1

Váš názor