Nelze nainstalovat tiskárnu, která používá vlastní tiskový procesor v serveru Windows Server 2003 nebo Windows XP Professional

Příznaky

Při pokusu o přidání další tiskárny do počítače se systémem Microsoft Windows Server 2003 nebo Microsoft Windows XP Professional pomocí Průvodce přidáním tiskárny zobrazí chybová zpráva po dokončení Průvodce přidáním tiskárny. Chybová zpráva, která se může zobrazit podobná následující:

Nelze nainstalovat tiskárnu. Tiskový procesor neexistuje.
Proto nelze přidat tiskárnu.

Příčina

K tomuto problému dochází, protože ovladač tiskárny používá vlastní tiskový procesor.

Řešení

Informace o aktualizaci Service pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Windows Server 2003. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
889100 jak získat nejnovější aktualizaci service pack pro systém Windows Server 2003

Informace o opravě hotfix systému Windows XP

Tato oprava hotfix může odstranit všechny porty IP tiskárny v počítači. Chcete před použitím této opravy hotfix zálohovat konfiguraci portu.

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Chcete-li najít rozdíl mezi časem UTC a místním časem, použijte kartu časové pásmo v položce datum a čas v okně Ovládací panely.
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Updspapi.dll6.2.29.0371,42412-Oct-200523:12x86ŽádnýNení k dispozici
Ntprint.dll5.1.2600.304391,13629-Nov-200615:08x86SP2SP2QFE


Informace o opravě hotfix systému Windows Server 2003

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí mít Windows Server 2003 Service Pack 1 nebo x64 založené verzi Windows Server 2003 nainstalován.

Požadavek na restartování

Po instalaci této opravy hotfix je nutné restartovat server.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Chcete-li najít rozdíl mezi časem UTC a místním časem, použijte kartu časové pásmo v položce datum a čas v okně Ovládací panely.
Windows Server 2003, verze x86
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Localspl.dll5.2.3790.2524348,16007-Sep-200502:30x86SP1SP1QFE
Ntprint.dll5.2.3790.252499 84007-Sep-200502:30x86SP1SP1QFE
Updspapi.dll6.1.22.4371,93605-Mar-200501:30x86ŽádnýNení k dispozici
Windows Server 2003, verze x64
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Localspl.dll5.2.3790.2524749,56807-Sep-200515:24x64SP1SP1QFE
Ntprint.dll5.2.3790.2524158,72007-Sep-200515:24x64SP1SP1QFE
Wntprint.dll5.2.3790.252499 84007-Sep-200515:24x86SP1WOW
Updspapi.dll6.1.22.4462,56007-Sep-200515:24x64ŽádnýNení k dispozici
Windows Server 2003, verze s procesorem Itanium
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SPSložka služby
Localspl.dll5.2.3790.2524968,19207-Sep-200515:23IA-64SP1SP1QFE
Ntprint.dll5.2.3790.2524275,45607-Sep-200515:23IA-64SP1SP1QFE
Wntprint.dll5.2.3790.252499 84007-Sep-200515:23x86SP1WOW
Updspapi.dll6.1.22.4639,71207-Sep-200515:23IA-64ŽádnýNení k dispozici

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro". Tento problém byl poprvé opraven v systému Windows Server 2003 Service Pack 2.

Další informace

Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
824684 Popis standardní terminologie používané k popisu aktualizací softwaru společnosti Microsoft

Technická podpora pro verze systému Microsoft Windows x64

Pokud byl hardware dodán s Microsoft Windows x64 edition, již nainstalována, výrobce hardwaru poskytuje technickou podporu a odbornou pomoc pro systém Windows x64 edition. V tomto případě výrobce hardwaru poskytuje podporu proto Windows x64 edition byl zahrnut v dodaném hardwaru. Výrobce hardwaru mohl upravit instalaci systému Windows x64 edition pomocí jedinečných součástí. Jedinečné součásti může zahrnout specifické ovladače zařízení a volitelná nastavení, aby maximalizoval výkon hardwaru. Společnost Microsoft bude vyvíjet přiměřené úsilí, jestliže potřebujete technickou pomoc k systému Windows x64 edition. Však bude pravděpodobně nutné obrátit přímo na výrobce. Výrobce je tím nejkvalifikovanějším pro poskytnutí podpory k softwaru, který instaloval na hardware. Pokud jste zakoupili samostatně Windows x64 edition, jako je například Microsoft Windows Server 2003 x64 edition, poskytne technickou podporu společnosti Microsoft.

Informace o systému Microsoft Windows XP Professional x64 Edition naleznete na následujícím webu společnosti Microsoft:Informace o x64 verze systému Microsoft Windows Server 2003 naleznete na následujícím webu společnosti Microsoft:
Vlastnosti

ID článku: 906752 - Poslední kontrola: 16. 1. 2017 - Revize: 1

Váš názor