Příkaz "E-mail" chybí nebo není k dispozici v aplikaci Excel 2007, PowerPoint 2007 nebo Word 2007

Příznaky

V aplikaci Microsoft Office Excel 2007, Microsoft Office PowerPoint 2007 nebo Microsoft Office Word 2007 klepnete na tlačítko Odeslat v nabídce Office . Když toto provedete, se vyskytnout některý z následujících příznaků:
  • Odeslat příkaz není k dispozici.
  • Chybí příkaz E-mail .

Příčina

Tomuto problému může dojít, pokud v počítači není nainstalována aplikace Microsoft Outlook.

Řešení

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1: Změňte výchozí program pro e-maily do aplikace Outlook

Chcete-li změnit výchozí program pro e-maily do aplikace Outlook, přejděte k části "Opravit za mě". Chcete-li změnit výchozí e-mailový program Outlook sami, přejděte "opravit sám" oddíl.

Automatická oprava


Chcete-li změnit výchozí program pro e-maily do aplikace Outlook automaticky, klepněte na odkaz Opravit tyto potíže. Klepněte na tlačítko
Spustitv
Stažení souborudialogové okno pole a postupujte podle kroků v tomto průvodci.




Poznámka: Tento průvodce může být v angličtině pouze; Automatická oprava však také funguje pro ostatní jazykové verze systému Windows.

Poznámka: Pokud nejste na počítači, který má problém, automatickou opravu můžete uložit na jednotku flash nebo na disk CD a potom můžete spustit v počítači, který má potíže.

Opravím si sám

Chcete-li změnit výchozí e-mailový program Outlook sami, postupujte takto:
  1. Spusťte aplikaci Microsoft Internet Explorer.
  2. V nabídce Nástroje klikněte na Možnosti Internetu
  3. Klepněte na kartu programy .
  4. V rozevíracím seznamu E-mail vyberte položku Microsoft Outlook.
  5. Klepněte na tlačítko OK

Metoda 2: Ověřte nastavení registru

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému Windows
  1. Ukončete všechny programy.
  2. Klepněte na tlačítko Start, klepněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte a vyberte následující podklíč registru:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem
  4. Vyhledejte následující hodnoty registru. Tyto hodnoty jsou obvykle uvedeny v klíči Windows Messaging Subsystem.
    JménoNapišteData
    ROZHRANÍ MAPIREG_SZ1
    CMCREG_SZ1
    CMCDLLNAMEREG_SZMapi.dll
    CMCDLLNAME32REG_SZMapi32.dll
    MAPIXREG_SZ1
    MAPIXVERREG_SZ1.0.0.1
    OLEMessagingREG_SZ1
  5. Pokud některé z těchto hodnot registru chybí, přidejte hodnoty takto:
    1. Klepněte na podklíč Windows Messaging Subsystem , v nabídce Úpravy přejděte na příkaz Nový a potom klepněte na tlačítko Řetězcová hodnota.
    2. Zadejte název chybějící hodnoty a stiskněte klávesu ENTER.
    3. Klepněte na novou hodnotu a poté v nabídce Úpravy klepněte na příkaz změnit .
    4. V dialogovém okně Upravit řetězec zadejte správnou hodnotu pro chybějící hodnota řetězce v poli Údaj hodnoty .
    5. Opakujte kroky 6a až 6d pro každou chybějící hodnotu uvedenou v tabulce v kroku 4.
  6. V nabídce soubor klepněte na příkaz Konec.
Obvykle aplikace Excel 2007, PowerPoint 2007 a Word 2007 automaticky zobrazí správné e-mailové možnosti při požadované klíče registru jsou k dispozici. Pokud tyto programy nejsou zobrazeny možnosti e-mailu po použití metod popsaných v tomto poli, přidejte k těmto programům možnosti e-mailu. Chcete-li to provést, postupujte takto:
  1. V nabídce soubor klepněte na tlačítko Možnosti aplikace Název aplikace .
  2. Klepněte na tlačítko Vlastní nastavenía potom klepněte na tlačítko všechny příkazyv seznamu Příkazy .
  3. Klepněte na požadovaný příkaz a potom klepněte na tlačítko Přidat na panel nástrojů Rychlý přístup přidat příkaz. Například klepněte na možnost Odeslat k recenzia klepněte na tlačítko Přidat na panel nástrojů přidat příkaz Odeslat na revizi .
  4. Klepněte na tlačítko OK

Metoda 3: Odeslání souboru jako přílohy z e-mailového programu

Alternativním řešením je z e-mailového programu procházením umístění souboru připojit soubor sady Office na vaši zprávu.

Další informace

Verze sady Microsoft Office, které jsou starší než Microsoft Office 2003 pomocí MAPI informace registru a soubor Win.ini. Office 2003 a novější verze systému Office použijte pro ukládání informací rozhraní MAPI pouze registr.

Další informace naleznete na následujícím webu společnosti Microsoft:
Vlastnosti

ID článku: 918792 - Poslední kontrola: 16. 1. 2017 - Revize: 1

Váš názor