Pracovní postup není obnovit automaticky při aktivaci zpoždění aktivity v Windows SharePoint Services 3.0

Příznaky

Pracovní postup, který se uvolní při aktivaci zpoždění aktivity automaticky nepokračuje i po naplánovaném čase zanikl v Microsoft Windows SharePoint Services 3.0. Stav pracovního postupu, který je zobrazen na stránce Stav pracovního postupu služby SharePoint zůstane "Probíhá."

Příčina

K tomuto problému může dojít z následujících příčin:

Příčina 1

V počítači není nainstalována oprava hotfix, která je popsána v článku znalostní báze Microsoft Knowledge Base 932394.

Příčina 2

Pracovní postup někdy uvolní před událostí časovače je plánováno pokračování pracovního postupu. Pokud není naplánováno události timer, nikdy obnoví pracovního postupu.

Příčina 3

Problém se vyskytuje se služba SharePoint Timer service. Problém můžete ověřit otestováním další funkce služby časovače. Například test Chcete-li vytvořit položku seznamu příchozích e-mailů.

Příčina 4

Časovač služby SharePoint není nakonfigurován na spuštění v správný čas. Služba SharePoint Timer service zpracován zpoždění aktivity v pracovních postupech a pracovní postupy pokračovat podle plánu úlohy časovače pracovního postupu. Úloha časovače je ve výchozím nastavení nakonfigurována na každých 5 minut. Například pracovní postupy, které jsou nakonfigurovány pro pokračování za pět minut může pokračovat po 9 minut a 59 sekund.

Příčina 5

Pracovní postup sestavení v globální mezipaměti sestavení (GAC), je přepsán. K tomuto problému dochází při aktualizaci sestavení pracovního postupu a přepsat existující sestavení pracovního postupu. V takovém případě proces časovač používá starou verzi definice pracovního postupu. Pracovního postupu nepokračuje, protože dojde k přepsání starší verze sestavení pracovního postupu a již neexistuje.


Pracovního postupu v modulu GAC je obvykle přepsány za následujících okolností:
  • Zkopírujte sestavení pomocí nástroje GACUtil.
  • Ručně zkopírujte sestavení pomocí Průzkumníka Windows.
  • Používáte Visual Studio Tools pro Microsoft Office System (VSTO) funkce nasazení pracovního postupu, který je součástí Microsoft Visual Studio 2008.

Příčina 6

Stav pracovního postupu, který se zobrazí ve službě SharePoint Services zůstane "Probíhá", přestože pracovního postupu nepokračuje.

Příčina 7

  • Pracovní postupy obsahují smyčky, které nikdy zastavit. Pracovní postupy mohou například obsahovat při smyčky, které nezvyšuje jejich čítačů.
  • Replicator činnosti v pracovním postupu nemají nastavit vlastnost InitialChildData .

Řešení

Řešení u příčiny 1

Chcete-li tento problém vyřešit, postupujte takto:
  1. Nainstalujte opravu hotfix popsanou v následujícím článku znalostní báze Microsoft Knowledge Base:
    932394 časovač nepokračuje operace po pracovního postupu nepokračuje v Microsoft Windows Workflow Foundation


    Nebo můžete nainstalovat Microsoft rozhraní.NET Framework 3 Service Pack 1 (SP1) nebo rozhraní.NET Framework 3.5. Další informace o aktualizaci SP1 rozhraní.NET Framework 3 naleznete na následujícím webu společnosti Microsoft:Další informace o rozhraní.NET Framework 3.5 naleznete na následujícím webu společnosti Microsoft:
  2. Obnovte Internetová informační služba (IIS).
  3. Restartujte službu SharePoint Timer service.

Řešení u příčiny 2

Instalace aktualizace Windows SharePoint Services 3.0, která je popsána v následujícím článku znalostní báze Microsoft Knowledge Base:
953749 problémy, které jsou opraveny v systému Windows SharePoint Services 3.0 infrastruktury aktualizaci Windows SharePoint Services 3.0


Tento problém řeší aktualizaci Windows SharePoint Services 3.0 infrastruktury plánováním časovač událostí.

Řešení pro příčinu 3

K řešení problémů, které se vztahují ke službě časovače můžete použít následující metody:
  • Restartujte službu SharePoint Timer service.
  • Ověřte, zda je spuštěna služba SharePoint Timer service (Owstimer.exe) pomocí programu Sledování (Taskmon.exe) úlohy.
  • Ověřte, zda soubory protokolu Unified Logging Service (ULS) obsahují položky Chyba služby časovače a odpovídajícím způsobem řešit tento problém.
  • Ujistěte se, že antivirový program není příčinou problémů služby časovače.

    Další informace o antivirových skenování ve službě Windows SharePoint Services 3.0 a Office SharePoint Server 2007 klepněte na následující číslo článku databáze Microsoft Knowledge Base:

    952167 složky mohou mít mají být vyloučeny z virů pomocí antivirový program úrovni souboru v systému Windows SharePoint Services 3.0 nebo SharePoint Server 2007

Řešení pro příčinu 4

Chcete-li tento problém vyřešit, spusťte následující příkaz nastavit správný interval pro úlohy časovače pracovního postupu a potom restartujte službu SharePoint Timer service:
Stsadm – o setproperty-pn úlohy workflow – pv interval pro spuštění úlohy časovače pracovního postupu

Řešení pro příčinu 5

Restartujte službu SharePoint Timer service.

Poznámka: Toto řešení se týká pouze nově vytvořeného pracovního postupu instance. Nelze upravit existující instance pracovního postupu, které již jsou ovlivněny. Číslo verze lze použít pro každé sestavení, která je vytvořena ke sledování instance pracovního postupu pro nové a staré.

Řešení pro příčinu 6

Zkontrolujte soubory protokolu Unified Logging Service (ULS) pro chybové zprávy a odpovídajícím způsobem vyřešení problému. Tomuto problému obvykle dochází, pokud nesprávně zpracovává výjimku a dojde k chybě pracovního postupu.

Řešení pro příčinu 7

Zkontrolujte problémy konstrukce smyčky v definici pracovního postupu. Ujistěte se, že vlastnost InitialChildData na aktivity replikátoru vázán na datový objekt.
Vlastnosti

ID článku: 953630 - Poslední kontrola: 14. 1. 2017 - Revize: 1

Váš názor