Bázi asynchronních operací a WorkflowLogBase tabulky růstu velmi velké a při použití mnoho pracovních postupů v aplikaci Microsoft Dynamics CRM 4.0 dojít k problémům s výkonem

Příznaky

Použití mnoho pracovních postupů v aplikaci Microsoft Dynamics CRM 4.0. Bázi asynchronních operací a WorkflowLogBase tabulky růstu velmi velké a dojít k problémům s výkonem.

Příčina

K tomuto problému dochází, protože při vyvolání pravidla pracovního postupu, instance pracovního postupu a pracovního postupu záznamu jsou vytvářeny v bázi asynchronních operací a WorkflowLogBase tabulky v databázi MSCRM. Však po dokončení instance pracovního postupu workflow záznam zůstane v databázi. Bázi asynchronních operací a WorkflowLogBase tabulky proto nadále růst. Následně dochází ke snížení výkonu.

Poznámka: Vlastnost AsyncOperationType těchto záznamů je nastavena na 10.

Řešení

Tento problém je vyřešen v nejnovější kumulativní kumulativní aktualizace pro aplikaci Microsoft Dynamics CRM 4.0.
Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
949256 Microsoft Dynamics CRM 4.0 aktualizace a opravy hotfix



Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:
322756 postup zálohování a obnovení registru v systému Windows


Po instalaci opravy hotfix, chcete-li povolit tuto opravu hotfix, přejděte "Opravit za mě" oddílu. Pokud dáváte přednost aktivaci opravy hotfix, přejděte "opravit sám" oddíl.

Automatická oprava



Chcete-li povolit opravu hotfix automaticky, klepněte oprava tlačítko nebo odkaz. Potom klepněte na příkaz Spustit v dialogovém okně Stažení souboru a postupujte podle kroků v průvodci opravou .




Poznámky
  • Tento průvodce může být dostupný pouze v angličtině. Nicméně, automatická oprava však také funguje pro ostatní jazykové verze systému Windows.
  • Pokud nejste na počítači, který má daný problém, uložte Fix it řešení opravy na jednotku USB flash nebo disk CD a potom jej spusťte v počítači, který má potíže.

Potom pokračujte k části "Byl problém opraven?".



Opravím si sám

Chcete-li povolit tuto opravu hotfix, postupujte takto:

  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedita klepněte na tlačítko
    OK.
  2. V editoru registru vyhledejte následující podklíč:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Ověřte, zda existuje položka registru DWORD s názvem AsyncRemoveCompletedWorkflows. Hodnotu dat položky registru AsyncRemoveCompletedWorkflows musí být 1.
  4. Pokud položka registru AsyncRemoveCompletedWorkflows neexistuje, přidejte položku. Chcete-li to provést, postupujte takto:
    1. Klepněte pravým tlačítkem myši MSCRM, přejděte na
      Nový, klepněte na příkaz Hodnota DWORDa pak zadejte
      AsyncRemoveCompletedWorkflows v
      Název pole.
    2. Poklepejte na položku
      AsyncRemoveCompletedWorkflowsa zadejte
      v poli Údaj hodnoty zadejte 1 .
    3. Klepněte na tlačítko Start, klepněte na tlačítko
      Spustit, zadejte příkaz iisreseta pak klepněte na tlačítko
      OK.

      Poznámka: Pokud hodnota v poli Údaj hodnoty pro hodnotu AsyncRemoveCompletedWorkflows DWORD vrátí hodnotu 0, aplikace Microsoft Dynamics CRM nadále zachovat záznamů pracovních postupů v databázi i v případě, že úkoly jsou dokončeny.
Poznámka: Tato oprava hotfix je pouze aktivní. Proto při instalaci a aktivaci opravy hotfix pouze nové záznamy pracovních postupů jsou automaticky odstraněny. Pokud tabulky bázi asynchronních operací a WorkflowLogBase jsou již velké z důvodu těchto záznamů pracovního postupu, je nutné provést vyčištění tyto tabulky pomocí skriptu vyčištění Microsoft SQL Server, který je obsažen v následujícím článku znalostní báze Microsoft Knowledge Base:
968520 výkon je pomalý, pokud tabulka bázi asynchronních operací se stane příliš velký v aplikaci Microsoft Dynamics CRM 4.0

Byl problém vyřešen?

  • Zkontrolujte, zda byl problém vyřešen. Pokud je problém vyřešen, jste hotovi s touto částí. Pokud potíže přetrvávají, můžete kontaktovat podporu.
  • Uvítáme vaše názory. Sdělit svůj názor nebo nahlásit potíže s tímto řešením komentář "Opravit za mě" blogu nebo nám odešlete e -mailovou zprávu.

Další informace

Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
Další informace o aplikaci Microsoft Business Solutions CRM software aktualizace a opravy hotfix balíček terminologie klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
887283 aktualizace a opravy hotfix aplikace Microsoft Business Solutions CRM software balíček standardy používání názvů

Vlastnosti

ID článku: 968755 - Poslední kontrola: 13. 1. 2017 - Revize: 2

Váš názor