Při aplikaci pokusí zapsat data sdílený soubor, pokud jiná aplikace má přístup jen pro čtení na stejný soubor v počítači se systémem Windows Server 2003 zobrazí chybová zpráva: "Neúspěšný odložený zápis"

Příznaky

Jde o takovouto situaci:
  • Máte sdílený soubor v počítači se systémem Windows Server 2003.
  • Dvě aplikace současně přístup sdílený soubor. Jedna aplikace má přístup pro zápis do souboru a aplikace má přístup jen pro čtení k souboru.
Po obě aplikace spustit určitou dobu, například několik hodin, aplikace, která má přístup pro zápis nelze zapsat data do sdíleného souboru a tato aplikace zobrazí chybová zpráva "Neúspěšný odložený zápis". Tento problém způsobuje ztrátu dat nebo poškození dat ve sdíleném souboru.

Příčina

K tomuto problému dochází z důvodu problému časování v ovladači přesměrovány Drive ukládání do vyrovnávací paměti podsystém (Rdbss.sys). Když nastane problém časování, vyprázdněn, pomocí nesprávný soubor objektu data v mezipaměti sdíleného souboru. Tento soubor objekt nemá přístup jen pro čtení.

Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí v počítači spuštěn systém Windows Server 2003 Service Pack 1 (SP1) nebo Windows Server 2003 Service Pack 2 (SP2).

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix


Tato oprava hotfix nenahrazuje žádné dříve vydané opravy hotfix.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Pro všechny podporované verze systému Windows Server 2003 SP1 x86
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.3377177,66415-Jul-200915:10x86
Pro všechny podporované verze systému Windows Server 2003 SP2 x86
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.4552177,66415-Jul-200914:58x86
Pro všechny podporované verze x64 systému Windows Server 2003 a Windows XP
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.3377309,24816-Jul-200914:12x64
Pro všechny podporované verze x64 Windows Server 2003 SP2 a Windows XP s aktualizací SP2
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.4552309,76016-Jul-200914:18x64
Pro všechny podporované verze s procesorem Itanium systému Windows Server 2003 SP1
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.3377487,93616-Jul-200914:12IA-64
Pro všechny podporované verze s procesorem Itanium systému Windows Server 2003 SP2
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Rdbss.sys5.2.3790.4552487,93616-Jul-200914:16IA-64

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft


Vlastnosti

ID článku: 971295 - Poslední kontrola: 13. 1. 2017 - Revize: 1

Váš názor