Existuje zpoždění při vypnutí, restartování nebo odhlášení od počítače se systémem Windows 7 nebo Windows Server 2008 R2

Příznaky

Jde o takovouto situaci:
  • Máte počítač se systémem Windows 7 nebo Windows Server 2008 R2.
  • Pokoušíte se vypnout, restartovat nebo odhlášení od počítače.
V tomto scénáři zastaví proces odhlášení po dobu asi 6 sekund. Dále se zobrazí následující zpráva:
1 program stále vyžaduje zavřete:
(Čekání) Okno úkolu hostitele

Příčina

K tomuto problému dochází, protože proces TaskHost.exe zastaví zpracování zpráv během vypnutí systému během restartování systému a při odhlášení ze systému.

Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Neexistují žádné požadavky.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souborech

Globální verze této opravy hotfix má atributy souborů (nebo novější) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
X86 edice systému Windows 7
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Taskhost.exe6.1.7600.2053749,15230-Sep-200906:59x86
Windows 7 a Windows Server 2008 R2, edice s procesorem x64
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Taskhost.exe6.1.7600.2053769,12030-Sep-200907:26x64
Windows Server 2008 R2, edice s procesorem Itanium
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Taskhost.exe6.1.7600.20537130,56030-Sep-200905:54IA-64

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
Vlastnosti

ID článku: 975777 - Poslední kontrola: 13. 1. 2017 - Revize: 1

Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Starter, Windows 7 Ultimate, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Standard, Windows Web Server 2008 R2

Váš názor