Přidání, odstranění a přepnutí zobrazení (stránek) ve formuláři

Platí pro
InfoPath 2010

Důležité

Podpora pro Microsoft InfoPath 2013 skončila 14. července 2026. Doporučujeme, abyste stávající formuláře a pracovní postupy InfoPathu migrovali do podporovaných řešení Microsoft 365. Další informace o vyřazení InfoPathu z provozu

Navržením různých zobrazení formuláře můžete uživatelům nabídnout různé způsoby prohlížení dat v závislosti na typu formuláře, který chcete vytvořit, nebo na typu uživatele, kterému formulář prezentujete. S více zobrazeními můžete například:

  • Dlouhý a složitý formulář, třeba dlouhý průzkum, můžete zjednodušit jeho rozdělením na několik stránek, po kterých můžou uživatelé procházet klikáním na tlačítka Další a Zpět .
  • Zobrazit různé verze formuláře různým uživatelům podle jejich role ve vaší organizaci, například zobrazení pojistníka, agenta a likvidátora při zpracování pojistných událostí.
  • Vytvořte zobrazení formuláře, které bude vhodné pro tisk.

Všechna zobrazení v jednom formuláři aplikace InfoPath sdílejí stejná data. Pokud tedy formulář obsahuje dvě zobrazení a jedno z nich textové pole e-mailové adresy, můžete toto textové pole zkopírovat do druhého zobrazení. Když uživatel zadá svou e-mailovou adresu v jednom zobrazení, zobrazí se automaticky i v druhém zobrazení.

V tomto článku

Úvod k zobrazením

Uživatelské prostředí

Ve výchozím nastavení mohou uživatelé formuláře přepínat zobrazení výběrem požadovaného zobrazení ve skupině Zobrazení/stránek zobrazení na pásu karet. Každé zobrazení bude uvedené podle názvu a aktivní zobrazení bude zvýrazněné. Zobrazí se všechna zobrazení s výjimkou těch, u kterých bylo v dialogovém okně Vlastnosti zobrazení zrušeno zaškrtnutí políčka Zobrazit v nabídce Zobrazit při vyplňování tohoto formuláře.

Pokud není zaškrtnuté políčko Zobrazit v nabídce Zobrazit při vyplňování tohoto formuláře , skupina Zobrazení stránek na kartě Domů se nezobrazí. To je užitečné v situacích, kdy nechcete, aby uživatelé měli přístup k jiným zobrazením než k tomu, které mají vyplnit. Například formulář, který slouží ke shromažďování názorů o uchazečích o zaměstnání, může mít tři odlišné uživatelské role – jednu pro náborové pracovníky, jednu pro tazatele a jednu pro náborové manažery. Pro každou roli uživatele můžete navrhnout mírně odlišné zobrazení formuláře.

Poznámka

Možnost skrýt zobrazení před uživateli není funkce zabezpečení. Uživatelé budou data pořád vidět, pokud vědí, jak pracovat se samotnými daty XML.

Chcete-li pomoci tazatelům v přepnutí do zobrazení Náborář nebo Náborový manažer, můžete při navrhování zobrazení Náborář a Náborový manažer otevřít dialogové okno Zobrazit vlastnosti a zrušit zaškrtnutí políčka Zobrazit v nabídce Zobrazit při vyplňování tohoto formuláře .

Poznámka

V možnostech formuláře je možné zakázat možnost přepínání zobrazení pro uživatele, kteří formulář vyplňují ve webovém prohlížeči. Klikněte na kartu Soubor , na Informace, na Možnosti formuláře a potom v části Webové prohlížeče zrušte zaškrtnutí políčka Zobrazení .

Pokud chcete přizpůsobit možnosti přepínání zobrazení, přidejte do formuláře tlačítka pro přepínání zobrazení, jak je vysvětleno dále v tomto článku.

Aspekty návrhu

Při návrhu nového zobrazení budete obvykle muset provést následující úkoly:

  1. Naplánujte zobrazení.

Naplánujte si jednotlivá zobrazení a způsob, jakým budou spolupracovat, a věnujte pozornost aspektům, jako jsou:

  • Které ze zobrazení se má zobrazit při prvním otevření formuláře?
  • Musí uživatelé používat více zobrazení? Jak se mezi nimi budou pohybovat?
  • Musí být některá zobrazení jen pro čtení?
  • Je pravděpodobné, že uživatelé vytisknou z formuláře InfoPathu nějaká zobrazení?
  • Vyplňte zobrazení.

Když do formuláře přidáte nové zobrazení, bude začínat šablonou rozložení stránky. Odtud můžete pomocí karty Vložení na pásu karet přidávat tabulky rozložení, strukturovat formulář a přidávat ovládací prvky z karty Domů ve skupině Ovládací prvky .

Do nového zobrazení můžete také přidat ovládací prvky, které budou sdílet stejné pole s ovládacími prvky použitými v jiných zobrazeních, a to přetažením příslušného pole z podokna úloh Pole .

  1. Přizpůsobte si možnosti navigace.

Jak budou moct uživatelé procházet formulář? Bude uživatel vědět, co znamenají výchozí příkazy pro přepínání zobrazení? Jsou výchozí příkazy dostatečné, nebo chcete, aby uživatelé mohli přepínat mezi zobrazeními kliknutím na tlačítko, které se zobrazí přímo ve formuláři? Pokud uživatel klikne na tlačítko, použijete uživatelské rozhraní s kartami nebo tlačítka Zpět a Další? Chcete, aby uživatelé vytiskli všechna zobrazení najednou, nebo jenom aktivní zobrazení?

Skupina Zobrazení na kartě Návrh stránky

Na kartě Návrh stránky na pásu karet můžete ve skupině Zobrazení přidávat a odstraňovat zobrazení nebo přepínat mezi různými zobrazeními. Chcete-li přizpůsobit nastavení a chování vybraného pohledu, klikněte na tlačítko Vlastnosti a otevřete dialogové okno Vlastnosti pohledu .

Zobrazení tisku můžete také vytvořit a přidružit k existujícímu zobrazení tak, že nejdřív vytvoříte zobrazení pro tisk, které se zobrazí, když chcete vytisknout zobrazení formuláře, a pak ho pomocí dialogového okna Vlastnosti zobrazení přiřadíte k existujícímu zobrazení. V dialogovém okně Zobrazit vlastnosti zobrazení můžete také zadat vlastní možnosti tisku pro zobrazení tisku, například záhlaví, zápatí a okraje stránky.

Začátek stránky

Přidání zobrazení

Pomocí následujícího postupu přidáte do formuláře další zobrazení.

  1. Klikněte na kartu Návrh stránky a potom ve skupině Zobrazení klikněte na Nové zobrazení.
  2. Zadejte název zobrazení a klikněte na tlačítko OK.

Dialogové okno Přidat zobrazení s polem Název nového zobrazení

  1. Chcete-li otevřít dialogové okno Vlastnosti zobrazení , klikněte na kartu Návrh stránky a poté ve skupině Zobrazení klikněte na tlačítko Vlastnosti.
  2. V dialogovém okně Vlastnosti zobrazení změňte nebo zadejte požadovaná nastavení nebo možnosti zobrazení a klikněte na tlačítko OK.

Dialogové okno Zobrazit vlastnosti s nastavením zobrazení a rozložení

  1. V pracovním prostoru navrhněte zobrazení přidáním tabulek rozložení a ovládacích prvků.

Chcete-li návrh nového zobrazení založit na existujícím zobrazení, otevřete existující zobrazení, stisknutím kláves CTRL+A vyberte vše v zobrazení a stisknutím kombinace kláves CTRL+C zkopírujte výběr do schránky. Vyberte nové zobrazení ze seznamu Zobrazení ve skupině Zobrazení na kartě Návrh stránky , odstraňte předem vyplněný obsah v zobrazení a stisknutím kláves CTRL+V vložte výběr do nového zobrazení.

Začátek stránky

Odstranění zobrazení

Po odstranění zobrazení nelze obnovit ani obnovit. Pokud odstraníte výchozí zobrazení ve formuláři, který obsahuje pouze jedno zobrazení, InfoPath automaticky vytvoří nové výchozí zobrazení. Pokud odstraníte výchozí zobrazení ve formuláři, který obsahuje více zobrazení, přiřadí aplikace InfoPath výchozí stav zobrazení dalšímu zobrazení v seznamu zobrazení, který je zobrazen na kartě Návrh stránky ve skupině Zobrazení v seznamu Zobrazení .

  1. Na kartě Návrh stránky ve skupině Zobrazení v seznamu Zobrazení vyberte zobrazení, které chcete odstranit.
  2. Na kartě Návrh stránky klikněte ve skupině Zobrazení na tlačítko Odstranit.
  3. Po zobrazení výzvy k odstranění zobrazení klikněte na tlačítko Ano.

Začátek stránky

Změna výchozího zobrazení

Každý formulář má výchozí zobrazení. Uživatelé toto zobrazení uvidí, když otevřou formulář, který je na formuláři založený. Pokud pro formulář vytvoříte vlastní zobrazení, můžete zvolit, které z dostupných zobrazení bude pro uživatele výchozí.

  1. Na kartě Návrh stránky ve skupině Zobrazení v seznamu Zobrazení vyberte zobrazení, které má být výchozím zobrazením.
  2. Na kartě Návrh stránky klikněte ve skupině Zobrazení na tlačítko Vlastnosti.
  3. Zaškrtněte políčko Nastavit jako výchozí zobrazení a klikněte na tlačítko OK.

Pokud formulář obsahuje jenom jedno zobrazení, je automaticky označeno jako výchozí zobrazení.

Začátek stránky

Přejmenování zobrazení

  1. Na kartě Návrh stránky ve skupině Zobrazení v seznamu Zobrazení vyberte zobrazení, které chcete přejmenovat.
  2. Na kartě Návrh stránky klikněte ve skupině Zobrazení na tlačítko Vlastnosti.
  3. V dialogovém okně Vlastnosti zobrazení zadejte do textového pole Název zobrazení nový název karty a klikněte na tlačítko OK.

Poznámka

Pokud přejmenujete zobrazení, které je přidružené k vlastnímu kódu, nemusí kód fungovat očekávaným způsobem. Chcete-li tento problém vyřešit, je třeba najít všechny odkazy na starý název zobrazení v kódu a aktualizovat je novým názvem zobrazení.

Začátek stránky

Přidání tlačítka pro přepínání zobrazení

Zobrazení jsou často navržena tak, aby pracovala s pravidly. Pravidla umožňují automatizovat určité úkoly v reakci na události nebo akce iniciované osobou vyplňující formulář. Můžete například vložit tlačítko do formuláře a vytvořit pravidlo, které po kliknutí na tlačítko přepne zobrazení. Po vložení tlačítka do formuláře můžete toto pravidlo přidružit k tlačítku, aby se přepnulo zobrazení, když na ně uživatel klikne.

Přesněji řečeno, ve formuláři pojistného nároku můžete vytvořit tlačítko Zobrazit souhrn , které po kliknutí otevře přehledné údaje o pojistné události. V souhrnném zobrazení se pak uživatelé mohli kliknutím na tlačítko Zobrazit podrobnosti vrátit do podrobnějšího zobrazení. Podobně platí, že pokud máte velmi dlouhý formulář, můžete ho rozdělit do několika zobrazení a přidat tlačítka Další a Zpět nebo navigaci na kartách , aby uživatelé mohli formulářem procházet.

  1. Vložte tlačítko v každém zobrazení.

Chcete-li provést následující postup, musíte mít formulář se dvěma existujícími zobrazeními.

  1. Na kartě Návrh stránky ve skupině Zobrazení v seznamu Zobrazení vyberte zobrazení, do kterého chcete přidat tlačítko.
  2. Umístěte kurzor na místo ve formuláři, kam chcete vložit tlačítko.
  3. Na kartě Domů ve skupině Ovládací prvky vyberte Tlačítko.
  4. V části Nástroje ovládacích prvků klikněte na pásu karet na kartu Vlastnosti .
  5. Do pole Popisek zadejte název tlačítka a klikněte na tlačítko OK.
  • Vytvořte pravidlo, které přepne zobrazení.

    1. Vyberte tlačítko.
    2. V části Nástroje ovládacího prvku na kartě Vlastnosti klikněte ve skupině Pravidla na tlačítko Přidat pravidlo.
      Nabídka Přidat pravidlo se zaškrtnutým políčkem Při kliknutí na toto tlačítko
    3. Vybrat Při kliknutí na toto tlačítko pak vyberte Přepnout zobrazení ze seznamu Akce .
    4. V textovém poli Zobrazit vyberte zobrazení, které se má zobrazit po kliknutí na tlačítko, a klikněte na tlačítko OK.
      Button Rule Details dialog set to switch to View 1
  • Opakováním kroků 1 a 2 vytvořte další tlačítka a odpovídající pravidla pro každé zobrazení.

  • Po přidání tlačítek do zobrazení a vytvoření nezbytných pravidel se doporučuje otestovat formulář a ujistit se, že funguje podle očekávání.

  • Na kartě Domů klikněte ve skupině Formulář na položku Náhled.

  • Kliknutím na tato tlačítka se ujistěte, že můžete přepínat mezi zobrazeními podle potřeby.
    Zobrazení, ve kterém jste pracovali naposledy, se objeví v okně náhledu, pokud nebylo vytvořeno pravidlo, které přepne zobrazení na základě role uživatele při načtení formuláře.

Poznámka

V zobrazeních jen pro čtení nejsou tlačítka dostupná. K navigaci v zobrazeních jen pro čtení, jako je například zobrazení ve formuláři sharepointového seznamu, použijte tlačítko obrázku a zrušte zaškrtnutí políčka Skrýt tlačítko obrázku v zobrazeních jen pro čtení v dialogovém okně Vlastnosti ovládacího prvku na kartě Vlastnosti pásu karet.

Začátek stránky

Zobrazení pomocí pravidla načtení formuláře

Když uživatel otevře formulář, může být zobrazení specifické pro daného uživatele nebo může odpovídat jiným kritériím. Pokud například navrhujete formulář, který zahrnuje uživatelské role a obsahuje více zobrazení, může být užitečné zobrazit zobrazení založené na uživatelské roli přiřazené danému uživateli. Konkrétně můžete použít pravidlo k zobrazení v případě, že uživatel s určitou uživatelskou rolí otevře formulář založený na daném formuláři.

Uživatelské role se dají použít jenom ve formulářích navržených pro InfoPath Filler. Chcete-li přepnout zobrazení na základě členství ve skupině pro formuláře s povoleným webem, zvažte vytvoření pravidla Načtení formuláře , které k určení členství uživatelů používá metodu getUserMemberships webové služby Profil uživatele.

Tento postup předpokládá, že máte ve formuláři definovanou roli uživatele. Pokud formulář aspoň jednu roli uživatele neobsahuje, přidejte před zahájením tohoto postupu roli uživatele z karty Data .

  1. Na kartě Data klepněte ve skupině Pravidla na tlačítko Načíst formulář.
  2. Klikněte na tlačítko Nový, na položku Akce a poté do pole Podrobnosti pro zadejte název pravidla.
  3. Pokud chcete, aby formulář načetl zobrazení na základě role uživatele, klikněte na odkaz v části Podmínka . V prvním seznamu klikněte na aktuální roli uživatele a pak vyberte roli uživatele.

V závislosti na podmínkách, které chcete ovlivnit načítání formuláře, můžete vybrat i další možnosti.

Dialogové okno podmínky pro pravidlo načtení formuláře založené na poli LastName

  1. Klikněte na OK.
  2. Klikněte na tlačítko Přidat a pak vyberte Přepnout zobrazení.

Dialogové okno s podrobnostmi pravidla načtení formuláře nastavené pro přepnutí na zobrazení 1

  1. V seznamu Zobrazení klikněte na požadované zobrazení a potom klikněte na tlačítko OK.

Začátek stránky