Import z aplikace Microsoft Excel v aplikaci Outlook vyžaduje pojmenovanou oblast

Podpora Office 2003 byla ukončena.

Společnost Microsoft ukončila dne 8. dubna 2014 podporu Office 2003. Tato změna ovlivnila aktualizace softwaru a možnosti zabezpečení. Další informace o tom, co to pro vás znamená a jak zajistit ochranu

Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Příznaky
Když se pokusíte importovat informace kalendáře, kontaktů nebo úkolů z aplikace Microsoft Excel, může se zobrazit jedna z následujících chybových zpráv:
Došlo k chybě v překladači aplikace Microsoft Excel při zjišťování obsahu systému souborů.

Soubor <cesta_k_souboru\název_souboru> Microsoft Excel nemá žádné uvedené oblasti. K uvedení oblastí dat určených k importu použijte Microsoft Excel.
Nebo:
Došlo k chybě ODBC v aplikaci Microsoft Excel při otevírání souboru kvůli sestavení mapy pole. Ovladač OBDC aplikace Microsoft Excel: definováno příliš mnoho polí.
Příčina
Informace, které se pokoušíte importovat, nejsou v souboru aplikace Microsoft Excel obsaženy v pojmenované oblasti. Nebo je použitý název oblasti identický s jedním z názvů záhlaví sloupců v oblasti.
Řešení
Chcete-li importovat informace ze sešitu aplikace Microsoft Excel, zrušte vše v aplikaci Microsoft Outlook a otevřete daný soubor v aplikaci Excel. Postupujte následujícím způsobem:
  1. V nabídce Soubor klepněte na příkaz Uložit jako.
  2. V rozevíracím seznamu Uložit jako typ klepněte na položku CSV (oddělený středníkem) a klepněte na tlačítko Uložit.

    Zobrazí se zpráva podobná následující zprávě:
    Vybraný typ souboru nepodporuje sešity, které obsahují více listů.
  3. Klepnutím na tlačítko OK uložíte pouze aktivní list.

    Zobrazí se zpráva podobná následující zprávě:
    Soubor název_souboru.csv může obsahovat vlastnosti, které nejsou kompatibilní s CSV (oddělený středníkem).
  4. Klepněte na tlačítko Ano a poté zavřete tuto zprávu. Po zobrazení dotazu, zda chcete dokument uložit, klepněte na tlačítko Ne.

    Dokument jste již uložili. Není proto nutné jej ukládat znovu.
Nyní můžete importovat soubor CSV do aplikace Outlook. Postupujte následujícím způsobem:
  1. V nabídce Soubor klepněte na příkaz Import a export.
  2. V seznamu klepněte na položku Import z jiného programu nebo souboru a potom na tlačítko Další.
  3. V seznamu klepněte na položku Hodnoty oddělené čárkami (Windows) a pak na tlačítko Další.
  4. Zadejte název souboru, který chcete importovat, klepněte na požadovanou možnost a potom klepněte na tlačítko Další.
  5. Klepněte na cílovou složku a potom klepněte na tlačítko Další.

    Cílová složka je složka Kontakty nebo jiná složka používající formát kontaktů IPM.
  6. Ve skupině Budou provedeny následující akce, zkontrolujte, že je zaškrtnuto políčko Import. Poté klepněte na položku Mapovat vlastní pole.
  7. Přetáhněte hodnoty ze zdrojových polí na levé straně do odpovídajících cílových polí aplikace Outlook na pravé straně a pak klepněte na tlačítko OK.
  8. Klepněte na tlačítko Dokončit, a zkontrolujte, zda jsou kontakty importovány zamýšleným způsobem.
Alternativní metoda je definovat pojmenovanou oblast v listu aplikace Microsoft Excel. Přiřazený název oblasti by neměl být totožný s žádným z názvů záhlaví sloupců.Chcete-li definovat pojmenovanou oblast v aplikaci Microsoft Excel, postupujte takto:
  1. V listu aplikace Microsoft Excel vyberte řádky a sloupce obsahující informace, které chcete importovat.
  2. V nabídce Vložit přejděte na podnabídku Název a pak klepněte na příkaz Definovat.
  3. Do pole Názvy v sešitu zadejte název (název nesmí obsahovat mezery a neměl by být identický s žádným z názvů záhlaví sloupců) pro zvolenou oblast a pak klepněte na tlačítko Přidat.
  4. Klepněte na tlačítko OK a pak v nabídce Soubor klepněte na příkaz Uložit.
  5. Uložte soubor a zavřete sešit.
Další informace
Aplikace Outlook používá při importu informací metodu ODBC (Open Database Connectivity). Když importujete soubor z aplikace Microsoft Excel, standard ODBC vyžaduje, aby byly informace v souboru aplikace Microsoft Excel obsaženy v pojmenované oblasti . Při použití výše uvedeného postupu pojmenování oblasti se jako výchozí hodnota pro název oblasti může nabídnout název pole ve vybrané oblasti. Tento název by měl být změněn, aby nebyl identický s názvem záhlaví sloupce.

Alternativní metodou je uložení informací z aplikace Excel ve formátu CSV a poté import souboru CSV do aplikace Outlook. Tato metoda nevyžaduje použití pojmenovaných oblastí v aplikaci Excel.
Vlastnosti

ID článku: 196743 - Poslední kontrola: 12/05/2015 09:53:15 - Revize: 4.0

Microsoft Office Outlook 2003, Microsoft Outlook 2002 Standard Edition, Microsoft Outlook 2000 Standard Edition

  • kbnosurvey kbarchive kbprb KB196743
Váš názor