Teď jste offline a čekáte, až se znova připojí internet.

Použití nástroje Histogram v aplikaci Excel

Podpora Office 2003 byla ukončena.

Společnost Microsoft ukončila dne 8. dubna 2014 podporu Office 2003. Tato změna ovlivnila aktualizace softwaru a možnosti zabezpečení. Další informace o tom, co to pro vás znamená a jak zajistit ochranu

Verzi tohoto článku pro aplikaci Microsoft Excel 98 naleznete pod číslem 189519.

Souhrn
Pomocí nástroje Histogram doplňku Analytické nástroje aplikace Microsoft Office Excel můžete provést analýzu dat a zobrazit je pomocí histogramu (sloupcový graf, který zobrazuje distribuci dat). Chcete-li vytvořit histogram, je třeba uspořádat data v listu do dvou sloupců. Tyto sloupce musí obsahovat vstupní data a čísla tříd. Vstupní data jsou údaje, které chcete analyzovat pomocí nástroje Histogram. Čísla tříd jsou čísla reprezentující intervaly, které má nástroj Histogram při analýze použít k měření vstupních dat.

Použijete-li nástroj Histogram, aplikace Excel zjistí počet datových bodů v každé třídě dat. Datový bod je zahrnut do konkrétní třídy dat, pokud je jeho hodnota větší než dolní mez a rovna nebo menší než horní mez třídy dat. Pokud vynecháte určení rozsahu tříd dat, aplikace Excel vytvoří sadu rovnoměrně rozdělených tříd mezi minimální a maximální hodnotou dat.

Výstup analýzy histogramu je zobrazen na novém listu (nebo v novém sešitě) a zobrazuje tabulku histogramu a sloupcový graf, který zaznamenává data v tabulce histogramu.

Před použitím nástroje Histogram je třeba se ujistit, zda je nainstalován doplněk Analytické nástroje.

Ověření, zda je nainstalován doplněk Analytické nástroje

Chcete-li ověřit, zda je nainstalován doplněk Analytické nástroje, postupujte takto:


Excel 2010
  1. V nabídce Soubor klikněte na příkaz Možnosti.

    Excel 2013:



    Excel 2010:

  2. V navigačním podokně klikněte na položku Doplňky.


  3. V rozevíracím seznamu Spravovat klepněte na položku Doplňky aplikace Excel a potom klepněte na tlačítko Přejít.
  4. V dialogovém okně Doplňky zkontrolujte, zda je v seznamu Doplňky k dispozici zaškrtnuté políčko Analytické nástroje, a pak klikněte na tlačítko OK.



    Poznámka: Políčko Analytické nástroje se v dialogovém okně Doplňky zobrazí pouze tehdy, pokud byl tento doplněk nainstalován do počítače. Pokud nevidíte políčko Analytické nástroje v dialogovém okně Doplňky, spusťte instalační program aplikace Microsoft Excel a přidejte tuto součást do seznamu instalovaných položek.
Excel 2007
  1. Klepněte na Tlačítko Office a potom na tlačítko Možnosti aplikace Excel.

  2. V navigačním podokně klikněte na položku Doplňky.

  3. V rozevíracím seznamu Spravovat klikněte na položku Doplňky aplikace Excel a potom klikněte na tlačítko Přejít.
  4. V dialogovém okně Doplňky zkontrolujte, zda je v seznamu Doplňky k dispozici zaškrtnuté políčko Analytické nástroje, a pak klikněte na tlačítko OK.

Excel 2003 a předchozí verze aplikace Excel
  1. V nabídce Nástroje klikněte na příkaz Doplňky.
  2. V dialogovém okně Doplňky zkontrolujte, zda je v seznamu Doplňky k dispozici zaškrtnuté políčko Analytické nástroje, a pak klikněte na tlačítko OK.



    Poznámka: Políčko Analytické nástroje se v dialogovém okně Doplňky zobrazí pouze tehdy, pokud byl tento doplněk nainstalován do počítače. Pokud nevidíte políčko Analytické nástroje v dialogovém okně Doplňky, spusťte instalační program aplikace Microsoft Excel a přidejte tuto součást do seznamu instalovaných položek.

Vytvoření tabulky histogramu

Při vytváření tabulky histogramu postupujte takto:
  1. Zkopírujte následující data a vložte je do nového listu.
    8720
    2740
    4560
    6280
    3
    52
    20
    43
    74
    61
  2. Proveďte jednu z těchto akcí:
    • V aplikaci Excel 2013, Excel 2010 nebo Excel 2007 klikněte na kartě Data na položku Analýza dat ve skupině Analýza.


    • V aplikaci Excel 2003 a dřívějších verzích aplikace Excel klikněte v nabídce Nástroje na příkaz Analýza dat.
  3. V dialogovém okně Analýza dat klepněte na položku Histogram a potom na tlačítko OK.


  4. Do pole Vstupní oblast zadejte A1:A10.


  5. Do pole Hranice tříd zadejte B1:B4.
  6. Ve skupinovém rámečku Možnosti výstupu vyberte přepínač Nový sešit, zaškrtněte políčko Vytvořit graf a potom klepněte na tlačítko OK.
Aplikace Excel vytvoří nový sešit s tabulkou histogramu a vloženým grafem.

V závislosti na ukázkových datech z kroku 1 bude tabulka histogramu podobná následující tabulce:
   A1: Třídy     B1: Četnost   A2:  20     B2:        2   A3:  40     B3:        1   A4:  60     B4:        3   A5:  80     B5:        3   A6: Další    B6:        1				
Zobrazí se sloupcový graf, který znázorňuje data v tabulce histogramu. V tomto příkladu třída odpovídající hodnotám dat od 0 do 20 obsahuje dva datové body: 3 a 20. 

Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
214029 Použití nástrojů Analýza dat v seskupených listech (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
ATP Tool Pack Toolpack histo XL 2003 XL2007 XL2010 XL2013 Excel 2003 Excel2007 Excel2010 Excel2013
Poznámka: Toto je článek určený k rychlému zveřejnění, který vydala přímo služba podpory společnosti Microsoft. Uvedené informace jsou poskytovány jako odpověď na vzniklé problémy. Vzhledem k požadavku na rychlé zveřejnění je možné, že zpráva obsahuje typografické chyby, a může být kdykoli bez ohlášení revidována. Další pokyny naleznete v dokumentu Podmínky užití.
Vlastnosti

ID článku: 214269 - Poslední kontrola: 10/31/2013 15:07:00 - Revize: 3.0

Microsoft Excel 2013, Microsoft Excel 2010, Microsoft Office Excel 2007, Microsoft Office Excel 2003

  • kbfunctions kbfuncstat kbaddin kbhowtomaster kbsmbportal KB214269
Váš názor
le="display:none;" onerror="var m=document.createElement('meta');m.name='ms.dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?"> /html>