Vytvoření křížového dotazu v aplikaci Access 2002 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.

Projděte si také anglickou verzi článku:304349
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Začínajícího: Vyžaduje znalost uživatelského rozhraní v počítačích pro jednoho uživatele.

Tento článek se týká pouze databáze aplikace Microsoft Access (MDB).

Aplikace Microsoft Access 97 verzi tohoto článku naleznete 304446.
Microsoft Access 2000 verzi tohoto článku naleznete 304348.

Obsah úlohy

Souhrn
Pomocí křížových dotazů můžete vytvořit souhrnné zobrazení dat usnadňují analýzu. Tento článek ukazuje, jak vytvořit křížový dotaz v aplikaci Access s a bez použití průvodce.

Upozornění: Pokud postupujte podle kroků v tomto příkladu, změníte ukázkovou databázi Northwind.mdb. Můžete chtít zálohovat soubor Northwind.mdb a postupujte podle těchto kroků na kopii databáze.

back to the top

Vytváření křížový dotaz pomocí Průvodce křížovým dotazem

  1. Spusťte aplikaci Microsoft Access.
  2. V nabídce Nápověda klepněte na příkaz Ukázkové databáze a potom klepněte na položku Ukázková databáze Northwind. Otevírání úvodní obrazovky klepněte na tlačítko OK a pak zavřete formulář Hlavní panel, když se zobrazí.
  3. V nabídce Vložit klepněte na dotaz.
  4. V dialogovém okně Nový dotaz klepněte na tlačítko Průvodce křížovým dotazem a potom klepněte na tlačítko OK.
  5. Na první stránce Průvodce křížovým dotazem klepnutím na objednávky ze seznamu tabulek a potom klepněte na tlačítko Další.
  6. Poklepejte na ČísloZaměstnance ze seznamu Dostupná pole přidat do seznamu Vybraná pole a potom klepněte na tlačítko Další. Vytvoří tento dotaz s jeden záznam na zaměstnance.
  7. Klepněte v seznamu polí DatumObjednávky a potom klepněte na tlačítko Další.
  8. Klepněte na rok pro interval data a potom klepněte na tlačítko Další. Vytvoří tento dotaz s jedním sloupcem za rok data objednávky.
  9. Klepněte KódObjednávky ze seznamu polí klepněte na Čítač v seznamu funkce a potom klepněte na tlačítko Další.
  10. Na poslední stránce průvodce klepněte na tlačítko Dokončit. Poznámka: dotazu je vytvořen, který zobrazí počet objednávek podle zaměstnance podle roku.
back to the top

Vytváření křížový dotaz bez použití Průvodce

  1. Spusťte aplikaci Microsoft Access.
  2. V nabídce Nápověda klepněte na příkaz Ukázkové databáze a potom klepněte na položku Ukázková databáze Northwind. Otevírání úvodní obrazovky klepněte na tlačítko OK a pak zavřete formulář Hlavní panel, když se zobrazí.
  3. V nabídce Zobrazit přejděte na Objekty databáze a klepněte na tlačítko dotazy.
  4. V nabídce Vložit klepněte na dotaz.
  5. V dialogovém okně Nový dotaz klepněte na příkaz Návrhové zobrazení a klepněte na tlačítko OK.
  6. V dialogovém okně Zobrazit tabulku klepněte na tabulku objednávky, klepněte na tlačítko Přidat a potom klepněte na tlačítko Zavřít.
  7. V seznamu pole z tabulky objednávky v horní polovině návrhové mřížky dotazu poklepejte na následující pole přidat do návrhové mřížky dotazu: ZeměPříjemce, MěstoPříjemce, ShipVia a Dopravné.
  8. V nabídce dotaz klepněte na Křížový dotaz. Poznámka: řádek je do návrhové mřížky dotazu s názvem křížové.
  9. Klepněte v buňce Křížová řádku ve sloupci ZeměPříjemce, klepněte na zobrazenou šipku a potom klepněte na tlačítko Hlavička řádku.
  10. Klepněte v buňce Křížová řádku ve sloupci MěstoPříjemce klepněte na zobrazenou šipku a potom klepněte na tlačítko Hlavička řádku.
  11. Klepněte v buňce Křížová řádku ve sloupci ShipVia, klepněte na zobrazenou šipku a potom klepněte na tlačítko Hlavička sloupce.
  12. Klepněte v buňce Křížová řádku ve sloupci Dopravné, klepněte na zobrazenou šipku a pak klepněte na položku Hodnota. Poznámka: hodnoty lze nastavit pouze jedno pole.
  13. Klepněte v buňce Souhrn řádku ve sloupci Dopravné, klepněte na zobrazenou šipku a potom klepněte na tlačítko Sum.
  14. V nabídce dotaz klepněte na tlačítko Zobrazit výsledky křížového dotazu Spustit.
back to the top


Odkazy
Další informace o vytváření dotazů v nabídce Nápověda klepněte na příkaz Nápověda pro Microsoft Access, zadejte Vytvoření křížového dotazu v Pomocníkovi Office nebo průvodce a klepněte na tlačítko Hledat zobrazte vrácená témata.

Další informace o vytváření křížových dotazů s více polí hodnot klepněte na následující číslo článku databáze Microsoft Knowledge Base:
304458Jak vytvořit křížový dotaz s více polí hodnota
Další informace o vytváření výběrových dotazů naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
304325Vytvoření výběrového dotazu v aplikaci Access 2002 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
Další informace o vytváření parametrických dotazů získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
304352Postupy: Vytvoření parametr dotazu v aplikaci Microsoft Access 2002
Další informace o převodu výběrového dotazu na akční naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
304354Postupy: Převést výběrový dotaz na dotaz akce v aplikaci Access
Další informace o úpravách vlastností dotazů naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
304356Úprava vlastností dotazu v aplikaci Microsoft Access (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
back to the top
OfficeKBHowTo inf

Upozornění: Tento článek je přeložený automaticky

Vlastnosti

ID článku: 304349 - Poslední kontrola: 12/06/2015 04:18:28 - Revize: 4.0

Microsoft Access 2002 Standard Edition

  • kbnosurvey kbarchive kbmt kbquery kbhowtomaster KB304349 KbMtcs
Váš názor