Teď jste offline a čekáte, až se znova připojí internet.

Při spuštění instalačního programu systému Office se zobrazí chybová zpráva: Chyba 1919. Při konfiguraci zdroje dat ODBC došlo k chybě.

Podpora Office 2003 byla ukončena.

Společnost Microsoft ukončila dne 8. dubna 2014 podporu Office 2003. Tato změna ovlivnila aktualizace softwaru a možnosti zabezpečení. Další informace o tom, co to pro vás znamená a jak zajistit ochranu

Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastanou potíže. Další informace o zálohování, obnovení a úpravě registru najdete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986 Popis registru systému Microsoft Windows
Příznaky
Po spuštění instalačního programu některé z aplikací uvedených v části Platí pro tohoto článku se může zobrazit následující chybová zpráva:
Chyba 1919. Při konfiguraci zdroje dat ODBC došlo k chybě: Databáze MS Access. Chyba ODBC 6: Součást nebyla v registru nalezena. Ověřte, že soubor databáze MS Access existuje a že k němu máte přístup.
Pokud klepnete na tlačítko Ignorovat, může se zobrazit následující chybová zpráva:
Chyba 1919. Při konfiguraci zdroje dat ODBC došlo k chybě: Soubory aplikace Excel. Chyba ODBC 0: Ověřte, že soubor aplikace Excel existuje a že k němu máte přístup.
Může se také zobrazit některá z následujících chybových zpráv:
Chyba 1919. Při konfiguraci zdroje dat ODBC došlo k chybě: Databáze MS Access. Chyba ODBC 0: Ověřte, že soubor databáze MS Access existuje a že k němu máte přístup.
Chyba 1919. Při konfiguraci zdroje dat ODBC došlo k chybě: Databáze Visual FoxPro. Chyba ODBC 0: Ověřte, že soubor databáze Visual FoxPro existuje a že k němu máte přístup.
Chyba 1919. Při konfiguraci zdroje dat ODBC došlo k chybě: Tabulky Visual FoxPro. Chyba ODBC 0: Ověřte, že tabulky Visual FoxPro existují a že k nim máte přístup.
Chyba 1919. Při konfiguraci zdroje dat ODBC došlo k chybě: Soubory dBase. Chyba ODBC 6: Ověřte, že soubory dBase existují a že k nim máte přístup.
Příčina
K těmto potížím může dojít, jestliže v registru systému Windows nebyly nalezeny některé klíče registru.
Řešení
Tyto potíže vyřešíte nahrazením chybějících klíčů registru. Použijte jednu z následujících metod.

Metoda 1: Instalace součástí MDAC 2.8

Součásti MDAC 2.8 naleznete na následujícím webu společnosti Microsoft:
Další informace o součástech MDAC 2.8 včetně pokynů pro instalaci a odebrání naleznete na následujícím webu MSDN: Po instalaci součástí MDAC 2.8 je třeba restartovat počítač a pak se přihlásit s pověřením pro správu.

Poznámka: Součásti MDAC 2.8 jsou také nainstalovány při instalaci aktualizace Service Pack 2 (SP2) pro systém Microsoft Windows XP. Pokud používáte operační systém Windows XP, lze místo předchozího postupu nainstalovat aktualizaci Windows XP SP2. Chcete-li nainstalovat aktualizaci Windows XP SP2, přejdete na následující web společnosti Microsoft:.
Další informace o aktualizaci Windows XP SP2 naleznete na následujícím webu společnosti Microsoft:

Metoda 2: Obnovení klíčů registru pomocí souboru Mdac.inf

Obnovte klíče registru pomocí souboru Mdac.inf.

Poznámka: Tento program může zobrazit výzvu k vložení disku CD-ROM systému Windows, aby získal nové soubory.

Proveďte některou z následujících akcí s ohledem na použitý operační systém a dostupnost disku CD-ROM systému Windows.

Prodejní verze systémů Microsoft Windows 2000, Microsoft Windows XP nebo Microsoft Windows Server 2003

  1. Klepněte na tlačítko Start a na příkaz Spustit, do pole Otevřít zadejte příkaz cesta\inf a pak klepněte na tlačítko OK.

    Slovo cesta v tomto příkladu představuje cestu ke složce systému Windows. Zadejte například C:\Windows\Inf nebo C:\Winnt\Inf. Ve výchozím nastavení je systém Windows XP nainstalován do složky C:\Windows. Ve výchozím nastavení je do složky C:\Winnt nainstalován systém Windows 2000 nebo systém Windows XP, pokud jste provedli upgrade ze systému Windows 2000 na systém Windows XP.
  2. V nabídce Nástroje klepněte na příkaz Možnosti složky.
  3. Na kartě Zobrazení v poli Upřesnit nastavení klepněte na přepínač Zobrazovat skryté soubory a složky a pak klepněte na tlačítko OK.
  4. Klepněte pravým tlačítkem myši na soubor Mdac.inf a pak klepněte na příkaz Nainstalovat.
  5. Zobrazí-li se výzva k vložení disku CD-ROM systému Windows, vložte tento disk do jednotky CD-ROM nebo DVD-ROM.
  6. Klepněte na složku I386 na pevném disku (obvykle na složku C:\I386) a pak klepněte na tlačítko OK.

    Poznámka: Pokud je složka I386 podsložkou složky Windows, nebude ji možné v některých počítačích vybrat. V takovém případě zadejte celou cestu do pole Zdroj kopírovaných souborů (zadejte například C:\Windows\I386 nebo C:\Winnt\I386) a pak klepněte na tlačítko OK.
  7. Restartujte počítač.

Verze systému Windows 2000 nebo Windows XP výrobců OEM (Original Equipment Manufacturer)

Upozornění: Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Krok 1: Změna klíčů registru

  1. Vyhledejte složku I386 na pevném disku a pak si poznamenejte cestu k této složce.
  2. Klepněte na tlačítko Start a pak na příkaz Spustit.
  3. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  4. V Editoru registru vyhledejte následující klíč a klepněte na něj:
    HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup
  5. Klepněte pravým tlačítkem myši na položku Installation Sources a pak klepněte na příkaz Změnit.
  6. V poli Údaj hodnoty změňte hodnotu na cestu ke složce I386 na pevném disku a pak klepněte na tlačítko OK.
  7. Zopakujte kroky 5 a 6 pro každou z následujících položek:
    • SourcePath,
    • ServicePackSourcePath.
  8. Ukončete Editor registru.

Krok 2: Instalace souboru Mdac.inf

  1. Klepněte na tlačítko Start a na příkaz Spustit, do pole Otevřít zadejte příkaz C:\Winnt\Inf a pak klepněte na tlačítko OK.
  2. V nabídce Nástroje klepněte na příkaz Možnosti složky.
  3. Na kartě Zobrazení v poli Upřesnit nastavení klepněte na přepínač Zobrazovat skryté soubory a složky a pak klepněte na tlačítko OK.
  4. Klepněte pravým tlačítkem myši na soubor Mdac.inf a pak klepněte na příkaz Nainstalovat.
  5. Zobrazí-li se výzva k vložení disku CD-ROM systému Windows, vložte tento disk do jednotky CD-ROM nebo DVD-ROM.
  6. Klepněte na složku I386 na pevném disku (obvykle na složku C:\I386) a pak klepněte na tlačítko OK.

    Poznámky
    • Nemáte-li k dispozici disk CD-ROM pro aktuální instalaci systému Windows, klepněte na tlačítko Procházet a pak vyhledejte a vyberte složku I386.
    • Pokud je složka I386 podsložkou složky Windows, nebude ji možné v některých počítačích vybrat.

      V takovém případě zadejte celou cestu do pole Zdroj kopírovaných souborů (zadejte například C:\Windows\I386 nebo C:\Winnt\I386) a pak klepněte na tlačítko OK.
  7. Restartujte počítač.

Metoda 3: Import klíčů registru z jiného počítače v síti

Poznámka: Pokud importujete klíče registru z jiného počítače, ujistěte se, že zdrojový i cílový počítač používají stejný operační systém. Pokud tuto metodu použijete například v počítači se systémem Windows XP, vyhledejte počítač se systémem Windows XP, který lze použít k exportu klíčů registru.

Upozornění: Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Část 1: Export klíčů z registru ve zdrojovém počítači

  1. V počítači, v němž klíče nechybí (ve zdrojovém počítači), klepněte na tlačítko Start, klepněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedit a pak klepněte na tlačítko OK.
  2. Vyhledejte následující klíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\ODBC
  3. V nabídce Soubor klepněte na příkaz Exportovat.
  4. Do pole Uložit do zadejte umístění pro dočasné uložení souboru registru (souboru REG).

    Do pole Název souboru zadejte název souboru a pak klepněte na tlačítko Uložit.
  5. Vyhledejte následující klíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\Software\ODBC
  6. Zopakujte kroky 4 a 5 i pro export tohoto klíče.

Část 2: Import klíčů do registru cílového počítače

  1. Zkopírujte exportované soubory REG ze zdrojového počítače do dočasného umístění v počítači, v němž chybí klíče (do cílového počítače).
  2. Klepněte na tlačítko Start a na příkaz Spustit. Do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. V nabídce Registr klepněte na příkaz Importovat soubor registru.
  4. Vyhledejte jeden ze souborů REG, které jste zkopírovali v kroku 1, klepněte na něj a pak klepněte na tlačítko Otevřít.
  5. Zopakujte kroky 4 a 5 i pro druhý soubor REG.
Jak potíže obejít
V případě zobrazení uvedených chybových zpráv lze tento problém vyřešit několikanásobným klepnutím na tlačítko Opakovat. Toto řešení však není dlouhodobé. Později může dojít k potížím při spuštění příkazu Rozpoznat a opravit nebo při přeinstalování sady Microsoft Office 2003.
Další informace
Chcete-li získat další informace o řešení potíží s chybovými zprávami souvisejícími s chybou 1919, vyhledejte položku Chyba 1919 ve znalostní bázi Microsoft Knowledge Base. Navštivte následující web společnosti Microsoft:
OFF2003 error 1918 kbnoOfficeAlertID ACC2007 XL2007 IP2007 OneNote2007 OL2007 PPT2007 PRJ2007 PUB2007 SPD2007 VSO2007 WD2007 PSVR2007 MOSS2007 OFF2007
Vlastnosti

ID článku: 818954 - Poslední kontrola: 05/13/2010 05:58:52 - Revize: 5.0

  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office InfoPath 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Word 2007
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office Project Professional 2007
  • Microsoft Office Project Standard 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2007 with Business Contact Manager
  • Microsoft Office OneNote 2007
  • Microsoft Office Excel 2007
  • kbupdate kbregistry kbwindowsinstaller kbsetup kberrmsg KB818954
Váš názor
osoft.com/ms.js" '="">com/ms.js" '="">