Teď jste offline a čekáte, až se znova připojí internet.

Výkres aplikace Visio se neotevře v prohlížeči Visio Viewer 2007 a v aplikaci Internet Explorer se může zobrazit chybová zpráva

Podpora Office 2003 byla ukončena.

Společnost Microsoft ukončila dne 8. dubna 2014 podporu Office 2003. Tato změna ovlivnila aktualizace softwaru a možnosti zabezpečení. Další informace o tom, co to pro vás znamená a jak zajistit ochranu

Příznaky
Pokusíte-li se otevřít výkres aplikace Microsoft Office Visio 2007 nebo Microsoft Office Visio 2003 v počítači, v němž je spuštěn prohlížeč Microsoft Office Visio Viewer 2007, může se stát, že se výkres v prohlížeči Windows Internet Explorer neotevře. Může se také zobrazit některá z následujících chybových zpráv:
  • Chybová zpráva 1
    Stránku nelze zobrazit.
  • Chybová zpráva 2
    Aplikace Internet Explorer nemůže zobrazit tuto webovou stránku.
Příčina
K těmto potížím může dojít, je-li aplikace Microsoft Visio 2002 nainstalována v počítači, v němž je nainstalován prohlížeč Visio Viewer 2007.
Jak potíže obejít
Chcete-li, abychom tyto potíže pomocí metody 2 vyřešili za vás, přejděte k části Automatická oprava. Chcete-li tyto potíže vyřešit sami, přejděte k části Manuální oprava.

Automatická oprava



Chcete-li tyto potíže odstranit automaticky, klikněte na tlačítko nebo odkaz Opravit. V dialogovém okně Stažení souboru klikněte na položku Spustit a postupujte podle kroků v průvodci opravou.


Poznámky
  • Tento průvodce může být k dispozici pouze v angličtině. Tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.
  • Pokud právě nejste u počítače, který má tyto potíže, můžete opravu uložit na jednotku USB Flash nebo na disk CD a spustit ji v příslušném počítači později.

Poté přejděte k části Byly potíže vyřešeny?.



Manuální oprava

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1: Odinstalace prohlížeče Visio Viewer 2007 a následná instalace prohlížeče Visio Viewer 2003

  1. Klikněte na tlačítko Start, dále na příkaz Spustit, zadejte příkaz appwiz.cpl a potom klikněte na tlačítko OK.
  2. V seznamu Aktuálně nainstalované programy klikněte na sadu Microsoft Office Suite 2007 a pak klikněte na tlačítko Změnit.
  3. Klikněte na přepínač Přidat nebo odebrat součásti a klikněte na tlačítko Pokračovat.
  4. Na stránce Možnosti instalace rozbalte seznam vedle položky Microsoft Office Visio Viewer a poté klikněte na možnost Není k dispozici.
  5. Klikněte na tlačítko Pokračovat.
  6. Po odebrání prohlížeče Visio Viewer 2007 nainstalujte prohlížeč Visio Viewer 2003. Chcete-li získat prohlížeč Visio Viewer 2003, navštivte následující web společnosti Microsoft:
K zobrazení souborů aplikace Visio, které byly vytvořeny v aplikaci Visio 2007 nebo Visio 2003, použijte prohlížeč Visio Viewer 2003.

Metoda 2: Úprava registru

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zazálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows


V programu Poznámkový blok vytvořte soubor registru (REG) pro změnu položek registru pro prohlížeč Visio Viewer 2007. Postupujte takto:
  1. Zkopírujte následující text a vložte jej do nového souboru programu Poznámkový blok:
    Editor registru verze 5.00[HKEY_CLASSES_ROOT\.vsd] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"[HKEY_CLASSES_ROOT\.vst] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"[HKEY_CLASSES_ROOT\.vdx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"[HKEY_CLASSES_ROOT\.vss] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"[HKEY_CLASSES_ROOT\.vst] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"[HKEY_CLASSES_ROOT\.vsx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"[HKEY_CLASSES_ROOT\.vtx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
  2. V nabídce File (Soubor) klikněte na příkaz Save As (Uložit jako).
  3. Vyberte umístění k uložení souboru.
  4. Do pole Název souboru zadejte název Visioreg.reg.
  5. V rozevíracím seznamu Soubory typu vyberte možnost Textový dokument (*.txt) a pak klikněte na tlačítko Uložit.
  6. V nabídce Soubor klikněte na příkaz Nový.
  7. Zkopírujte následující text a vložte jej do nového souboru programu Poznámkový blok:
    @echo off reg delete "hkcr\.vdx"  /f reg delete "hkcr\.vsd"  /f reg delete "hkcr\.vss"  /f reg delete "hkcr\.vst"  /f reg delete "hkcr\.vsx"  /f reg delete "hkcr\.vtx"  /f regedit /s C:\Visioreg.reg
    Poznámka: Poslední řádek souboru musí obsahovat úplnou cestu a název souboru REG, který jste vytvořili v kroku 5.
  8. V nabídce File (Soubor) klikněte na příkaz Save As (Uložit jako).
  9. Vyberte umístění k uložení souboru.
  10. Do pole Název souboru zadejte název Visiofix.bat.
  11. V rozevíracím seznamu Soubory typu vyberte možnost Textový dokument (*.txt) a pak klikněte na tlačítko Uložit.
  12. V Průzkumníku Windows vyhledejte složku, do níž jste uložili soubor Visiofix.bat .
  13. Dvakrát klikněte na soubor Visiofix.bat.
Pokud po dokončení metody 2 dvakrát klikněte na soubor aplikace Visio, otevře se pouze v prohlížeči Visio Viewer. Chcete-li upravit soubor aplikace Visio, musíte spustit aplikaci Visio, kliknout na příkaz Otevřít v nabídce Soubor a pak vyhledat soubor, který chcete upravit.

Dojde-li k opravě aplikace Visio 2002 nebo instalaci aktualizace Service Pack, je třeba toto řešení použít znovu.

Byly potíže vyřešeny?

  • Ověřte, zda jsou potíže vyřešeny. Pokud ano, v této části již pro vás nejsou žádné potřebné informace. Pokud potíže přetrvávají, můžete kontaktovat podporu.
  • Uvítáme vaše názory. Chcete-li nám sdělit svůj názor nebo nahlásit potíže s tímto řešením, uveďte poznámky v blogu Fix it for me (Automatická oprava) nebo nám odešlete e-mailovou zprávu.
VSO2007 Visio2007 fixit fix it fixme
Vlastnosti

ID článku: 926948 - Poslední kontrola: 10/03/2011 09:47:00 - Revize: 6.0

Microsoft Office Visio Professional 2007, Microsoft Office Visio Standard 2007, Microsoft Office Visio Professional 2003, Microsoft Visio 2002 Professional Edition, Microsoft Visio 2002 Standard Edition

  • kbtshoot kbexpertisebeginner kbprb kbfixme kbmsifixme KB926948
Váš názor