Teď jste offline a čekáte, až se znova připojí internet.

Při spuštění nebo úpravě pracovních postupů může aplikace Microsoft Dynamics CRM 4.0 pracovat pomalu

Příznaky
Při spuštění nebo úpravě pracovních postupů může aplikace Microsoft Dynamics CRM 4.0 pracovat pomalu.
Příčina
K těmto potížím dochází z toho důvodu, že aplikace Microsoft Dynamics CRM 4.0 vytváří záznamy o všech nečinných instancích pracovních postupů v tabulce PluginAssemblyBase. Navíc, pokud upravíte některé pravidlo pracovního postupu, aplikace Microsoft Dynamics CRM 4.0 vytvoří jeden záznam v tabulce PluginAssemblyBase a další záznam v tabulce PluginTypeBase. Tyto záznamy však nejsou nikdy odstraněny. Pokud tedy často upravujete pravidla pracovních postupů, budou tabulky PluginAssemblyBase a PluginTypeBase velmi rozsáhlé.
Řešení
Tyto potíže jsou opraveny v nejnovější kumulativní aktualizaci pro aplikaci Microsoft Dynamics CRM 4.0. Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
949256 Aktualizace a opravy hotfix pro aplikaci Microsoft Dynamics CRM 4.0

Chcete-li zvýšit výkon této opravy hotfix, vytvořte v databázi Organization_MSCRM následující index.
Poznámky:
  • V následujícím skriptu představuje zástupný text název_organizace skutečný název databáze Microsoft CRM. Zástupný text nahraďte skutečným názvem databáze.
  • Následující index nevytvářejte, pokud již máte index se stejnými sloupci klíče. Existující indexy lze zobrazit spuštěním následujícího kódu:
    sp_helpindex AsyncOperationBase
USE název_organizace_MSCRM CREATE NONCLUSTERED INDEX CRM_AsyncOperation_WorkflowCleanupQuery ON [AsyncOperationBase](OperationType,StateCode,WorkflowActivationId)

Pomocí nástroje CRM 4 ScaleGroup Job Editor naplánujte spuštění Služby odstranění aplikace Microsoft Dynamics CRM 4 po skončení běžné pracovní doby, aby byl dopad na výkon uživatelů aplikace Microsoft Dynamics CRM snížen na minimum. Chcete-li získat nástroj CRM 4 Deployment Job Editor, navštivte následující web společnosti Microsoft:
  1. Vyberte organizaci.
  2. Změňte typ úlohy na hodnotu Deletion Service (Služba odstranění).
  3. Nastavte základní čas na dobu, kdy je aplikace Microsoft Dynamics CRM nejméně využívána, například po skončení pracovní doby.
  4. Doporučujeme nastavit položku Reschedule Job (Přeplánovat úlohu) na hodnotu 1440 minut nebo ji na této hodnotě ponechat. Pokud tak učiníte, bude se úloha spouštět každý den v čase zadaném v poli Base Time (Základní čas).
Poznámka: Při prvním spuštění Služby odstranění aplikace Microsoft Dynamics CRM 4.0 po instalací této opravy může být třeba zvýšit hodnotu položky OLEDBTimeout na delší čas, než jakému odpovídá výchozí hodnota. Doporučujeme vytvořit nový podklíč REG_DWORD, pokud tento podklíč dosud neexistuje. V adresáři HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM\ na serveru nebo serverech Microsoft Dynamics CRM 4.0 pojmenujte tento podklíč OLEDBTimeout. Nastavte jej na desítkovou hodnotu 86400. Po spuštění Služby odstranění aplikace Microsoft Dynamics CRM 4.0 po instalaci této opravy důrazně doporučujeme, abyste klíč registru OLEDBTimeout v adresáři HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM odstranili nebo jej nastavili v rozmezí mezi desítkovými hodnotami 60 a 300, aby se zabránilo přílišnému blokování SQL a špatnému výkonu aplikací v důsledku dlouho probíhajících dotazů.
Další informace
Pokud při prvním spuštění Služby odstranění neprovedete kroky pro zvýšení výkonu uvedené v části řešení, mohou být po instalaci této opravy do protokolu událostí aplikací na serverech Microsoft Dynamics CRM 4.0 zaneseny následující chyby.
.Typ události: Zdroj události chyby: MSCRMDeletionService Kategorie události: Žádné ID události: 16387 Datum: 2009/01/26 Čas: 11:41:54 Uživatel: Není k dispozici Počítač: CRMSERVER Popis: Chyba: Službě odstranění se nepodařilo vyčistit tabulku=CleanupInactiveWorkflowAssembliesProcedureDalší informace naleznete v Centru pro nápovědu a podporu na webu http://go.microsoft.com/fwlink/events.asp.
Odkazy
Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
948629 Chybová zpráva při přepnutí do offline režimu klienta Microsoft Dynamics CRM 4.0 pro aplikaci Outlook s offline přístupem: Přesunutí dat pro entitu Plug-in Assembly během akce Vložit se nezdařilo, počet řádků=[číslo]
Další informace o terminologii používané při popisu aktualizací softwaru společnosti Microsoft naleznete v následujících článcích znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
887283 Standardy používání názvů u balíčků oprav hotfix a aktualizací softwaru aplikace Microsoft Business Solutions CRM
Vlastnosti

ID článku: 948843 - Poslední kontrola: 10/10/2011 02:26:00 - Revize: 2.0

Microsoft CRM client for Microsoft Office Outlook, Microsoft Dynamics CRM 4.0

  • kbfix kbautohotfix kbexpertiseinter kbmbsmigrate kbqfe kbhotfixserver KB948843
Váš názor
ript"> Asimov.clickstreamTracker.init(); >id=1&t=">