Nelze přejít online po odeslání e-mailové zprávy jinému uživateli v klientovi Microsoft Dynamics CRM 4.0 aplikace Microsoft Office Outlook

Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.

957960
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Příznaky
Zvažte následující scénář Microsoft Dynamics CRM 4.0.
  • Konfigurovat Microsoft Dynamics CRM vytvořit samostatné e-mailové zprávy pro každého uživatele.
  • Přihlášení klienta Microsoft Dynamics CRM 4.0 pro aplikace Microsoft Office Outlook pomocí uživatel má oprávnění ke čtení na úrovni uživatele pro entitu aktivity. Potom můžete přejít do režimu offline.
  • Odeslání e-mailové zprávy jinému uživateli.
  • Pokuste se přejít do režimu online.
V tomto případě se zobrazí následující chybová zpráva:
Chyba synchronizace dat:
Název: Zadejte: Chyba
Test E-mail: E: nemáte dostatečná oprávnění pro přístup k objektu Microsoft Dynamics CRM nebo provedení požadované operace. Další informace obraťte se na správce Microsoft Dynamics CRM.

Test E-mail: E: požadovaný záznam nebyl nalezen nebo nemáte dostatečná oprávnění k jeho zobrazení. Test E-mail: E: požadovaný záznam nebyl nalezen nebo nemáte dostatečná oprávnění k jeho zobrazení.

V protokolu trasování platformy Microsoft CRM Server požadavku SOAP se nezdařilo je zaznamenána následující zpráva:
URL: http: / / URL
MethodName: spouštění
Response:
<? xml version = "1.0" encoding = "utf-8"? >
<soap: Obálka xmlns:xsd="http://www.w3.org/2001/XMLSchema"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" >
<soap:Body>
<soap:Fault>
<faultcode>soap: Server</faultcode>
<faultstring>Server nemohl zpracovat požadavek.---&gt; má byla vyvolána výjimka cíle vyvolání.---&gt; e-mail S ID = 2ce117e0-9785-dd11-81be-00155d41d218 neexistuje</faultstring> < podrobností / >
</soap:Fault>
</soap:Body>
</soap:Envelope>
System.web.Services.Protocols.SoapException: Server nemůže požadavek zpracovat. ---> System.Reflection.TargetInvocationException: Výjimka došlo cíle vyvolání. ---> Microsoft.Crm.BusinessEntities.CrmObjectNotFoundException: e-mail S ID = 2ce117e0-9785-dd11-81be-00155d41d218 neexistuje.
v Microsoft.Crm.BusinessEntities.BusinessProcessObject.retrieve (BusinessEntityMoniker zástupný název, EntityExpression entityExpression, ExecutionContext kontextu, deletionCodes Int32 [], Int32 languageCode)
Příčina
Při pokusu o přechod online e-mailová zpráva již byla vytvořena protože dotaz dokončení kontextu SYSTEM uživatele, kteří se zvýšenými oprávněními. Však nelze přejít online protože máte přístup k e-mailovou zprávu, která byla vytvořena.
Řešení
Tento problém je vyřešen v nejnovější kumulativní aktualizaci kumulativní Microsoft Dynamics CRM 4.0. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
949256Microsoft Dynamics CRM 4.0 aktualizace a opravy hotfix
Prohlášení
Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.
Další informace
Další informace o terminologii používané v aktualizacích softwaru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
Další informace o Microsoft Business Solutions CRM software opravy hotfix a aktualizace balíček terminologii klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
887283Standardy používání názvů u balíčků oprav hotfix a aktualizací softwaru aplikace Microsoft Business Solutions CRM (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Warning: This article has been translated automatically

Vlastnosti

ID článku: 957960 - Poslední kontrola: 01/15/2015 10:19:39 - Revize: 2.0

  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM for Microsoft Office Outlook
  • kbnosurvey kbarchive kbmt kberrmsg kbexpertiseinter kbfix kbautohotfix kbsurveynew kbmbsmigrate kbqfe kbhotfixserver KB957960 KbMtcs
Váš názor