Teď jste offline a čekáte, až se znova připojí internet.

Vzdálené zařízení NDIS (RNDIS) nemusí pracovat správně po neočekávaném provádění odebrání v počítači se systémem Windows XP a poté připojte zařízení RNDIS k počít...

Podpora Windows XP byla ukončena.

Společnost Microsoft ukončila dne 8. dubna 2014 podporu Windows XP. Tato změna ovlivnila aktualizace softwaru a možnosti zabezpečení. Další informace o tom, co to pro vás znamená a jak zajistit ochranu.

DŮLEŽITÉ: Tento článek je přeložen pomocí softwaru na strojový překlad Microsoft. Nepřesný či chybný překlad lze opravit prostřednictvím technologie Community Translation Framework (CTF). Microsoft nabízí strojově přeložené, komunitou dodatečně upravované články, a články přeložené lidmi s cílem zajistit přístup ke všem článkům v naší znalostní bázi ve více jazycích. Strojově přeložené a dodatečně upravované články mohou obsahovat chyby ve slovníku, syntaxi a gramatice. Společnost Microsoft není odpovědná za jakékoliv nepřesnosti, chyby nebo škody způsobené nesprávným překladem obsahu nebo jeho použitím našimi zákazníky. Více o CTF naleznete na http://support.microsoft.com/gp/machine-translation-corrections/cs.

Projděte si také anglickou verzi článku: 959765
Příznaky
Jde o takovouto situaci:
  • Zařízení ovladače vzdálené sítě specifikace rozhraní (RNDIS) je nainstalován v počítači systémem Windows XP, například rádiové zařízení USB.
  • Provádíte neočekávaném odebrání RNDIS zařízení z počítače.

    Poznámka: Neočekávaném odebrání je zařízení odebrat bez první operační systém upozornění.
  • Připojení zařízení RNDIS k počítači znovu.
V tomto scénáři RNDIS zařízení nepracuje správně. Data aplikace v počítači, například může hlásit chybu přenosu dat se nezdařilo. Chcete-li vyřešit tento problém, musíte restartovat počítač.
Příčina
K tomuto problému dochází, protože při neočekávaném odebrání nastane, dojde k zablokování mezi dvěma podprocesy Windows RNDIS ovladač miniportu (Rndismpx.sys). K tomuto problému dochází, pokud zařízení RNDIS je odeslán dotaz objektu identifikátor (OID) a kabel je odstraněna dříve, než obdrží odpověď.

Z důvodu k zablokování RNDIS zařízení odstraněna ze systému po neočekávaném odebrání. Když toto zařízení připojená k tomuto počítači znovu, toto zařízení není rozpoznána, protože stále existuje předchozí instance. Proto toto zařízení nepracuje správně.
Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, je sekce "Oprava Hotfix je dostupná ke stažení" v horní části tohoto článku znalostní báze Knowledge Base. Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft: Poznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí mít Windows XP Service Pack 2 nebo novější aktualizace service pack nainstalované v počítači.Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389 Jak získat nejnovější aktualizaci service pack pro systém Windows XP

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Systém Windows XP Service Pack 2, verze x 86
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Rndismp.sys5.1.2600.348330,59224. listopadu 200810:54x 86SP2
Rndismpx.sys5.1.2600.348330,59224. listopadu 200810:54x 86SP2
Usb8023.sys5.1.2600.348312,80024. listopadu 200810:54x 86SP2
Usb8023x.sys5.1.2600.348312,80024. listopadu 200810:54x 86SP2
Systém Windows XP s aktualizací Service Pack 3, verze x 86
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Rndismp.sys5.1.2600.571630,59225. listopadu 200811:42x 86SP3
Rndismpx.sys5.1.2600.571630,59225. listopadu 200811:42x 86SP3
Prohlášení
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Další informace
Další informace o RNDIS a systému Windows naleznete na následujícím webu:

Upozornění: Tento článek je přeložený automaticky

Vlastnosti

ID článku: 959765 - Poslední kontrola: 07/25/2015 09:09:00 - Revize: 4.0

Microsoft Windows XP Professional, Microsoft Windows XP Home Edition

  • kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbmt KB959765 KbMtcs
Váš názor