Pokud obrazce obsahují data, můžete spustit Průvodce exportem databáze a vytvořit tabulku databáze obsahující tato data.

Rozdíl mezi Průvodce exportem databáze a dialogem, ke které se dostanete pomocí příkazu Exportovat do databáze, spočívá v tom, že pomocí průvodce můžete exportovat všechny obrazce ve vrstvě. Pokud nepotřebujete exportovat podle vrstev, můžete zjistit, že použití příkazu Exportovat do databáze je efektivnější. 

Použití Průvodce exportem databáze

  1. Na kartě Zobrazení > doplňky > Visio Doplňky > Průvodce exportem databáze.

  2. Postupujte podle pokynů na stránkách průvodce.

    Tipy: 

    • Před názvy buněk dat obrazce, která se zobrazí v seznamu,předchází prop , například Prop.Cost.

    • Když spustíte Průvodce exportem databáze k exportu dat obrazce, uloží průvodce informace související s exportem na stránku výkresu. Pokud u obrazců změníte a chcete data znovu exportovat, klikněte pravým tlačítkem myši na stránku výkresu a pak zvolte Exportovat tabulku databáze.

Použití příkazu Exportovat do databáze

  1. Na kartě Zobrazení > doplňky > Visio Doplňky > Exportovat do databáze.

  2. Vyberte tabulku databáze, kterou chcete použít.

    • Pokud máte zdroj dat uložený někde jinde než ve výchozím umístění, klikněte na Procházet a vyhledejte soubor.

    • Pokud chcete vytvořit nový zdroj dat, klikněte na Vytvořit. Postupujte podle průvodce Vytvoření nového zdroje dat. Po kliknutí na Dokončitse zobrazí dialogové okno Nastavení ODBC. Odtud můžete buď vybrat existující databázi, nebo vytvořit novou. Tabulku v databázi vytvoříte později.

      Poznámky: 

      • Pokud používáte Excel jako zdroj dat, můžete vybrat existující sešit, ale nemůžete ho vytvořit v průvodci.

      • Pokud zvolíte Excel sešitu, zrušte zaškrtnutí políčka Jen pro čtení v dialogovém okně Vybrat sešit.

  3. Pokud vaše databáze podporuje vlastníky, klikněte v seznamu Vlastník na jméno vlastníka a vyfiltrujte seznam vlastníků tabulek. Tabulka databáze se vytvoří pomocí názvu, který jste použili k přihlášení k databázi.

  4. Pokud databáze umožňuje přístup k více databázím, klikněte v seznamu Kvalifikátor na databázi, kterou chcete použít.

    Tip: Pokud používáte Access nebo Excel, tady je uveden název a umístění databáze, do které budou data exportována.

  5. V seznamu Tabulka klikněte na tabulku databáze, kterou chcete použít. Pokud chcete vytvořit novou tabulku, zadejte pro ní název.

  6. Pokud chcete změnit způsob exportu dat z buněk ShapeSheet, proveďte jednu z těchto akcí:

    Přidání buňky ShapeSheet do seznamu exportu

    1. Klikněte na Přidat.

    2. Vyberte buňku ShapeSheet, kterou chcete exportovat.

    3. V poli Vyhodnotit jako vyberte datový typ hodnoty, která je uložená v poli databáze.

    4. Vyberte pole databáze, do kterého se data obrazce zkopírují.

    5. Zadejte datový typ databáze, délku pole a desetinnou přesnost databázového pole.

    Změna způsobu exportu dat v buňce ShapeSheet

    1. Vyberte název buňky a klikněte na Změnit.

    2. Změna způsobu exportu dat

    Odstranění buňky ShapeSheet ze seznamu exportu

    Vyberte název buňky a klikněte na Odstranit.

Použití Průvodce exportem databáze

  1. V nabídce Tools (Nástroje) přejděte na Add-Ons(Doplňky), přejděte na Visio Extra apotom klikněte na Průvodce exportem databáze.

  2. Postupujte podle pokynů na stránkách průvodce.

    Tipy: 

    • Před názvy buněk dat obrazce, která se zobrazí v seznamu,předchází prop , například Prop.Cost.

    • Když spustíte Průvodce exportem databáze k exportu dat obrazce, uloží průvodce informace související s exportem na stránku výkresu. Pokud u obrazců změníte a chcete data znovu exportovat, klikněte pravým tlačítkem myši na stránku výkresu a pak zvolte Exportovat tabulku databáze.

Použití příkazu Exportovat do databáze

  1. V nabídce Tools (Nástroje) přejděte na Add-Ons(Doplňky), pak přejděte na Visio Extra apotom klikněte na Exportovat do databáze.

  2. Vyberte tabulku databáze, kterou chcete použít.

    • Pokud máte zdroj dat uložený někde jinde než ve výchozím umístění, klikněte na Procházet a vyhledejte soubor.

    • Pokud chcete vytvořit nový zdroj dat, klikněte na Vytvořit. Postupujte podle průvodce Vytvoření nového zdroje dat. Po kliknutí na Dokončitse zobrazí dialogové okno Nastavení ODBC. Odtud můžete buď vybrat existující databázi, nebo vytvořit novou. Tabulku v databázi vytvoříte později.

      Poznámky: 

      • Pokud používáte Microsoft Office Excel jako zdroj dat, můžete vybrat existující sešit, ale nemůžete ho vytvořit v průvodci.

      • Pokud zvolíte Excel sešitu, zrušte zaškrtnutí políčka Jen pro čtení v dialogovém okně Vybrat sešit.

  3. Pokud vaše databáze podporuje vlastníky, klikněte v seznamu Vlastník na jméno vlastníka a vyfiltrujte seznam vlastníků tabulek. Tabulka databáze se vytvoří pomocí názvu, který jste použili k přihlášení k databázi.

  4. Pokud databáze umožňuje přístup k více databázím, klikněte v seznamu Kvalifikátor na databázi, kterou chcete použít.

    Tip: Pokud používáte accessovou Microsoft Office nebo Excel, tady je uveden název a umístění databáze, do které budou data exportována.

  5. V seznamu Tabulka klikněte na tabulku databáze, kterou chcete použít. Pokud chcete vytvořit novou tabulku, zadejte pro ní název.

  6. Pokud chcete změnit způsob exportu dat z buněk ShapeSheet, proveďte jednu z těchto akcí:

    Přidání buňky ShapeSheet do seznamu exportu

    1. Klikněte na Přidat.

    2. Vyberte buňku ShapeSheet, kterou chcete exportovat.

    3. V poli Vyhodnotit jako vyberte datový typ hodnoty, která je uložená v poli databáze.

    4. Vyberte pole databáze, do kterého se data obrazce zkopírují.

    5. Zadejte datový typ databáze, délku pole a desetinnou přesnost databázového pole.

    Změna způsobu exportu dat v buňce ShapeSheet

    1. Vyberte název buňky a klikněte na Změnit.

    2. Změna způsobu exportu dat

    Odstranění buňky ShapeSheet ze seznamu exportu

    Vyberte název buňky a klikněte na Odstranit.

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×