Buňky

Import a export textových souborů (.txt nebo .csv)

Import a export textových souborů (.txt nebo .csv)

Data z textového souboru v Excelu můžete importovat dvěma způsoby: můžete je otevřít v Excelu nebo je můžete importovat jako Oblast externích dat. Pokud chcete exportovat data z Excelu do textového souboru, použijte příkaz Uložit jako a z rozevírací nabídky změňte typ souboru.

Existují dva běžně používané formáty textových souborů:

  • Textové soubory s oddělovači (TXT), ve kterých znak TAB (kód znaku ASCII 009) obvykle odděluje jednotlivá pole textu.

  • Textové soubory s oddělovači (CSV), ve kterých znak čárky (,) obvykle odděluje jednotlivá pole textu.

Můžete změnit znak oddělovače, který se používá v textových souborech s oddělovači i .csv. To může být nutné, abyste měli jistotu, že operace importu nebo exportu funguje tak, jak chcete.

Poznámka: Můžete importovat nebo exportovat až 1 048 576 řádků a 16 384 sloupců.

Import textového souboru otevřením v Excelu

Textový soubor, který jste vytvořili v jiné aplikaci, můžete otevřít jako excelový sešit pomocí příkazu Otevřít. Otevřením textového souboru v Excelu se nezmění formát souboru – můžete to vidět v záhlaví Excelu, kde název souboru zachovává příponu názvu textového souboru (například .txt nebo .csv).

  1. Přejděte na Soubor > Otevřít a přejděte do umístění, které obsahuje textový soubor.

  2. V rozevíracím seznamu Typ souboru v dialogovém okně Otevřít vyberte Textové soubory.

  3. Vyhledejte textový soubor, který chcete otevřít, a poklikejte na něj.

    • Pokud je soubor textový soubor (.txt), Excel spustí Průvodce importem textu. Až budete s tímto postupem hotovi, dokončete operaci importu kliknutím na Dokončit. Další informace o oddělovači a upřesňujících možnostech najdete v tématu Průvodce importem textu.

    • Pokud je soubor .csv, Excel automaticky otevře textový soubor a zobrazí data v novém sešitu.

      Poznámka: Když Excel otevře soubor .csv, použije aktuální výchozí nastavení formátu dat k interpretaci importu jednotlivých sloupců dat. Pokud chcete větší flexibilitu při převodu sloupců na různé formáty dat, můžete použít Průvodce importem textu. Například formát datového sloupce v souboru .csv může být MDY, ale výchozí formát dat Excelu je YMD nebo chcete převést sloupec čísel, který obsahuje úvodní nuly na text, abyste mohli zachovat počáteční nuly. Pokud chcete, aby Excel spouštěl Průvodce importem textu, můžete před otevřením změnit příponu názvu souboru z .csv na .txt nebo můžete textový soubor importovat tak, že se k ní připojíte (další informace najdete v následující části).

Import textového souboru připojením k textovému souboru (Power Query)

Data z textového souboru můžete importovat do existujícího listu.

  1. Na kartě Data klikněte ve skupině & transformovat data na Z textu/CSV.

  2. V dialogovém okně Importovat data vyhledejte textový soubor, který chcete importovat, a poklikejte na něj a klikněte na Importovat.

  3. V dialogovém okně Náhled máte několik možností:

    • Pokud chcete data načíst přímo do nového listu, vyberte Načíst.

    • Pokud chcete data načíst do tabulky, kontingenční tabulky nebo kontingenčního grafu, existujícího nebo nového excelového listu nebo jednoduše vytvořit připojení, vyberte možnost Načíst do. Můžete taky přidat data do datového modelu.

    • Pokud chcete data načíst do Power Query, vyberte Transformovat data a upravte je před tím, než je převezete do Excelu.

Pokud Excel nevertuje určitý sloupec dat na formát, který chcete, můžete data po importu převést. Další informace najdete v článkách Převod čísel uložených jako text na čísla a Převedení kalendářních dat uložených jako text na kalendářní data.

Export dat do textového souboru uložením

Excelový list můžete převést na textový soubor pomocí příkazu Uložit jako.

  1. Přejděte na Soubor > Uložit jako.

  2. Klikněte na Procházet.

  3. V dialogovém okně Uložit jako zvolte v části Uložit jako typ formát textového souboru listu. například klikněte na Text (s oddělovači tabulátoru) nebo CSV (s oddělovači).

    Poznámka: Různé formáty podporují různé sady funkcí. Další informace o sadách funkcí podporovaných různými formáty textových souborů najdete v tématu Formáty souborů podporované v Excelu.

  4. Přejděte do umístění, kam chcete nový textový soubor uložit, a klikněte na Uložit.

  5. Zobrazí se dialogové okno s připomenutím, že do nového souboru se uloží jenom aktuální list. Pokud jste si jistí, že aktuální list je ten, který chcete uložit jako textový soubor, klikněte na OK. Další listy můžete uložit jako samostatné textové soubory opakováním tohoto postupu pro každý list.

    Pod pásem karet se také může zobrazit upozornění, že při uložení sešitu ve formátu CSV může dojít ke ztrátě některých funkcí.

Další informace o ukládání souborů v jiných formátech najdete v tématu Uložení sešitu v jiném formátu souboru.

Import textového souboru připojením k textovému souboru

Data z textového souboru můžete importovat do existujícího listu.

  1. Klikněte na buňku, kam chcete data z textového souboru umístit.

  2. Na kartě Data klikněte ve skupině Na get external data (Na kartě Data) na From Text (Z textu).

  3. V dialogovém okně Importovat data vyhledejte textový soubor, který chcete importovat, a poklikejte na něj a klikněte na Importovat.

    Postupujte podle pokynů v Průvodci importem textu. Další informace o Vzhled tlačítka průvodce získáte kliknutím na Nápověda na libovolné stránce Průvodce importem textu. Po dokončení kroků v průvodci dokončete operaci importu kliknutím na Dokončit.

  4. V dialogovém okně Importovat data proveďte toto:

    1. V části Kam chcete data umístit?proveďte jednu z těchto akcí:

      • Pokud chcete vrátit data do vybraného umístění, klikněte na Existující list.

      • Pokud chcete vrátit data do levého horního rohu nového listu, klikněte na Nový list.

    2. Volitelně můžete kliknout na Vlastnosti a nastavit možnosti aktualizace, formátování a rozložení importovaných dat.

    3. Klikněte na OK.

      Excel zamísí oblast externích dat do umístění, které zadáte.

Pokud Excel nepřevádí sloupec dat na formát, který chcete, můžete data po importu převést. Další informace najdete v článkách Převod čísel uložených jako text na čísla a Převedení kalendářních dat uložených jako text na kalendářní data.

Export dat do textového souboru uložením

Excelový list můžete převést na textový soubor pomocí příkazu Uložit jako.

  1. Přejděte na Soubor > Uložit jako.

  2. Zobrazí se dialogové okno Uložit jako.

  3. V poli Uložit jako typ zvolte formát textového souboru listu.

    • Klikněte třeba na Text (s oddělovači tabulátoru) nebo CSV (s oddělovači).

    • Poznámka: Různé formáty podporují různé sady funkcí. Další informace o sadách funkcí podporovaných různými formáty textových souborů najdete v tématu Formáty souborů podporované v Excelu.

  4. Přejděte do umístění, kam chcete nový textový soubor uložit, a klikněte na Uložit.

  5. Zobrazí se dialogové okno s připomenutím, že do nového souboru se uloží jenom aktuální list. Pokud jste si jistí, že aktuální list je ten, který chcete uložit jako textový soubor, klikněte na OK. Další listy můžete uložit jako samostatné textové soubory opakováním tohoto postupu pro každý list.

  6. Zobrazí se druhé dialogové okno s připomenutím, že list může obsahovat funkce, které formáty textových souborů nepodporují. Pokud máte zájem jenom o uložení dat listu do nového textového souboru, klikněte na Ano. Pokud si nejste jistí a chcete se dozvědět víc o tom, které funkce Excelu nejsou formáty textových souborů podporované, klikněte na Nápověda, kde najdete další informace.

Další informace o ukládání souborů v jiných formátech najdete v tématu Uložení sešitu v jiném formátu souboru.

Způsob změny oddělovače při importu se liší podle toho, jak importujete text.

  • Pokud použijete na & transformovat data > z textu/CSV,vyberte textový soubor a klikněte na Importovata v seznamu v části Oddělovač zvolte znak, který chcete použít. Efekt nové volby můžete hned vidět v náhledu dat, abyste měli jistotu, že před tím, než budete pokračovat, si můžete vybrat, co chcete.

  • Pokud k importu textového souboru použijete Průvodce importem textu, můžete v kroku 2 Průvodce importem textu změnit oddělovač, který se používá pro operaci importu. V tomto kroku můžete také změnit způsob zpracování po sobě jdoucích oddělovačů, například po sobě jdoucích uvozovek.

    Další informace o oddělovači a upřesňujících možnostech najdete v tématu Průvodce importem textu.

Pokud chcete použít středník jako výchozí oddělovač seznamu při uložení jako .csv, ale potřebujete tuto změnu omezit na Excel, zvažte změnu výchozího oddělovače desetinných míst na čárku – excel tak vynutí použití středníku pro oddělovač seznamu. Je zřejmé, že to také změní způsob zobrazení desetinných čísel, proto zvažte také změnu oddělovače tisíců, aby se omezily nejasnosti.

  1. Zrušte zaškrtnutí políčka Možnosti aplikace Excel> Upřesnit > možnosti úprav > Použít oddělovače systému.

  2. Nastavte oddělovač desetinných míst na , (čárka).

  3. Nastavte oddělovač tisíců na. (tečka).

Když sešit uložíte jako soubor CSV, výchozí oddělovač seznamu (oddělovač) je čárka. Tento znak můžete změnit na jiný znak oddělovače pomocí nastavení Oblasti systému Windows. 

Upozornění: Změna nastavení Windows způsobí globální změnu na vašem počítači, která ovlivní všechny aplikace. Pokud chcete změnit jenom oddělovač pro Excel, podívejte se na informace v tématu Změna výchozího oddělovače seznamu pro ukládání souborů jako textu (CSV) v Excelu.

  1. V Microsoft Windows 10 klikněte pravým tlačítkem myši na tlačítko Start a potom klikněte na Nastavení.

  2. Klikněte na & Jazyk apotom na Oblast v levém panelu.

  3. Na hlavním panelu klikněte v části Místní nastavenína Další datum, časa místní nastavení .

  4. V části Oblastklikněte na Změnit formáty data, času nebo čísla.

  5. V dialogovém okně Oblast na kartě Formát klikněte na Další nastavení.

  6. V dialogovém okně Přizpůsobit formát zadejte na kartě Čísla znak, který chcete použít jako nový oddělovač do pole Oddělovač seznamu.

  7. Dvakrát klikněte na tlačítko OK.

  1. V systému Microsoft Windows klikněte na tlačítko Start a pak na příkaz Ovládací panely.

  2. V části Hodiny, jazyk a země či oblast klikněte na Změnit datum, čas nebo formáty čísel.

  3. V dialogovém okně Oblast na kartě Formát klikněte na Další nastavení.

  4. V dialogovém okně Přizpůsobit formát zadejte na kartě Čísla znak, který chcete použít jako nový oddělovač do pole Oddělovač seznamu.

  5. Dvakrát klikněte na tlačítko OK.

Poznámka:  Po změně znaku oddělovače seznamu v počítači používají všechny aplikace nový znak jako oddělovač seznamu. Stejným postupem můžete změnit znak zpět na výchozí znak.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Import dat z externích zdrojů (Power Query)

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×