Excel pro Mac zahrnuje technologii Power Query (nazývanou také Get & Transform), která poskytuje větší možnosti při importu, aktualizaci a ověřování zdrojů dat, správě zdrojů dat Power Query, vymazání přihlašovacích údajů, změně umístění zdrojů dat založených na souboru a tvarování dat do tabulky, která vyhovuje vašim požadavkům.  Dotaz Power Query můžete vytvořit taky pomocí jazyka VBA. 

Poznámka: Podívejte se na další oznámení o vylepšeních Excel pro Mac a integraci Power Query.

Další informace o použití starších spojnic k importu dat najdete v tématu Import dat Excel pro Mac (starší verze).

  1. Vyberte Data> Získat data.

    Hlavní tlačítko a nabídka pro získání dat

  2. V dialogovém okně Zvolit zdroj dat – získat data (Power Query) vyberte Excel sešitu nebo Text/CSV.

    Příklad zdrojů dat, které je třeba vybrat v dialogovém okně

  3. Vyberte Procházet a vyhledejte soubor, který chcete připojit jako zdroj dat.

  4. V dialogovém okně Výběr souboru vyberte soubor, zkontrolujte podrobnosti souboru a klikněte na Další. 

  5. Pokud je více než jedna sada dat, vlevo vyberte data, která chcete importovat, a pak vpravo potvrďte výběr v náhledu dat.

  6. Vpravo dole vyberte Načíst.

Výsledek

Importovaná data se zobrazí v novém listu.

Typické výsledky dotazu

Můžete aktualizovat následující zdroje dat: soubory SharePoint, seznamy SharePoint, složky SharePoint, OData, textové soubory nebo soubory CSV, sešity Excel (.xlsx), soubory XML a JSON, místní tabulky a oblasti a Microsoft SQL Server databáze.

První aktualizace

Při prvním pokusu o aktualizaci zdrojů dat založených na souboru v dotazech sešitu bude možná potřeba aktualizovat cestu k souboru.

  1. Vyberte Data,   šipku vedle tlačítka Na získat dataa potom klikněte na Nastavení. Zobrazí se dialogové okno Nastavení zdroje dat.

  2. Vyberte připojení a pak vyberte Změnit cestu k souboru.

  3. V dialogovém okně Cesta k souboru vyberte nové umístění a pak vyberte Získat data.

  4. Vyberte Zavřít.

Aktualizace dalších časů

Aktualizace:

  • Všechny zdroje dat v sešitu vyberte Data > Aktualizovat vše.

  • Konkrétní zdroj dat, klikněte pravým tlačítkem myši na tabulku dotazu na listu a pak vyberte Aktualizovat.

  • Kontingenční tabulka, vyberte buňku v kontingenční tabulce a pak vyberte Analýza kontingenční tabulky > Aktualizovat data.

Při prvním přístupu k SharePoint, SQL Server, OData nebo jiným zdrojům dat, které vyžadují oprávnění, musíte zadat příslušné přihlašovací údaje. Můžete taky vymazat přihlašovací údaje a zadat nové přihlašovací údaje.

Zadání přihlašovacích údajů

Když dotaz aktualizujete poprvé, může se zobrazit dotaz k přihlášení. Vyberte metodu ověřování a zadejte přihlašovací údaje pro připojení ke zdroji dat a pokračujte v aktualizaci.

Pokud je přihlášení povinné, zobrazí se dialogové okno Zadat přihlašovací údaje.

Příklady:

  • SharePoint přihlašovací údaje:

    SharePoint výzvy k zadání přihlašovacích údajů na Macu

  • SQL Server přihlašovací údaje:

    Dialogové SQL Server pro zadání serveru, databáze a přihlašovacích údajů

Vymazání přihlašovacích údajů

  1. Vyberte Data> Data > Data Source Nastavení.

  2. V dialogovém okně Nastavení zdrojedat vyberte připojení, které chcete.

  3. Dole vyberte Vymazat Permissions.

  4. Potvrďte, že se jedná o to, co chcete udělat, a pak vyberte Odstranit.

I když vytváření v Power Query Editoru není v aplikaci Excel pro Mac, jazyk VBA podporuje vytváření Power Query. Přenesení modulu kódu jazyka VBA do souboru z Excel pro Windows Excel pro Mac je dvoukrokový proces. Na konci tohoto oddílu je k dispozici ukázkový program.

První krok: Excel pro Windows

  1. V Excel Windows vyvíjet dotazy pomocí jazyka VBA. Kód jazyka VBA, který používá následující entity v objektovém modelu Excel, funguje také v Excel pro Mac: Queries object, WorkbookQuery object, Workbook.Queries Property.Další informace najdete v tématu Excel jazyka VBA.

  2. V Excel zkontrolujte, jestli je Visual Basic editor otevřený stisknutím kombinace kláves ALT+F11.

  3. Klikněte pravým tlačítkem myši na modul a pak vyberte Exportovat soubor. Zobrazí se dialogové okno Exportovat.

  4. Zadejte název souboru, zkontrolujte, jestli je přípona souboru .bas, a pak vyberte Uložit.

  5. Upload soubor VBA do online služby, aby byl soubor přístupný z Macu.

    Můžete použít Microsoft OneDrive. Další informace najdete v tématu Synchronizace souborů s OneDrive mac OS X.

Krok dva: Excel pro Mac

  1. Stáhněte si soubor VBA do místního souboru, který jste uložili v části Krok 1: Excel pro Windows" a nahrajte ho do online služby.

  2. V Excel pro Mac klikněte na Nástroje> Editoru> Visual Basic maker. Zobrazí se Visual Basic Editor souborů.

  3. Klikněte pravým tlačítkem myši na objekt v okně Project a pak vyberte Importovat soubor. Zobrazí se dialogové okno Importovat soubor.

  4. Vyhledejte soubor VBA a pak vyberte Otevřít.

Ukázkový kód

Tady je základní kód, který můžete přizpůsobit a použít. Toto je ukázkový dotaz, který vytvoří seznam s hodnotami od 1 do 100.

Sub CreateSampleList()
    ActiveWorkbook.Queries.Add Name:="SampleList", Formula:= _
        "let" & vbCr & vbLf & _
            "Source = {1..100}," & vbCr & vbLf & _
            "ConvertedToTable = Table.FromList(Source, Splitter.SplitByNothing(), null, null, ExtraValues.Error)," & vbCr & vbLf & _
            "RenamedColumns = Table.RenameColumns(ConvertedToTable,{{""Column1"", ""ListValues""}})" & vbCr & vbLf & _
        "in" & vbCr & vbLf & _
            "RenamedColumns"
    ActiveWorkbook.Worksheets.Add
    With ActiveSheet.ListObjects.Add(SourceType:=0, Source:= _
        "OLEDB;Provider=Microsoft.Mashup.OleDb.1;Data Source=$Workbook$;Location=SampleList;Extended Properties=""""" _
        , Destination:=Range("$A$1")).QueryTable
        .CommandType = xlCmdSql
        .CommandText = Array("SELECT * FROM [SampleList]")
        .RowNumbers = False
        .FillAdjacentFormulas = False
        .PreserveFormatting = True
        .RefreshOnFileOpen = False
        .BackgroundQuery = True
        .RefreshStyle = xlInsertDeleteCells
        .SavePassword = False
        .SaveData = True
        .AdjustColumnWidth = True
        .RefreshPeriod = 0
        .PreserveColumnInfo = True
        .ListObject.DisplayName = "SampleList"
        .Refresh BackgroundQuery:=False
    End With
End Sub

Viz také

Nápověda pro doplněk Power Query pro Excel

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×