Import dat z Excel, Accessu, SharePoint webů, SQL Server a jiných externích zdrojů

Data můžete rychle importovat a zobrazit přímo na obrazcích v Visio. Prvním krokem je připojení ke zdroji dat a import dat do výkresu. Druhým krokem je propojení importovaných dat s obrazci.

Krok 1: Import dat

V prvním kroku importujte data pomocí Průvodce výběrem dat.

Data, která se zobrazí v okně Externí data, jsou snímek zdrojových dat v době importu. Data ve výkresu můžete aktualizovat tak, aby odpovídala změnám ve zdrojových datech. Zdroj dat ale nemůžete aktualizovat změnou dat ve výkresu. Viz Aktualizace importovaných dat.

  1. Na kartě Data klikněte ve skupině Externí data na možnost Propojit data s obrazci.

  2. Na první stránce Průvodce výběrem dat zvolte, který z následujících typů zdrojů dat chcete použít:

    • Sešit aplikace Microsoft Excel

    • Databáze aplikace Microsoft Access

    • Seznam Microsoft SharePoint Foundation

    • Databáze systému Microsoft SQL Server

    • jiný zdroj dat OLEDB nebo ODBC,

    • dříve vytvořené připojení.

  3. Dokončete zbývající část průvodce.

    Poznámka: Pokud zvolíte jinou možnost než sešit aplikace Excel, accessovou databázi nebo seznam SharePoint na první stránce průvodce, můžete být dočasně přesměrováni do Průvodce datovým připojením v průběhu dokončení Průvodce výběrem dat.

Po kliknutí na Dokončit na poslední stránce Průvodce datovým připojením se zobrazí okno Externí data s importovaná data zobrazená v mřížce.

Krok 2: Propojení řádků dat s obrazci ve výkresu

Existují tři způsoby propojení řádků dat s obrazci ve výkresu: Řádky můžete propojit s existujícími obrazci po jednom, řádky můžete propojit automaticky s obrazci nebo můžete vytvořit obrazce z dat.

Metoda 1: Propojení řádků s existujícími obrazci po jednom

Tento přístup je nejlepší pro existující výkresy s relativně malými obrazci.

  • Přetáhněte řádek z okna externích dat na obrazec ve výkresu.

    Poznámka: Pokud okno Externí data nevidíte, přejděte na kartu Data a ve skupině Zobrazit nebo skrýt zaškrtněte políčko vedle položky Okno externích dat.

    Data se zobrazí v obrazci a nalevo od řádku v okně Externí data se zobrazí ikona odkazu.

    Přetažení řádku na obrazec

    Poznámky: 

    • Jeden řádek můžete propojit s více obrazci, ale nemůžete propojit více řádků s jedním obrazcem.

    • Pokud chcete změnit nebo vylepšit vzhled obrazců a dat, podívejte se na část Vylepšení dat datovými obrázky.

    • Okno Externí data zobrazíte tak, že v nabídce Zobrazení kliknete na Okno externích dat.

Metoda 2: Automatické propojení řádků s existujícími obrazci

Tento přístup je nejlepší pro existující výkresy s velkým počtem obrazců. To funguje jenom v případě, že obrazce už v nich mají data, která můžete porovnat s daty ve zdroji dat.

  1. V Visio 2016 a novějších verzích: V nabídce Data klikněte na Aktualizovat vše a vyberte Automatické propojení po aktualizaci, pokud ještě není zaškrtnuté.

    V Visio 2013 a starších verzích: V nabídce Data klikněte na Automaticky propojit.

  2. Postupujte podle pokynů v Průvodci automatickým propojením.

    Data se zobrazí ve vašich obrazcích. Pokud chcete změnit nebo vylepšit vzhled obrazců a dat, podívejte se na část Vylepšení dat datovými obrázky.

Metoda 3: Vytvoření obrazců z dat

Tento přístup je nejlepší, pokud výkres ještě nemá obrazce a nemusíte používat konkrétní obrazce.

  1. Klikněte na obrazec v podokně Obrazce.

  2. Přetáhněte řádek nebo sadu řádků z okna Externí data do prázdného místa ve výkresu.

    U každého řádku, který přetáhnete do výkresu, se zobrazí jedna instance obrazce, na který kliknete.

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

×